Privilege /Disk Full Error when modifying NSLU2 Shares

Discussion in 'Cisco/Linksys Network Storage Devices' started by fmoli, Mar 1, 2005.

  1. fmoli

    fmoli Guest

    I've been using NSLU2 in a plan network for several months.
    Now suddnely, many of my files (not all files, even in the same share) and directories on my shares are reported as READ-ONLY, and I connot delete/create/modify them.

    WinXP reports Disk Full or insufficient privileges.

    I Checked USER/GROUP Access permeissions, and they're all RW for all users.

    Even the default Administrator can't access them in Write.

    I'm using latest V2.3R29 firmware, with two 80GB Lacie USB 2.0 enclosures (one main, one backup). I perform drive backup, checkdisk and system reboot every night.

    Any suggestion ?
    Do I have to downgrade to R25?

    Many thanks

  2. helsten2

    helsten2 Network Guru Member

    I got the same problem.

    The disk has been working fine for several months, then I suddenly get this access error problem.
    The whole disk has become Read-Only and there is no way to change it.

    I tried remove/add users, remove/add priviliges, downgrade to R25.
    Nothing works.

    Looks like reformatting is the only option .... :(

    F... Shi.... !!!!! All my music, video and pictures will be lost!
  3. helsten2

    helsten2 Network Guru Member

    Reformatted the disk. Worked well for a month (R29). Same problem again!
    What a piece of sh.... ! All my data is lost. AGAIN!

    How can anyone sell such cr...?
  4. helsten2

    helsten2 Network Guru Member

    ... and when I hooked up another disk to rescue the data, I get 'device I/O error' after a few minutes (random) of copying.

  5. helsten2

    helsten2 Network Guru Member

    ... just did a power off of the NSLU2 and both hard-disks.
    When I restarted everything, my second disk is also Read Only
    How can I now resue any data?

    LINKSYS: What kind of testing has been done here? You should at least provide a tool to switch off the Read-Only flag!

  6. irming

    irming Guest

    No reply to this ?

    I have this exact same problem - and could use a solution
  7. helsten2

    helsten2 Network Guru Member

  8. padream

    padream Guest

    I've just had the same problem.
    This is wat I did:
    1. deleted the user (name = windows logon name)
    2. restarted the nslu2
    3. created new user (name = windows logon name), NO PASSWORD
    4. made this user member of 'administrators'
    5. restarted the nslu2
    6. formated HD

    now it seems to work, ik can create en delete files. It seems that the problem started af a firmware upgrade. I'm not sure.
    Hope this helps...
  9. uhu-stick

    uhu-stick Network Guru Member

    same problem !!!!!
    All of a sudden disk is marked read only and 100%full.
    No deletion, creation or modification possible.

    All my data incl the backups ( on mirrored disk ) is gone if I don't get this p.o.s. back in operation.

    Dumped all my various LAN / NAS hardware beginning of 2005 and changed to Linksys products.



    btw Firmware is 2.3R29
  10. rpsmith

    rpsmith Guest

    Confirmed: NSLU2 is close to worthless

    I've had the NSLU2 now for about 9 months. It seems to work fine for about 3 months at a time. Then -- it falls apart.

    Today I discovered that all of the files have been marked "read only". Any attempts to move data onto the disk are greeted with the happy "access denied" error message.

    The only good news is that I discovered this forum and find that I am not alone. I have decided to remove the NSLU2 and am just going to add a disk onto my existing music server.

    Too bad. Product concept makes a lot of sense. But it is totally unreliable for keeping backup data.
  11. uhu-stick

    uhu-stick Network Guru Member

    I got the advice from Linksys tech support to downgrade from R29 to R25 what I did. And....
    immediately I had access to all my files which have been marked read only before.
    Maybe it was luck, maybe there is a real tech reason behind. For the moment I don't care, at least I got time to think about if I'll keep this stuff or not.

  12. kkannank

    kkannank Network Guru Member

    Same story here. NSLU2 with R29 firmware. Everything was running ok then all of a sudden file system marked as read only and getting access is denied for any write operations.

    I know reformatting the HDD will solve the issue but I don't want to go through that whole process.

    Linksys really needs to fix this. I called support and their agent acknowledged it was a known problem and and then proceeded to ask me to power the unit off and on. Give me a break!!

    If anyone knows where to download the older firmware please share. I'd like to try downgrading. The Linksys site only has the R29 firmware.
  13. uhu-stick

    uhu-stick Network Guru Member

  14. helsten2

    helsten2 Network Guru Member

    Well, I downgraded to R25 yesterday and it seemed to be succesfull (everything was working).
    However, R25 also has its problems .... At random intervals (several times each hour) you will get a 'device not found' error when you try to access the disk(s). Some seconds later (10-15) the disk(s) can be accessed again.
    I use the NSLU2 to store audio and video files for streaming. Of course the song or the movie will stop in the middle ...

    I said it before and I say it again:

  15. SANdood

    SANdood Guest

    Caused by I/O errors?

    I suspect that this problem is caused by an I/O error on the drive(s). It seems to me that the NSLU2 is dropping into read-only mode if it gets an error writing to the drive. Rebooting sometimes resets this, as I can usually create a directory right after reboot, but I can't write a lot of files.

    This may be why reformatting helps - bad blocks may be getting mapped out during the process.

    I'm on my second reformat...if the problem crops up again, I'm gonna attempt a dd_rescue of the drive to another and watch for I/O errors in the process. This approach solved I/O error problems with my TiVo - might work for the NSLU2 as well!

    Hope this helps...
  16. excellentdrums

    excellentdrums Network Guru Member

    This worked for me - NSLU2 Write Access Fix, Maybe...

    I've only had it working for about an hour so take this post with a grain of salt. Can't confirm permanent results.

    I had the same issue. Linksys couldn't help me. They told me to call Maxtor (I have a 160GB OneTouch connected to the NSLU2). Neither company was of any assistance. What a crappy experience this has been.

    I fixed it on my own. I am not sure which step did the trick. Might have been one or the other or both.

    1. downgrade to firmware 2.3 R25
    2. Scandisk

    I can't imagine that the scandisk is what fixed it but immediately following the downgrade, I still did not have write access. After the scandisk completed, I was good to go. No reboots or relogins necessary. very strange. Truthfully, I really don't care how it worked as long as I got access to the disk back without having to reformat.

    Anyway, I never posted here before but it was the first place I came when the issue popped up so I figured I would kick in my 2 cents in hopes that it will help someone else.

    Also, I read above that someone said that Linksys took the old firmware off their site. This is true but you can still dig it up on their ftp server. That's where I got it. Here's a link:
  17. mbenita

    mbenita Network Guru Member

    how about unslug?

    I read a lot of those posts and it seems that people have more luck with non-linksys firmwares. i found a lot of information at this site:

    I also got a recommendation to take the disk and mount it on a linux machine. log as root and change all the file (there is a command with a recursive flag) to change all the file permissions. I am no linux expert but it seems to make sense.
    I hope this helps.
  18. kkannank

    kkannank Network Guru Member

    Scandisk worked for me too

    Only had it working for a couple of hours but using the Scandisk utilty in the NSLU2 web admin utility allowed me to write files to my 500 DB Lacie Big Disk again. I'm going to schedule a Scandisk daily and cross my fingers that it doesn't revert back to read only status.

    Thanks for the tip!
  19. phatteus

    phatteus Network Guru Member

    Upgraded to r29 and this started happening to me. I'm locked out of only certain directories & sometimes only the deeper levels. Rolled back to r25 and it opened some (but not all) directories. Scandisk didn't help. My advice would be to stay on r25.
  20. helsten2

    helsten2 Network Guru Member

    Got the Read Only error for the sixth time (in 6 months). And no answer at all from Linksys. That's it - this sh** goes to the bin!!!! I already dumped D-LINK products for poor quality - now LINKSYS goes the same way!!!
    DON'T BUY THIS CR**!!!!!!!
  21. ppcfan

    ppcfan Network Guru Member

    .. with a little help from my friends

    same problem with my Maxtor 300 GB One Touch I.
    The firmware downgrade 29-->25 did not help me.
    So I'm saving a lot of data to other disks at the moment.
    But before I re-format the NSLU2, I want to try to fix the problem.
    My solution way: Start knoppix 3.8 (LINUX) from CD and connect the Maxtor-Disk direct via USB. Investigate some information in the ext-filesystem to find the wrong "permission"-rights and try to correct them.
    Is anybody out there who want to help me ?
    Has anyone experience with such a job ?
    ... standby for any comment.
  22. ppcfan

    ppcfan Network Guru Member

    ..... anybody out there !

    nobody here with some hints for me ?
    Ok, my work for now:
    - connecting the HD via USB to Linux, everything looks good. With root access it's possible to write + delete in the data partition.
    - upgrading the NSLU2 to Unslung V3. Same story: no write access to the HD.

    During my work, I learn that it is possible to add a new user to the NSLU2 but it's not possible to add (write) a new share for him.

    I repeat my invitation: please help me.
  23. techmanblues

    techmanblues Network Guru Member

    I have this problem as well, but only sporatically. Fortunately, I use the NSLU2 to access a backup drive only and after reading about this issue, I will remain using it as a backup. So when worse comes to worse, I can simply reformat the drive.

    Read-only means you can open the files and able to copy it, right? Therefore how can you lose the data if the files are read-only? I am from the Windows world where read only is just that. Cannot be deleted and modified, but can be copied.

    Could this be a problem with the ext3 file format? Why would Linksys chose this rarely used file format instead of a universally accessible FAT32 is a mystery. Ok, so FAT32 does not offer security like NTFS and ext3, but Linksys should give the users the option to format one or the other.
  24. techmanblues

    techmanblues Network Guru Member

    Re: .. with a little help from my friends

    I used the Knoppix 3.8 CD boot and it did not offer the choice the change permissions at all. But there was no need anyway since Knoppix told me that everyone has full permissions! The icons of the files on the ext3 drive has this lock on it which I assume is translated as read-only in Knoppix world. I cannot even create a directory to the drive or copy any of the files to a FAT32 partitions using Knoppix. I would think that since the OS in the NSLU2 is Linux-based, why would Knoppix have problem opening, copying, and creating files from the ext3 drive?

    Weird problem indeed. I am not sure who is to blame here with this read-only problem.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice