Problem accessing Linksys Router w/Tomato via HTTP

Discussion in 'Tomato Firmware' started by massong, Jan 23, 2008.

  1. massong

    massong Guest

    I am unable to access my Linksys Router w/Tomato running on it via HTTP any longer.

    Everything was working fine until I recently (briefly) enabled remote WAN access in Tomato to show it to a friend on port 8080, that all went fine. I then disabled remote access to shut out anyone from the outside access my router.

    At this point I'm not sure if I had tried to access the firmware on the LAN interface, I'm guessing that I did not, but not 100% sure. I think what I may have done is somehow totally disabled all HTTP access to the linksys router.

    That was 3 or 4 days ago, things have been (and still are) running fine as far as day to day use of my Internet connection that I run through my linksys w/tomato, however, tonight I tried to access the linksys router w/Tomato via http and it's failing to connect (it times out).

    I am still able to telnet to the linksys router and I can log into the Tomato linux console using my admin username & password. However, now that I am able to access it from command line I really don't know where to go to find the configuration file to make sure I didn't somehow accidentally disable HTTP access totally so that I can re-enable it.

    Can you please tell me where I could find that configuration file or give me any other suggestions.

  2. mstombs

    mstombs Network Guru Member


    It is possible to start another web daemon on another port, but I'm not sure of the command

    The rule that will be blocking you access will be visible with the commands

    iptables -L -vn
    iptables -L -vn -t nat

    probably in the PREROUTING chain

    but I suspect you are better off using the little reset button on the back and setting it all up again.
  3. ytsejam

    ytsejam Network Guru Member

  4. dakotageek

    dakotageek LI Guru Member

    If you enabled SSH to the router, you should be able to connect to it using that ro see changes that mstombs is talking about. Otherwise, I believe that telnet is enabled by default and you should also be able to use that to connect, but if it is enabled I suggest turning it off once you get things straightened out and us SSH instead.

    If all else fails, you could just go about clearing the NVRAM using your routers reset button. I know that this sucks if you don't have your configuration setup correctly, but at least you get back into your router if somehow changes were made that you were unaware of. Once the NVRAM is cleared you should be able to set it up just like you did previously.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice