Problem after recovering from bad flash

Discussion in 'DD-WRT Firmware' started by Surray, Aug 26, 2008.

  1. Surray

    Surray Addicted to LI Member

    Hey there :)

    I got a WRT54GL and decided to flash it with DD-WRT... I screwed up though and bricked it. After trying to find a solution all day I finally managed to get the default firmware back on there using tftp and grounding pin 16 on the flash chip.

    So that apparentlywent fine, I got this message:

    C:\>tftp -i PUT WRT54GL.bin
    Transfer successful: 2937856 bytes in 12 second(s), 244821 bytes/s

    I can now log back into my router. It seems to work but whenever I click a button to apply settings or start a firmware upgrade (for switching back to ddwrt, this time without bricking it :p ) I get a browser error page saying 'Connection Interrupted' and nothing happens. The address bar shows the cgi script of what was supposed to happen, like "" when I try to upgrade the firmware.

    I have tried a hard reset (30 seconds of holding the reset button) as well as a 30/30/30 reset and nothing seems to help.

    Does anyone have an idea of what could cause this or what I could try to fix it?

    here is a picture of what it looks like. It happens when I click the button to reset to factory defaults, or apply new firmware, and even happens when I switch from the standard WAN setup 'DHCP' to 'PPTP' in the dropdown list. In some other cases, the page is simply blank instead.

  2. Surray

    Surray Addicted to LI Member

    Hmm! It works now!

    I disconnected the WRT54GL from power yesterday before I went to sleep, and when I tried it again today it worked fine. Was now able to re-flash a custom firmware and it's working great now!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice