Problem after upgrading to tofo 12

Discussion in 'HyperWRT Firmware' started by bboehmei, Jan 9, 2006.

  1. bboehmei

    bboehmei Network Guru Member

    I have a wrt54gl and I upgraded it to tofu 11. Everything worked fine and tonight I put tofu 12 on it. I follow all the steps in the readme. Cleared NVRAM and all after upgrade. But everything I type in anything in the fields it jumps to page. But there is no buttons, just a blank page. So basically I can't change anything. Is there anyonelse out there who seen this problem or have a fix for it? I had load up tofo 11 back.
  2. dirtyclyde

    dirtyclyde Network Guru Member

    Upgrade 2 WRT54G v4 from 11 to 12 OK, no problems! Seems to be running great! on both!
  3. NateHoy

    NateHoy Network Guru Member

    I have a WRT54G V4 (identical to a WRT54GL), which was running Tofu 10. Here's what I did.

    1. Unplugged my cable modem and removed all network devices but one from my WRT54G.
    2. Ran command "ERASE NVRAM; REBOOT", logged in using "admin"/"admin", and verified that the router had wiped all my settings.
    3. Restarted router one last time (unplugged power, plugged back in).
    4. IPCONFIG /RENEW from client to make sure lease was fresh.
    5. Flashed router with Tofu 12. Waited a couple of minutes to make sure the firmware was applied.
    6. Went into "Administration"/"Factory Defaults" and did "Clear NVRAM, restore factory defaults"
    7. Manually keyed all of my settings.

    Worked like a charm.

    So the apply.cgi page just comes up as a blank page? It does for me, as well, if I key it in directly into a web browser. So I assume there are some session variables that are not being passed along.

    Did you do a factory reset (administration / factory defaults) to make sure all the settings were initialized properly?
  4. bboehmei

    bboehmei Network Guru Member

    Yeah I loaded the factory defaults. Let me see if I can describe it better. After doing the upgrade I try to use the pull down menu to select PPPoE. Right away I get that apply.cgi blank page. So I refesh the page and the selection hasn't taken. Or if I type in say a new name for the router, the movement I try to save the setting it goes to the apply.cgi. Login to the page again and the name hasn't been saved.
  5. robsonn

    robsonn Network Guru Member

    Maybe try to use another web browser. Specific version of Opera or FF might have some problems. Try in IE if here works then change altenative browser. If you still have problems then reflash it again - this should help. If you cant upgrade via www then you must use TFTP.
    I always flash firmware with below steps:
    1. Restore factory defaults
    2. reset computer to renew lease
    3. upgrade
    4. reset to factory defaults and claer nvram
    5. set configuration manualy
  6. pharma

    pharma Network Guru Member

    If you take a look at Tofu's readme you'll see some additional variables he added to help people with Opera or Firefox issues:

    NVRAM -- Additional variables used in this firmware

    capfix 0, 1 On some browsers like Opera, the text "Capture()" is displayed instead of the correct one. This variable enables a work-around to the problem.

    noffx 0, 1 In Firefox 1.0.x, drop-down listboxes are not displayed properly if the last item is selected when the page loads. This enables a work-around for that problem.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice