Problem: Firmware tab and Backup tab disabled, STP broken IP

Discussion in 'DD-WRT Firmware' started by DevilStick, Feb 10, 2006.

  1. DevilStick

    DevilStick Network Guru Member


    Yesterday I updated my WRT54G from DD-WRT 22 Std to DD-WRT 23 VoIP image via webinterface.

    After the first boot with firmware default values, everything looks ok. Firmware and backup tab are enabled. But as soon as I make changes in IP configuration, after next reboot those two tabs are white instead cyan and cannot be opened any more.

    What could be the reason? I accidently used the voip.wrt54g.bin image instead of the generic one as suggested for web update. But after a 2nd try the image was successfully applied. I even reset the system later to defaults which causes firmware and backup tab to work again and loaded the generic voip image.

    But there is still the same problem when I save any changes.

    There is another strange effect. I changed IP address on LAN side, but the STP hello packets are still sent with default address? (I run ethereal on a pc to watch STP packets)

    Another thing where I do not know whether this is normal or also a problem is my full jffs2 filesystem. Does WRT54G have so little flash that the voip image only leaves 320K left?

    The jffs2-fs gets mounted rw, but I cannot even touch an empty file, since I get a 'file system full' message. But with 320K free space it should be possible to create an empty file, shouldn't it?

    I there a way to completely reset my WRT54G including jffs2? Or are there any known bugs?
  2. AliM

    AliM Network Guru Member

    Firmware and backup tab are disabled in https mode, use http mode for firmware upgrade.

    If you want tu use jffs on g router, you must use mini version of the firmware.
  3. DevilStick

    DevilStick Network Guru Member

    Thanx for this information. I understand the reason for disabling firmware upgrades via https, but why are backups disabled? I do not think that https transfer would be such critical for config files.

    What about the Spanning tree issue? Are there known bugs? I have a WRT54GS running with 23-mini image and the address used for STP hello packets is correct, but the WRT54G with voip image uses as STP address.

    I think this is the reason why STP dows not work correct in my environment. I have a WPA2-PSK secured WDS-Bridge running and as soon as I create a loop via wired interfaces, a topology change packet is created, but network traffic is impacted until I remove the loop.

    I would expect the WDS interface to be blocked and traffic should be transmitted via the wire ports which should have less costs fpr STP.

    Which process is responsible for STP and which nvram settings are influecing it? Maybe I can try a manual fix.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice