Problem logging to CIFS

Discussion in 'Tomato Firmware' started by SilverXJ, Feb 2, 2008.

  1. SilverXJ

    SilverXJ Guest

    I have tried to send the logs to my CIFS1 share using the scripts in this thread:

    However it doesn't seem to work. CIFS1 is working because the bandwidth logging is working. It appears that the msg2cifsmsg is not running even though it is set to run in the CIFS1 client config (Execute when mounted: /cifs1/msg2cifsmsg). The client is running XP SP2

    If I telnet in and run the lines in the msg2cifsmsg script manually it appears to work as an ls -al gets me this:
    # ls -al
    drwxr-xr-x    1 root     root            0 Dec 31  1969 .
    drwxr-xr-x    1 root     root            0 Dec 31  1969 ..
    lrwxrwxrwx    1 root     root           17 Feb  2 11:55 messages -> /cifs1/GLmes
    I can also access cifs1 via telnet.

    The only reference to cifs in the log I see is this:

    Dec 31 19:00:08 mount-cifs[108]: notice: Mounting...
    Any ideas?
  2. dakotageek

    dakotageek LI Guru Member

    When I tried the script, I got it to work for a little while, but then the logs rotated on me. This resulted in moving the symbolic linked file from 'message' to 'message.o'. The system then creates a new 'message' file that then will get moved over the symbolic linked file.

    So, short of using a symbolic link on the actual log directory, I don't think that this method is going to work unless you make the log directory symbolically linked to the remote share. That would be a big mistake though I am sure as it would probably mess with the system. The only other option would be to take and get some type of job to watch for the logs getting rotated and then push the files to the remote share.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice