Problem using with cable. (comcast I think)

Discussion in 'Tomato Firmware' started by Trel, Mar 9, 2008.

  1. Trel

    Trel LI Guru Member

    A friend got a WRT54GL and put Tomato on it. I hooked it up to the cable modem, and it worked fine. It's using DHCP as it's connection method. However, it seems to periodically "disconnect". The only way I've been able to make it re-connect is to go to basic config and save the settings. Is there anything else I'd be able to do to prevent this?
  2. pharma

    pharma Network Guru Member

    I've been using different versions of Tomato with Comcast cable for about 1.5 years with NO disconnect problems. I'm also using DHCP and my WRT54G is connected to the cable modem. I'd suggest just using the default Tomato firmware settings until you become "really" familiar with the different parameters.

    To troubleshoot your Comcast disconnect problems:

    1. Most of the time the splitter or cable connection is defective. While you can do some of the troubleshooting yourself, like replacing splitters and cable ends, Comcast will be more than happy to come do it for you.

    2. If you are using a wireless adapter, check your wireless adapter settings in Windows. In the past many of my wireless issues were solved by changing some the wireless adapter parameters. A google search will reveal what the different parameters mean, but I believe there is also a Guide at this website (I believe Toxic wrote it).

    Using Comcast's automated voice menu system call your local number and navigate through the Comcast menu system to have Comcast send a signal to reboot your modem. You can do this a few times (sometimes it will take a few reboot signals) until your modem lights are correctly lit. If you still have problems, I'd call Comcast for a visit.

  3. Trel

    Trel LI Guru Member

    The thing is if the connection is being used, it doesn't happen. It only happens when the connection idles.
  4. Trel

    Trel LI Guru Member

    It happened again. Power cycling the router had no effect, but as soon as they went to basic configuration (network section) and hit save without changing anything, the connection came back.
  5. Macskeeball

    Macskeeball LI Guru Member

    Basic -> Network

    Is Connect Mode set to Keep Alive?
  6. Trel

    Trel LI Guru Member

    I said this is on cable using DHCP. Keep Alive isn't an option with DHCP.
  7. kevanj

    kevanj LI Guru Member

    Did you do have the router configured using the stock firmware before you flashed Tomato? If so, did you do an NVRAM reset after you flashed Tomato?

    Odd behavior is often cured by resetting NVRAM, and reconfiguring, especially after flashing from one firmware to another.
  8. gatchel

    gatchel LI Guru Member

    I would say to reset your NVRAM, reconfig, and see what happens.
    I have comcast with no issues on ver 1.15.
  9. Trel

    Trel LI Guru Member

    Started as a brand new router out of the box.
    After flashing, I both reset with the button and cleared the nvram.
  10. pharma

    pharma Network Guru Member

    Really sounds like a cable problem ... either outside coming in or somewhere inside the house. Have comcast come to check the signal strength to the modem and through the cables ...
  11. Trel

    Trel LI Guru Member

    Why would it only happen with the router in place, and why would simply saving the settings fix it 100% of the times it happens?
  12. pharma

    pharma Network Guru Member

    I'd rather ask why isn't the same thing happening to everyone else who is using a similar router and Tomato firmware? I don't see any threads with this type of bizarre behavior -- usually points to something in your setup or connections. IT is possible your do have a bad connection or router ... as I mentioned above I have basically the same router, using Comcast Cable with DHCP and experience none of your disconnect problems. Two years ago I had some disconnect/connectivity problems and had Comcast come out ... they did some tests and replaced the connections at the end of the cable wire with newer, better quality ones. Haven't had any problems since.

    Have you tried calling your local Comcast number and used their automated phone menu system to send a modem reset signal? Or tried any troubleshooting beyond looking at your router?

  13. Trel

    Trel LI Guru Member

    They had a power outage recently and as it happened they were unable to connnect until they saved the settings again.

    The modem was on, and the router was on. For some reason, it just wasn't connecting until they hit save on the connection settings.

    This is bothering me, the only conclusion I can draw is that Tomato is not re connecting, even though it's set to DHCP until it's saved.

    (Also, when the power came back on, both the modem and router came up fine, but the internet was not usable until going into the connection settings and hitting save (not changing anything))
  14. Trel

    Trel LI Guru Member

    I have a friend with the same model router but with stock firmware who was going to be putting tomato on. I convinced him to let me borrow it before he did. I put that in the setup of the person with the problem and it worked fine and as expected.

    Afterwards, we put tomato on it, and cleared nvram and reset with the button, it then had the same problem. (and the same "fix") It's definitely something with tomato.
  15. pharma

    pharma Network Guru Member

    Inside the Tomato menus, under Administration --> Configuration there is a drop-down menu where you can "Erase all Data in Nvram" everything. Try that and when it has finished rebooting only change the parameters necessary to connect to the internet.

    If that doesn't work, try another firmware like DD-WRT or even the stock firmware.

    You still haven't mentioned whether you are using a wireless adapter, or if you connect the router directly to your computer using a cable. If you are using wireless then it's probably a problem with the computer wireless adapter settings, the router's wireless settings or both. Also try connecting the router directly to the computer using a cable.
  16. Trel

    Trel LI Guru Member

    Well I just said in the post right before yours I tried it with the stock firmware (and it worked fine) and then I tried putting tomato on it (AND erased the nvram BOTH with the option in tomato and by resetting to defaults using the button).

    Once again when I have the problem, it is fixed by using the router interface going to the basic->network screen and hitting save.

    This happens regardless of using a wired or wireless connection.

    (I really feel like I'm going in circles here :\ )
  17. likuidkewl

    likuidkewl Network Guru Member

    @Trel - Being short with folks will not get you too far. You are asking for help, if it too much trouble for you to install Tomato on the WRT54GL's then as stated previously install another FW or keep the stock.
    As for going in circles, yes you seem to be going in circles and this is unfortunate but you must take steps to try to sort out your issues, others are not at your machines.

    If you have access to these routers physically try to SSH into the router the next time this happens and manually try to reset the network service and see if for some reason that is not being restarted. Also have a look at /var/log/messages and post it here the next time it happens.
  18. LLigetfa

    LLigetfa LI Guru Member

    The GL is the most popular router with 36% of polled Tomato users. You have found a very unique set of circumstances that you've been able to repro but nobody else can.

    You will need to look at what is unique with that setup and then trying to change things out to narrow it down.
  19. Trel

    Trel LI Guru Member

    Well I don't live at the affect place and it only happens upon losing power (either unplugged or what), is either a service isn't starting right, or something's up with using DHCP with everything else at defaults.

    I personally still use 1.11 because I had PPPoE disconnect issues with 1.14 and never got a concrete answer if it was fixed in higher versions. I wonder if it's related. Unless I find something obvious next time I'm there (and I will try to ssh to it next time I'm there), I'll try putting 1.11 on it to see if it works better.

    Also, I wasn't being short, it was just that I said the answers to exactly what he asked in the post directly before it was asked. (I even used the same terminology such as saying "stock firmware" and not default, so it's not like I was vague)

    Anyway, I'll also make note of what brand their cable modem is to see if maybe it's some conflict.
  20. pharma

    pharma Network Guru Member

    What I meant was for you to go back and use the whatever was working for you in the past .... whether it's stock firmware or another firmware (DD-WRT). It's obvious Tomato 1.17 is not working for your setup.

  21. Trel

    Trel LI Guru Member

    I'm sorry then. I thought you were telling me to try other firmware to see if it worked in those (as a way to narrow down the problem) and not to use one.
  22. likuidkewl

    likuidkewl Network Guru Member

    This sounds like the router is trying to bring up the WAN interface and that the modem is not responding in time.

    -----For further troubleshooting-------
    Q: When you say "lose power" you mean an outage when both are out right?
    Q2: What happens when you pull power to only the router and not the modem?

    I would suggest grabbing the log file when this happens, note the /var/log/messages file gets wiped on a regular basis to keep the logging RAM usage to a minimum.
    So I would the next time you are over there pull the plug on both the units, immediately asap login via ssh or the web interface and copy the log. Then do the same only killing the power to the router.

  23. Trel

    Trel LI Guru Member

    Well I can't get access to it for some time, but I can tell you, it does happen if only the router loses power. If your guess is correct, is there something I can do to the router to make it wait longer for the response?
  24. likuidkewl

    likuidkewl Network Guru Member

    You could start by adding a script that sleeps for say 30-60 seconds and then restarts the wan interface in the init section.

    sleep 30
    service wan restart
    You can do this from a ssh session to make it happen when you want and see the messages log right after.

    service wan restart && tail -f /var/log/messages
    ctrl-c kills the tail

    After looking into this issue, I see some others are having this issue also. If the above doesn't fix it I would install 1.15 on them. I am still using 1.15 and it works fine. :)
  25. Trel

    Trel LI Guru Member

    When I go there next (or they call about the problem) I will try the init version and then have them power cycle. Hopefully that's the problem as that's an easy enough fix.
  26. kevanj

    kevanj LI Guru Member

    Shot in the (not quite) dark.....

    Trel, on the Advanced....DHCP/DNS page of Tomato, what is the DHCP Client ... Reduce Packet Size setting? Checked or Unchecked?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice