Problem with BEFSR41 v4 router

Discussion in 'Other Linksys Equipment' started by dds0021, Nov 20, 2008.

  1. dds0021

    dds0021 Guest

    Ive had the BEFSR41 v4 router for a few years and it has always worked fine.

    My service provider (charter) did some maintenance in the area slowing my connection down. The next day still the same, except the maintenance was done. I reset everything numerous times, but still both comps on my router (PC and a MAC) were slow. I then directly connected my mac to the cable modem and the connection was fine. I asked a tech friend if he could help me and he said to install the new firmware (1.04.09). So I booted up the PC, followed the instructions and installed the firmware. Then I tried to install it again to make sure... except it said it now couldn't find the connection. Apparently, both computers wouldn't even recognize the router now. The power button also started blinking. I called tech support and they said to hold down the restart button for 30sec, did it and still nothing. Did the firmware update cook the router? or is it something else...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice