Problem with DHCP Lease Drops

Discussion in 'Tomato Firmware' started by efmw1198, Aug 4, 2009.

  1. efmw1198

    efmw1198 Addicted to LI Member

    My WRT54GL v1.1 (running Victek’s mod of Tomato Firmware v1.25.8025 .2-RAF STD) is hooked up directly to my cable modem (SB5101) and as far as I can tell, that connection appears to be solid. I am using the DHCP server on the WRT54GL to assign dynamic IP address in the to range. The router appears to assign an IP address to all devices that I’ve connected to it and they can all access the internet.

    The problem is that two devices (Airave from Sprint and an Xbox) seem to periodically lose IP leases with the router then reconnect right away. For the Airave (a femtocell) this is causing problems because it doesn’t keep the IP lease long enough to properly initialize. The DHCP client in the router is configured for 1 day IP leases, but when I monitor the “Device List†page, the lease count down starts at 24 hours and never makes it longer than 7-10 minutes before starting at 24 hours again. Same thing for the Xbox (try to stream a Netflix movie on the Xbox and the xbox freezes after about 10 minutes).

    The thing is that my PC and a different VOIP router that are also connected to the router appear to be rock solid. They renew their lease every 24 hours as they should.

    All connections are wired connections at this point – no wireless. I’ve tried removing everything from the network so that only the Airave is connected to the router and that didn’t help. I tried assigning the Airave a static IP through the router based on the Airave’s MAC address (Airave is a black box and can’t change config within it) – and that didn’t help.

    I’ve tried older Tomato firmware versions (v1.23) to see if they were any more stable. I always run the “Erase all data in NVRAM memory) option after flashing with a different firmware. I've power-cycled the entire network and brought each device up one at a time - no beans. I have even disabled the wireless client just to eliminate that.

    The following activity appears in the log whenever I see the Xbox or Airave restart their IP lease:

    Aug 3 14:02:22 unknown dnsmasq-dhcp[99]: DHCPDISCOVER(br0) 00:16:32:91:47:81
    Aug 3 14:02:22 unknown dnsmasq-dhcp[99]: DHCPOFFER(br0) 00:16:32:91:47:81
    Aug 3 14:02:22 unknown dnsmasq-dhcp[99]: DHCPREQUEST(br0) 00:16:32:91:47:81
    Aug 3 14:02:22 unknown dnsmasq-dhcp[99]: DHCPACK(br0) 00:16:32:91:47:81

    And, perhaps related, I see something like this every 2 hours:
    Aug 3 15:11:35 unknown udhcpc[291]: Sending renew...
    Aug 3 15:11:36 unknown udhcpc[291]: Lease of 68.115.33.XXX obtained, lease time 14400

    I've tried many, many google searches and haven't found anything helpful. So, I thought that I would turn to the wisdom of this group.

    Any thoughts on what might be going on? Anything that I should do in order to further troubleshoot this?

    …be gentle with me – I am pretty tech savvy but fairly new to networking but learning lots while trying to troubleshoot this. So, try not to use too many big words. :)
  2. mstombs

    mstombs Network Guru Member

    BusyBox udhcpc is the dhcp client on the WAN side - it looks like it it is renewing cleanly as normal when 50% of lease lost. dnsmasq is the dhcp server the LAN side.

    The problem on the LAN side is that your clients are not happy and are trying to renew to fix the problem. There is no protocol for the server to inform the client the lease is revoked, but I know windows XP and a Wii seem to generate lots of renews, presumably everytime their connection is slow they check they are still using the correct IP.

    I am not familiar with your problem devices - do they need upnp enabled, custom port forwards, nat helpers enabled for example?
  3. FattysGoneWild

    FattysGoneWild LI Guru Member

    Static DHCP will do the trick with the Xbox. Not sure about the other. You can try it as well if you like. Running the same setup as you just about accept with out the phone part. No issues at all. Enable UPnP as well in the router. It will forward the required ports for the 360 and always give you a open nat when playing or using live in general.



    Just read the post again. It is 3 in the morning here after all and missed the static part that you have tried. Now when you say you assigned a static ip. Just to make sure. Since it seems you are using the stock settings for dhcp. Did you give the addresses like this:


    I can tell you 100% that method works with the 360 and UPnP enabled.
  4. efmw1198

    efmw1198 Addicted to LI Member

    I am using mostly stock settings. UPnP is enabled but NAT-PMP is not enabled like it is on your screenshot. Should it be? As for the rest of the settings in your screenshot, I do not have those in my version.

    I know how to configure my Xbox to request a static IP address but my Xbox is my lower priority right now - I was mainly throwing that out there to suggest that perhaps something is wrong with the router. It has always worked getting a dynamic IP address in the past though on other routers. But, I'll try that for the xbox to see if that helps. Unfortunately for the Airave, that is a black box and you can't change any settings within it. I know from experience dealing with Sprint's 2nd tier tech support that it can only be configured to accept a dynamic IP address so there isn't much i can do there. I was using the "Static DHCP" settings within the router to assign a static IP address to the MAC address of the Airave so that it was always assigned the same IP address - that way i could place it in the DMZ to see if that would help. The static IP addresses that I used were outside of the dynamic IP address range (ex. - other than that, shouldn't make a difference - right?

    And, to mstombs, all 4 of the "Tracking/NAT Helpers" checkboxes are checked - I haven't touched those settings though so they must be set by default. And, on the "DHCP/DNS" tab, "Use Internal Caching DNS Forwarder" is checked, "Use Received DNS With Static DNS" and "Intercept DNS Port" are unchecked.

    I've been able to get the Airave to work if I hook it directy up to the cable modem. It also works when I use one of my older wireless routers that I am trying to replace. It is fairly plug n play with the older routers with their default settings. But, for the life of me, I can't get it to work through the WRT54GL w/ Tomato. Seeing as Tomato gives me WAY more options than my older routers, I would hope that there is some way to get it to work.

    The Airave is my primary concern right now as we have almost no cellphone signal in our house without it our cell phones die pretty quickly searching for signals. So, I really want to get that box working.
  5. mstombs

    mstombs Network Guru Member

    The Sprint FAQ includes this:-

    but assigning DMZ should have allowed those incoming. Port 53 is DNS, so perhaps its just that your AIRAVE does not work with the dnsmasq caching on the router. Some other routers just have dns proxy which just passes on requests.
  6. efmw1198

    efmw1198 Addicted to LI Member

    I have tried placing the Airave in the DMZ and that didn't help. I was still seeing the IP leases getting reset every 7-10 minutes along with the same entries in the log mentioned in the original post. It wasn't able to establish it's connections with Sprint's servers. At first I was concentrating on the Airave, but when I saw the exact same behavior with the xbox, that is what led me to believe that the problem is with the router. And, when I saw the Xbox freeze while streaming a Netflix movie at the same time that it's IP lease was rest by the router, that makes me believe that the same thing is happening for the Airave.

    As for the dnsmasq caching on the router, if I uncheck the "Use Internal Caching DNS Forwarder" setting, is that the setting that will turn off the dnsmasq caching functionality? Are there any downsides to doing so? Any other settings related to dnsmasq that I should look at?
  7. efmw1198

    efmw1198 Addicted to LI Member

    Well, here is what I have tried today:

    I tried unchecking the "Use Internal Caching DNS Forwarder" setting and that did not work. I tried increasing the dnsmasq cache-size to 8192 using the Advanced > DHCP / DNS > Custom Configuration setting, that didn't work either. I tried changing the Advanced > Firewall > NAT Loopback setting to "Disabled" and that didn't work (the default appears to be "Forwarded Only" and that didn't work either.

    Sprint's level 2 Airave technicians even logged into the Airave to make some sort of change (they didn't provide details) and those changes didn't work.

    Lastly, I went to configure my Xbox to request a fixed IP address instead of a dynamic one and luck me - it finally hit the "red ring of death" :mad: (This is just not my week).

    Any other thoughts? Is it possible that I have a defective WRT54GL - or it more than likely a firmware thing?
  8. efmw1198

    efmw1198 Addicted to LI Member

    Well, things are now working. I think we have a case of the stars aligning – on the day that I decided to install my new WRT54GL w/ Tomato , Sprint’s Airave servers (the ones that the individual Airave devices phone home to) and my Xbox decided to take a crap – woe is me :). So, all the DHCPDISCOVER, DHCPOFFER, DHCPREQUEST, and DHCPACK activity in the log (along with the LAN-side DHCP lease drops) appears to be a sign that the device connecting to the Tomato router is not happy.

    When I logged into the Xbox to try to assign it a static IP – it said that it said that its IP address was something like yet the router said that it was Unfortunately it died a few minutes after that so I was not able to investigate further. The Airave tech support mentioned that they did make some sort of change to the Airave and I wonder if it too was stuck trying to get the same IP address that it used from the previous router – something like 192.168.0.XXX instead of the 192.168.1.XXX one that the new router was trying to assign. Just throwing out some guesses.

    Anyway, the Airave works with the default config options available in Tomato. I’ve been able to turn on QoS, configure it to use the OpenDNS servers, and make numerous other tweaks for some of the other devices on my network and the Airave is still happy. So, if anyone in the future is having similar troubles with Tomato and their Airave device, rest assured that the device does work with the WRT54GL router w/ the Tomato firmware - and the default config should work. If you see similar problems, I would start with Sprint’s Airave support (they are actually pretty good once you get to the point where their 2nd tier support is involved) and have them check things on their side first. And, lastly be patient – it took almost a full hour for the Airave to phone home and successfully connect after Sprint did their magic.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice