Problem with my WAG54GX2 SRX200 Gateway

Discussion in 'Other Linksys Equipment' started by AdamPD, Feb 14, 2006.

  1. AdamPD

    AdamPD Network Guru Member

    Hello all

    I've been having this issue for sometime, herein lies the problem

    When using the router with the standard, nonsecured setup, everything works fine, until I try and enable security.

    I allways use AES and in the past have had no problem with it
    But, now when I enabled it, then save changed, I and my brother get disconnected and can no longer connect to the router AT ALL
    Even though it prompts for the password, it just wont connect

    I've double checked all the network settings, all are ok, but to no avail

    I've tried WPA Persona, WPA Personal 2 and WPA Mixed, none work

    The only way to get back into the router, is to literally reset it by holding down the button for 30 seconds

    So I'm now running on a Zoom X6 ADSL router (Yeuck) because I don't like using an unsecure network.

    Any tips?
  2. icest0rm

    icest0rm Network Guru Member

    have your tried TKIP insteat of AES?
  3. marca56

    marca56 Network Guru Member


    Just use WPA and TKIP. It works.

    I've found that WPA2, WPA2-Mixed and anything requiring AES is broken.

  4. Amoebe

    Amoebe Network Guru Member

    Marc / Adam --

    Have the same problem here. I own my WAG54X2 since a couple of days and have problems with XP SP2 (with Hotfix for WPA2 support) using AES on WLAN. Have found Windows Update not able to connect to its website (it runs upto the "checking for updates" animation, but then returns an error code) and my connection to my Website-FTP-Server via SmartFTP will drop when trying to upload data.

    Living in Zurich, I have placed a claim at Linksys Switzerland support (maybe identical to Germany). First they told me to check with Microsoft, as it seems to be a XP bug. I told them now, that do not believe that this is an operating system issue, it seems to me that there is something wrong with the AES implementation in the hardware (firmware 1.00.01).

    As the AES encryption feature is new and most WLAN user will use WPA-TKIP or WEP, I think that this bug has not been discovered yet by many users. Living in Zurich, I have to secure my WLAN as much as possible and bought this hardware as it is able of WPA2 encryption.

    The errors have been reproduced with two different laptops (Acer Travelmate 4001 / 2200BG Intel WLAN / XP2 + Hotfix and Samsung X50 / 2200BG Intel WLAN / XP2 + Hotfix). Same troubles on both machines (and the Acer is 1 year old, Samsung is 2 months - can't be coincedence).

    Please contact your local support with this issue. I can pass you the contact & name of Linksys Switzerland, if you want to tell them the same story I did. Hope they can fix this soon.

    Best regards from Switzerland,
  5. marca56

    marca56 Network Guru Member

    No, Amoebe, it's not a chip bug. It's not a WindowsXP bug either.

    I've actually confirmed the software bug in WPA2 code with my friends at the ODM and Airgo.

    Just use WPA+TKIP and all will be fine.

  6. Amoebe

    Amoebe Network Guru Member

    Hi Marc

    Do I understand it correctly, that the bug is in the firmware AES implementation ? If it is not Windows XP and not the hardware itself, it must be the firmware ?

    Best regards,
  7. freesailor

    freesailor Network Guru Member

    I own a WAG54GX2 Annex A, with the current firmware 1.00.01, and I've found no problem with AES encryption.
    It works fine for me, both on WPA-Personal and WPA2-Personal (I didn't tested WPA2-Mixed).

    I've tested AES on WPA and WPA2 with two wireless network adapter:
    - Intel PRO 2100 (801.11b), built-in on my Centrino notebook Acer TravelMate 803LMi; firmware version:
    - Linksys WPC54GX (801.11g and SRX), installed on the same notebook

    No problem for me with AES, with both network adapters.

    Notebook O.S. is Windows XP Professional SP2, with hotfix for WPA2.

    I think I didn't applied any particular wireless setting to the router, the only thing being having changed the transmission channel from 11 (default) to 7, due to interference on channel 11 from another wi-fi network in the neighborhood (this has nothing to do with AES, the other network bothered me, preventing connections, even in unprotected mode).
  8. marca56

    marca56 Network Guru Member


    It's a confirmed bug in the software AES implementation.


    I didn't say it would not work or even work fine, but some applications definitely won't work properly. In my case, I could surf the net, VPN to my company's intranet, but MSN Messenger and MSN Explorer could never connect.

  9. freesailor

    freesailor Network Guru Member

    Quite strange and inconsistent behaviour, thinking about an implementation bug ... :???:
    It would seem to me more likely related to different level of Windows update (patches applied, fixes, etc.), but ... :?

    So far, I have found no problem at all (not even with MSN Messenger).
    I've asked to a couple of friends on another forum and they are perfectly fine with AES on WAG54GX2, too.
    Maybe we need more time to find the bug on some apps or ... maybe we are just lucky! :)
  10. Amoebe

    Amoebe Network Guru Member

    You name it, Freesailor !

    As Marc stated correctly, it seems only a few applications are affected (for me it's the Windows Update, my FTP client and a forum, where I cannot post, if WPA AES is activated). There rest works fine, homebanking, surfing the internet or email.

    Recently got info from Linksys-support in Germany, they tried to follow up this problem, but with their PCMCIA-cards and their WAG54GX2 the problems (tested on the Windows Update) did not show up. But here it is still not working on (meanwhile) three Laptops all of different age.

    This is really strange... :cry:
  11. billis

    billis Guest

    Hi guys!!

    I think I got the solution for your problems!!

    First of all : sorry for my poor english ;-)

    I bought the WAG54GX2 today here in Germany. Before buying it, I read this thread and hoped there wouldn't be any problem with my new router. But, as expected, I had the same porblems like some of you. If I activated the AES encryption, it seems that my windows update wouldn't work. :cry:

    I spent my hole day trying all kind of settings to get this work and found finally the solution: It's not a problem with the AES encyption at all! It's an MTU setting problem!!

    I knew from my old router, that my optimal MTU size is 1452. So I also set this value in the WAG54GX2 settings (default value was : auto - 1500). Then I checked it with the TCP/IP analyzer on and MTU size was not 1452 (as set in the router) but 1492 (Windows default!). I downloaded the TCP Optimizer from the same site and set the MTU of my WinXP to 1452. After rebooting, I made the TCP/IP analyzer again and it showed me up the new MTU (1452)! From now on, my windows update worked withou any problems!

    So it seems to me like a bug in the WAG54GX2 firmware that would ignore the MTU size you set in the router. I called already the Linksys support to report this. The technical on the phone couldn't really help me and said the only solution is to set the MTU on every single PC manually. I asked him to notice the (obviously) wrong behavour of the MTU handling and that I hope to see a fix in an upcoming firmware...

    That's all!

    Hope I could help somebody of you out there!

  12. Amoebe

    Amoebe Network Guru Member

    Bill, this solution works on my WAG54GX2 too. Thanks a lot.
  13. Michelangelo

    Michelangelo Guest

    I don't want to bother anyone here but I guess that at the present time Linksys didn't solve this bug at all on the WAG54GX2.

    I really want to thank Linksys to have abandoned me (and you) with a broken firmware and care at all.:(
  14. anj747

    anj747 Guest

    Any fix on this guys?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice