Problem with Netdisk (Ximeta) !!

Discussion in 'Other Linksys Equipment' started by frenchy94, Jan 17, 2005.

  1. frenchy94

    frenchy94 Network Guru Member

    again another issue, hope to be not alone ...
    try to use Netdisk products from Ximeta connected to WAG54G ethernet
    Netdisk is not seen from others laptops connected on Wifi
    i contacted Ximeta and they said problem comes from WAG54G and
    linksys is aware of that ?
    any informations will be appreciated
  2. calijason

    calijason Guest

    I use the Netdisk NU250 (not the switch-based version) and everything works fine. However, my WRT54g has lost it's wireless access - so all my systems are on wire - and there have been no issues.

    try putting systems on a hard wire to the switch - and make sure all systems have the exact same version of the driver.

  3. frenchy94

    frenchy94 Network Guru Member

    problem on linksys side !!

    got on phone linksys and ximeta support
    problem is on linksys side apparantly ximeta proprietary protocol
    is not forwarded thru wireless link on WAG54G
    both are still investigating,no solution yet
    so it's pity seems only this Wireless router that doesnt work against
    ximeta products..
  4. BTAG

    BTAG Network Guru Member

    I have the same problem, using the WAG54G and the Ximeta Netdisk NDU10-250. After spending several hours doing everything on the Ximeta FAQ list (re-installing anti-vires / firewalls etc), I also got in touch with Ximeta. They told me the same thing - that the WAG54G blocks the Ximeta NDAS protocol over wireless.

    The German branch of Linksys support said that the problem has gone to the U.S., but no response back yet. Because I am UK based, I was advised to go through the UK Linksys support team, but they don't seem to be aware of the problem and haven't offered anything yet.

    This is what the German Linksys support team say:
    ""The main trouble for this failure is the XIMETA specified LPX protocol. In Germany we got only some requests to this case. I escalated to the american support team, but till this moment, i haven't got a feedback to this escalation. The software employees work on it and will look for an solution."

    Searching the Linksys US support pages yielded nothing, so I've logged a query about resolution dates on the US site.

    Must admit it's very annoying. I feel like I am having to do the leg work between the different Linksys support teams (German, UK and US), and between Linksys and Ximeta, when I would expect them to all be communicating with each other on this.

    As it turns out, I've now got an expensive pice of kit that I can't use over my wireless network because of this compatability issue. :(
  5. rlisanti

    rlisanti Network Guru Member

    Does anybody have an update on this?

    I requested help from the European and US Ximeta Support sites but have heard nothing back. Seems like the real cuplrit is the LPX protocol which is not supported on the WAG54G. Wouldn't have thought that woukd be too big a problem for Linksys if they really wanted to add it...

    Oh well, off to the Linksys site now to register my problem. :evil:
  6. Ore-Oreo

    Ore-Oreo Network Guru Member

    The LPX Protocol is very basic protocol. There really isnt much to it. I dont think its an actual issue with the protocol, i just think the WAG54G has a range of 'compatible' protocols it wishes to use and choose not to include forign protocols.

    Its an issue that only Linksys can correct :roll:
  7. rlisanti

    rlisanti Network Guru Member

    Update from Ximeta and Linksys!

    If anyone's interested in these updates...

    Linksys Customer Support
    "Thank you for contacting Linksys Customer Support.
    There is a possibility that your NDAS device will not talk wirelessly with our WAG54G because of protocol and chipset compatibility. I'll forward this matter to our Product Management team so that they can do something about it.
    Thank you"

    Ximeta Tech Support
    "please try contacting Linksys to notify them that the NetDisk does not work with the WAG54G model. We’ve found that the NetDisk LPX protocol is completely blocked by the WAG54G over the wireless side. On the wired side it works just fine however. Linksys should be able to create a new firmware patch to fix this issue, however it will require enough customers to request the fix from Linksys to occur."

    If you haven't contacted Linksys yet, then please do. It's only way this will get fixed
  8. frenchy94

    frenchy94 Network Guru Member

    Push push them to have a Fix

    welcomed on Board guys !!!!

    this is totally a linksys issue, WAG54G doesnt pass LPX protocol
    thru Wireless side , so go ahead and flood linksys email support
    both US and your countries to have a fix about this issue ...

  9. Ore-Oreo

    Ore-Oreo Network Guru Member

    Re: Push push them to have a Fix

    Hahaha, very nice...i would totally have to agree.

    I'ved talked to Ximeta Tech Support before and they have always beed honest and forthcoming about issues that they are aware about. Im sure if it was somthing that they could fix, they would.
  10. vetinry

    vetinry Network Guru Member

    It's great to stumble across sites where you find that you are not alone in trying to sort out problems.

    My work unfortunately provided me with a WAG54G for wired use of my laptop at home.

    I've taken the opportunity of using the wireless gateway to set up a home network but have been suffering the problem of dropped signal as discussed elsewhere.

    I have also got a Ximeta Netdisk and wish I'd discovered this info before I wasted several nights trying to get my wireless network to access it.

    I am trying to improve the signal using the Linksys range expander but now realise that it probably isn't the range causing the problem, but a firmware issue which would solve both the dropped signal and NetDisk problems.

    Some other sites eg broadband buyer mention upgrading the firmware to a different version, which helps to get the range expander to work, but will this solve the other issues.

    If not, what is the best product to buy to solve these problems. Will the Ximeta work ok with other Linksys products?

    Thanks in advance

  11. rlisanti

    rlisanti Network Guru Member

    Netdisk Wireless Issue


    I'm almost 100% certain theat the firmware upgrade for the WAG will not fix the wireless problem with Netdisk.
    I too had a problem with a Linksys range expander and installed 1.02.7 as advised by their UK support. This enabled a new tab (WDS) which then allowed me to specify the Mac address of the range expander. The entire network then worked.

    The Netdisk problem still persisted. Works fine on a wired connection but not wireless due to the LPX protocol not being supported by the WAG.

    Does anyone have any update on this? This disk is such great value and such a neat solution I would really like to get this working.
  12. purge98

    purge98 Network Guru Member

    Yeah it's nice to know that you're not alone.

    I also have just bought a Netdisk 160GB drive and tried for 5 hours to get it to work on my WAG54G. Installing/un..etc..etc..

    I rang and they had no idea about the problem.

    I then searched for "netdisk wag54g problems" on Google and here I am.

    The search also led me to,1558,1369365,00.asp
    Check out the last paragraph. Wot a lot of rot.

    Check out number 11. Not good.

    I then rang back and the guy was helpful and said he would ask the US if they were aware of the problem and what they are doing about it. I will let you know what they say.

    I will also email Linksys to complain.

    I found a way round the problem however for the time being.

    Attach drive to PC as USB. Then in Win XP, share a folder on the drive. This can then be seen by other PC's connected to the WAG54G wireless network.

    Not perfect I know but at least you can access it wirelessly.
  13. purge98

    purge98 Network Guru Member

    Just had this back from Linksys:


    Hi Jason,

    Thanks for the e-mail, we are currently pending feedback from our
    escalation team with regards to this issue.

    As soon as we have any further information we will get back to you.

    Best Regards

    If you have further questions, please contact us at 08707 393939 or send
    us an email at so that we may further assist you.

    Linksys - A Division of Cisco Systems, Inc.

    UK Support Centre


    I'll post their further response when I receive it.
  14. vetinry

    vetinry Network Guru Member

    Hi Guys

    Thanks for your responses and support. I've had a chat with the IT guys at Pfizer where I work, and although as a company we don't yet support wireless networking, they are going to have a think about this problem.

    Just a couple of thoughts

    Connecting the netdisk to another computer via usb is a good idea in principle, but I only have 1 computer at home so it's not ideal to lug around the netdisk, and also the reason I invested in it rather than just an external hard drive was to have wireless access to files stored on the net disk.

    Also, my computer has only USB 1 so am I right in thinking that I'll only get maximum transfer speed of 11 or 12 Mbs rather than upto 54Mbs on wireless G and 100Mbs on wired? I apologise if this is wrong - that's why I'm a vet and not an IT expert.

    The other thing I was thinking about today was if it is possible to add a wireless access point such as the WAP54G to the WAG54G - then by disabling the wireless facility on the WAG54, would this be a way around the problem. What I don't know is if the Net disk will run through the WAP54G - it wasn't listed on the Net Disk FAQ's, and I haven't read or heard about so many issues with it.

    Is the firmware for it going to be suitably better so as to not cause these problems.

    Any comments?

    Best wishes

  15. rlisanti

    rlisanti Network Guru Member

    One other solution....

    Of course another way to get around this may be to buy the Network Storage Link (NSLU2) unit from Linksys.

    This allows you to attach any USB stroage evice (including flash drives) by a wired link to your WAG54G.

    The drive then appears as a Linksys-recognised drive to the newtork and should work over wired and wireless...essentially like Linksys's own network attached storage devcies.

    The disdvantages are:
    a. cost
    b. I think the Netdisk gets formatted specifically for the NSLU2 and you couldn't then move it to another PC for use without re-formatting it, and
    c. you have even mre gear cluttering-up your desk. One of the advantages of the Netdisk is its size. Attaching more gear is a messy solution if you bought it for that feature.

    Anyway Linksys should fix this. Having said that Ximeta should put a warning on their packaging. I know it mentions the limitations in the FAQ's but the Linksys addition is relatively new and te whole caveat thing is buried in their web site.

    Have to keep hassling Linksys. That's the only way this will get fixed.
  16. rlisanti

    rlisanti Network Guru Member

    WAG54 version2

    Has anybody tried using the Netdisk on a version 2 WAG?
    You should be able to see the version number printed on the tab under the unit next to the model number. If it has no number it is version 1.

    I've heard some suggestions that it should work with this version but I cna't check it on my WAG.
  17. purge98

    purge98 Network Guru Member

    Good points rlisanti.

    I ordered mine in the UK from and they don't seem to know of the problem.

    There should definitely be a warning on the box and website to that effect but of course manufacturers are loathed to admit their little baby has a problem with some interfaces.

    I've started an email sending spree to Linksys and Ximeta and won't stop until I get some action.

    Incidentally the WAG54G is a very popular unit in Europe and it looks like the Netdisk will be also. If both company's don't pull their fingers out then they will lose quite a bit of trade to Netgear, US Robotics etc.... whose router let through LPX.
  18. vetinry

    vetinry Network Guru Member

    I've just had a look under my WAG, and it says ver 1.2? I'm confused now - is that version 2 or version 1?

    I upgraded my firmware last night from the FTP site because the main linksys site doesn't have very recent versions on. I only used the version one firmware - 1.02.7_03m rather than the version 2 firmware that was available on there.

    The wireless connection appears to be more stable downstairs, where I was having problems before, but I haven't had a chance to test the net disk.

    Since I only live in a 3 bedroomed house, would I be right in thinking that I should really need the range expander since my problem appeared to be with the signal dropping rather than poor range?


  19. rlisanti

    rlisanti Network Guru Member

    Version numbers


    Version 1.2 refers to the model number of the WAG54G...this is something very different to the firmware which you have loaded (1.02.7).

    The note I got from Linksys states clearly that it should say version 2 on the WAG itself so I don't think you have a version 2 unit (just like me!).

    Another note I got from Ximeta suggested that some people hadn't experienced the problem with not seeing the Netdisk over wireless with the later generation router. This is unconfirmed but I assumed they meant the version 2 router so there my be hope for a lucky few.

    With regard to your wireless set-up the firmware you have loaded just enables another tab (WDS) on the WAG where you can enter the the MAC address of the range expander. This will the allow you to extend the range of your network.
    This is a competely seperate problem to the Netdisk issue and won't fix that.
  20. wern1211

    wern1211 Guest

    May I join you ?

    I have just bought a WAG54G and a WPC54G as a 802.11g remplacement to my old Siemens Santis WiFi b modem/router and my 3COM PCMCIA WiFi b card.

    It looks like I made the wrong choice ...

    As many of you did, I spent too a couple of nights trying to get a wireless access to my 80Go Netdisk ! I did not succeed.

    In the beginning, I was happy that at least the wired connection was OK but now I find it so frustrating ! I mean this is clearly a Linksys issue (a WAG54G issue I should say) and thing do not seem to be moving.

    I do agree that it is clearly a Linksys issue but forget about any firmware. To date, I have tried them all but none fixes anything. I had even tried the 1.02.6 beta firmware from the French website (where firmwares are called "microgiciels", cute isn't it ?) ...

    Maybe they do not want to pay royalties to use the Ximeta LPX Proprietary Protocol ... Or maybe they hope to sell their own net-storage-solutions ? In the latest case, I would simply forget about it cause Netdisk rules ! Anybody will tell you that they will get rid of their WAG54G if it gives them wireless access to the Netdisk !

    I too had to act as the "missing link" between the French and Belgian supports, and more recently between those two and the US support !

    It is funny to note how communication can be so bad within a company that sells communication devices. By the way, have you guys tried to call Linksys ? ... Outsourcing is definitely killing the business, I tell you !
  21. purge98

    purge98 Network Guru Member

    Works with WAG54G Version 2

    I have just had my WAG54G replaced with a Version 2 by Linksys.

    I plugged in the Netdisk and it WORKS!!!

    The PC in the other room made a pling sound and by the time I had walked into the room, Win XP had found it and installed it. (I already had the NDAS software loaded)

    I also switched on the Laptop and it worked too with a pling also. Which is nice.

    I am just waiting to see if this new WAG54G V2 is more reliable than the previous one, as that is the reason why I returned it to Linksys in the first place.

    I am running the factory original WAG54G V2 Firmware 1.00.19
  22. rlisanti

    rlisanti Network Guru Member

    Linksys WAG54 G and N etdisk success!

    Excellent purge98.

    Then the rumours that the version2 WAG fixes this are true.

    I had a note recently from Linksys saying that there were no planned firmware upgrades to the WAG for v1.2 devices.

    Too late for me...I sold the Netdisk on eBay and and am now running a Firewire attached Lacie 160Gb drive from my Mac. I can share this across my network even though it's not an ideal solution.
  23. purge98

    purge98 Network Guru Member

    Yeah rlisanti the rumours are true. V2 is compatible with Netdisk.

    However I can't ftp upload now. It is a known problem and is fixed with the new firmware.

    Here we go again....firmware upgrades all over again!!!

    Shame you had to sell your Netdisk but if it gets you a common drive then at least you've got part the way there.

    I doubt whether Linksys will put much effort into new firmware for V1 as they will probably want to forget it ever existed!!

    No-one at Linksys ever told me that the V2 would work with Netdisk. Unbelievable company.

    I even got this from one of their support people:


    Response (Marvin P(17461))04/17/2005 06:10 PM
    Dear Jason,

    Thank you for contacting Linksys Customer Support.

    Sorry to keep you waiting regrading this.

    I have already verified this problem but unfortunately, the LPX protocol is not supported by our routers. Even in version 2 of WAG54G, it will not work.

    If you have further questions, please contact us at (800) 326-7114 or send us an email at so that we may further assist you. Please use this phone number given as reference for future support calls.


    Marvin C. Prieto
    Linksys – A Division of Cisco Systems, Inc.
    Product Support Specialist


  24. Andyrew

    Andyrew Network Guru Member

    XiMeta NetDisc

    Hey Guys,

    Has anyone tried beta firmware version 1.03.1 yet? I received it from Linksys UK today but haven't had time to test it yet.
  25. frenchy94

    frenchy94 Network Guru Member

    Linksys is working on a fix

    never too late
    got a message from Linksys, a beta firmware will be available
    soon to fix this issue there are working for V1 and V1.2 also
  26. Andyrew

    Andyrew Network Guru Member


    Firmware version 1.03.1 is for the WAG54G v1 / v1.2 and from what I gather it addresses the LPX pass-through issue.

    Have you spoken to Linksys UK or have you already tried 1.03.1?

    I've been busy with work and still haven't got round to playing with it yet, if you get a spare moment drop Linksys UK an e-mail to requesting firmware 1.03.1
  27. vetinry

    vetinry Network Guru Member

    Thanks for all the hassling of Linksys.

    I requested the new firmware (1.03.1) and it arrived yesterday. Everything seems to be working well now.

    Can access the netdisk wirelessly and signal appears to be reasonably constant. No drop-outs yet.

    Cheers everyone

  28. frenchy94

    frenchy94 Network Guru Member

    post it please !!!1.03.1)

    could you post it somewhere on the network please
  29. frenchy94

    frenchy94 Network Guru Member

    1.03.1 post it please !!!

    could you post it somewhere on the network please ???
  30. nick_squonk

    nick_squonk Network Guru Member

    After reading on this thread about a 1.03.1 firmware I've googled a lot and found this link To download right click and choose "save object to..." otherwise search in the forum page below the link to the ZIP file (there is another one to a bin file which does not work).

    I've found it in this french forum, downloaded and installed 2 days ago.

    I have a WAG54G v 1.2 from about 15 months now and this is the first time that I have no wireless or internet interruption for such a long period.

    At the moment this is the most stable firmware I've used...

    Of course, as you suggested, I've wrote to the uk Linksys support, but I'm still waiting for a reply...

    I've downloaded this firmware because I've bought an NDAS device (a sarotech netdisk which uses the Ximeta software) and it didn't work with the 1.03.0 beta 4 firmware; now it works very well and i can access it also from my wireless laptop.

    Hope this help...
  31. nick_squonk

    nick_squonk Network Guru Member

    Just an update to the previous post.
    Today I've received the firmware from linksys support, so I can say that the file I've downladed and installed is identical to the one received by Linksys.

    WAG54G still working without reboot from installation
  32. HiSpeed

    HiSpeed Network Guru Member


    Could you tell me if the WDS menu is existing and working (could you enter MAC addresses) ?

  33. nick_squonk

    nick_squonk Network Guru Member

    No, you're right.
    The WDS menu exists, but even after enabling WDS you can't enter mac addresses...

    Don't know exactly, but maybe it can detect MAC addresses of other access point on the network that are wds-enabled.
  34. HiSpeed

    HiSpeed Network Guru Member

    That confirms once again the only one firmware to set MAC addresses with WDS is 1.02.7 ! :sadbye:
  35. ajgball

    ajgball Network Guru Member

    WAG54G and Smartdisk

    I have tried 103.1 with the smartdisk and it still doesn't work! Bugger. As for the WDS it does work in this version. It uses something called LAzy WDS. You just enable it and it will scan the network for all mac addresses and work with any of the devices that it sees.
  36. nick_squonk

    nick_squonk Network Guru Member

    What kind of problems you have had with NetDisk? I have a Sarotech Netdisk using Ximeta NDAS software version 3.10.1231 and it works well...
  37. msg_moi

    msg_moi Network Guru Member

    Got stability issue with Ximeta

    I Taught i could join this topic.

    I recently buy a WRT54GS (firmware 4.70.6) with and adaptor for notebook.

    I have Two Netdisk 160 that have different Firmware
    TM100-24 for my oldest one about one year+
    15.05R15 for my most recent less then a week.

    When both netdisk are mount.....

    Only the older one seem to be unstable when both are activate on my router. I keep get the bublle «connection lost...» then finally it stay unmount

    I notice that when i disable the afterburner (booster mode) my netdisk seem more stable.

    But i keep receiving the unstable connection when my two net disk are connect simultanious.

    Best i had is to have my older one hardwire while the newest one is wireless.

    If someone know how to flsh the firmware of the netdisk???

    Otherwise i might transfert all my stuff and format the older one to see what happen.

    Hope others will have trick to share until both Netdisk and Linksys update their firmware.....
  38. ioolex

    ioolex LI Guru Member

    wag54g ver1.2 FW 1.03.1 with lpx

    Hi vetinry,
    i also have the wag54g ver 1.2 with firmware 1.03.1_beta 1. I have a ndas-external-hard-disk using the lpx-protocol. Using wired conection everything works fine. Using the wlan conection the ndas-software find the hard disk an i can mount it, but then windows xp stop working and i have to shot down. With the firmware 1.02.7 i didnt find the hard disk with wlan. So firmware 1.03.1 is better but it still not work. Maybe i have to change the settings of my wag54g???
    I dont know...
    Maybe someone has result this problem. I had difficult to find this firmware 1.03.1 and i read always lpx does not work on wag54g. But then i read this thred where some find a result for this problem. Are you shure using NDAS and not a NAS device?

    THX a lot
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice