Problem with Tomato 1.6 and Verizon FIOS TV

Discussion in 'Tomato Firmware' started by rickgrob, Apr 17, 2007.

  1. rickgrob

    rickgrob LI Guru Member

    The problem has to do with the video on demand (VOD). Verizon FIOS TV uses a Motorola NIM to handle the program guide and VOD. On a bone stock Buffalo WHR-HP-G54, both the guide and VOD works. However, with Tomato 1.6 (the only one I have tried) the guide works but the VOD doesn't. I have tried putting the NIM in the DMZ, but even that doesn't help. Does anyone have any ideas? The stock WHR-HP-G54 firmware is horrible compared to Tomato so I would really like to get this working.

  2. Odin-60

    Odin-60 LI Guru Member

    A wild guess: Make sure that "Allow Multicast" is checked
    on the "Advanced/Firewall" page. Does this help?
  3. rickgrob

    rickgrob LI Guru Member

    Thanks Odin, I will give that a try when I get home. My gut tells me it has to be something simple like this, as I can't believe that the stock firmware would work while Tomato (a far far better firmware) would not. I will update tonight when I give it a try.

  4. rickgrob

    rickgrob LI Guru Member

    No luck with this change. Turned on multicasting and still no video on demand. I am open to other suggestions or explanations.
  5. GeeTek

    GeeTek Guest

    You may wish to give Tomato 1.04 a try. Starting with Version 1.05, a lot of browser helpers were removed from the code. If 1.04 does fix it, you will have other problems with your fios, because using QOS on ver 1.04 will limit your upload speed to 3.6 Mbps.
  6. kuangeleven

    kuangeleven LI Guru Member

    I'm having this problem too with Tomato 1.0.5 -- with my wrt54g at the head of my network and the verizon supplied ActionTec MI424-WR set up as a bridge between the coax/moca and ethernet networks, video-on-demand just doesn't work.

    I finally gave in and switched back to having the Verizon supplied router at the head of my network, handling the pppoe and nat -- boo.

    I'm wondering if there's something about the QoS support in the ActionTec router that Tomato doesn't provide. I've seen reports of fiostv video-on-demand working with newer WRT54G's and firmware versions, so it seems that it is possible to use this router at the head. I'd like to try to use Tomato if possible.

    If there's anything I can do to help figure out what the problem is -- wireshark packet dumps etc -- I'd be happy to help.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice