Problem with WDS

Discussion in 'Tomato Firmware' started by sorian25, Oct 12, 2007.

  1. sorian25

    sorian25 LI Guru Member

    Here is what I want I have set up:
    (router 1)Linksys WRT54GL w/tomato 1.09 AP+WDS WPA TKIP
    (router 2)Linksys WRT54G v4 w/tomato 1.09 WDS WPA TKIP

    All of the wired machines on both routers can connect to each other and the internet without a problem. The problem is with the wireless machines.

    I have 2 Laptops using 2 different wireless cards and neither one can stay connected to the network. They can connect and browse the web, but only for a short time (like less than 5 minutes). If I disable WDS on router 1 and set it to AP mode the Laptops connect just fine.

    I have followed the directions on the faq page here:

    I have also tried the suggestions I could find on the forums such as; enabling frame burst, setting beacon interval to 50, setting RTS Threashold to 2304, and setting Fragmentation Threshold to 2304.

    Both routers have the same ssid and the same wireless settings. Router 2 is using the ip address of router 1 for the gateway and dns server. All the advanced wireless settings are set to default except for the transmit power (set to 84).

    Any ideas on what could be causing the problem?
  2. goRt

    goRt Network Guru Member

    I have WDS and AP enabled on both of mine

    As an aside I also use AES as this seem to have a much lower overhead

  3. mikester

    mikester Network Guru Member

    Your laptop may be trying to connect to both units and be flipping back and forth - use your wireless connection utility to set the priority of one unit over the other.

    Wireless zero config always caused me problems - using the hardware utility (i.e. intel wireless) solved a lot of connection stability issues for me.
  4. Bernini

    Bernini LI Guru Member

    I have the same problem and i dont know how to solve it.

    Can may this tool solve the problem: Wireless Zero Shutdown.

  5. azeari

    azeari LI Guru Member

    give the 2 routers a different SSID? perhaps with an additional trailing space for 1 (=
  6. Bernini

    Bernini LI Guru Member

    I have already tried it but then the wds doesnt work.
    I think wds needs the same ssid
  7. pug76

    pug76 Network Guru Member

    I have the same problem with v1.10.1188. However, the problem only surface for one of the laptops. Anyone has any idea on how to resolve it once and for all? Does other firmwares have this issue?
  8. pug76

    pug76 Network Guru Member

    An update. Hope it helps the developers.

    If I moved the laptop far from the first router (with the WAN), it connects to the second AP and works perfectly. However, if the laptop is right next to the first router, it cannot hold the connection with error "First MIC Failure".

  9. Bernini

    Bernini LI Guru Member

    in accordance with the german wikipedia it is not absolutely neccesary to use the same SSID. Can any one confirm this? Is this also possible with Tomato?
  10. Odin-60

    Odin-60 LI Guru Member

    My setup is similar, but I have no such problem.
    A shot into the dark: Enable STP on both APs; does that change anything?
  11. Bernini

    Bernini LI Guru Member

    Unfortunately i do not understand this function.
    Do you know a better description than the description in the faq?
  12. tgillett

    tgillett Network Guru Member

    I have found this problem with WDS in DDWRT when using WPA-PSK security with laptops with Intel 3945ABG chipset running Ubuntu - OK with Windows XP SP2.

    I haven't tested in Tomato but I suspect it will be similar

    Other laptops with Intel 2100 work OK under Ubuntu.

    I have changed to using WPA AES and that seems to work OK with both chipsets under Ubuntu.
  13. Odin-60

    Odin-60 LI Guru Member

    You mean "STP"? Just go to the page Advanced | Routing
    and enable "Spanning-Tree Protocol". Do so on all routers.

    STP is meant for a different purpose, but it also seems to make
    WDS more stable as a side effect -- don't ask me why...
  14. pug76

    pug76 Network Guru Member

    I solved the problem by setting the client to connect to "Mandatory MAC" address of the 2nd router.

    Probably something to do with roaming...
  15. Bernini

    Bernini LI Guru Member

    is the client a windows pc?
    how can i adjust this?
  16. pug76

    pug76 Network Guru Member

    Yes. I am using the Intel client, under Profiles->Advanced.

    Do not think that Windows Wireless Client can do it, as least I don't know how :D
  17. Bernini

    Bernini LI Guru Member

    in my case it is not possible because i have a linksys pci card.

    Another Queastion:
    If i have different ssid's on the router the problem is solved. but is this possible with tomato? I have tried it but there is no internet connection on the second router.
    is ther may another setting? (With dd-wrt this is only possible with WEP security)

  18. gotamd

    gotamd Network Guru Member

    For some reason, TKIP encryption has never worked for me when using WPA + WDS and Tomato. I get continually disconnected for some reason. AES seems to work much better.
  19. fiurico

    fiurico Network Guru Member

    DITTO THAT! That is why I was forced to use DD-WRT for one of my implementations that involved this type of setup...TKIP would not work, AES did just fine, but I needed TKIP...
  20. Bernini

    Bernini LI Guru Member

    why did you need tkip? are there any disadvantages with AES?
  21. voxabox

    voxabox LI Guru Member

    some older cards don't support aes
    my Dad has one. Whenever he's over, I have to downgrade to tkip/aes
    to let him use my network
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice