Problem with wired ports after v23 (10/14/05) install

Discussion in 'DD-WRT Firmware' started by ericsten, Dec 14, 2005.

  1. ericsten

    ericsten Network Guru Member

    I've got a strange problem I cannot seem to get resolved. I have a WRT54G v1.1 that I put DD-WRT v23 beta2 (10/14/05) on in order to use the router as a client. I installed the firmware via the Linksys web interface for firmware updates while connected to a wired port. This is worth mentioning since after the firmware installation the wired ports were no longer responding to dhcp. The NIC would show a link light and Windows will make the DHCP request (traffic info via nic info in Windows show packets going out) but no response is ever seen (traffic info via nic info....) The wireless side of things works perfectly fine. I suspected a bad flash since the power light would not stop blinking.

    I replaced the firmware with the Linksys 4.0_4.20.7 via TFTP. Yes, I was able to connect via TFTP. Very interesting there. Followed the debricking info on this site and set my NIC to and started pinging the router. After rebooting the router I would get 4-6 pings before it would stop responding. I took this as a good sign that the ports aren't bad. So I started TFTP and restarted the router, reflashed with the Linksys firmware and was up and running. EXCEPT for one small problem, the wired ports are still not working properly. I reset the NIC to a static IP as I did above but amd still not able to talk to the router.

    So, I finally get to my question/request. What have I done/misconfigured to cause the wired ports only to work during the initial boot sequence of the router? What can I do to reverse this? I've done the standard "reset button for 30 seconds" on both the DD-WRT and Linksys firmwares but no luck.

    Thanks in advance!

    Eric Sten
  2. scotkb

    scotkb Network Guru Member

    I expect that you cleared nvram before and after??

    erase nvram; reboot
  3. ericsten

    ericsten Network Guru Member

    Yep, cleared the NVRAM and rebooted. Unless there is another way besides holding the reset button for 30sec.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice