Problem with wireless client mode.

Discussion in 'Tomato Firmware' started by eugene28, Sep 30, 2012.

  1. eugene28

    eugene28 Serious Server Member

    I am trying to connect my Cisco E4200 router with Tomato installed as a wireless client to my WNDR3700 (Gargoyle firmware) router. I amusing tomato-E4200USB-NVRAM60K-1.28.9007MIPSR2_RAF-VPN-NOCAT firmware to establish connection with no luck.
    Here is my setup. Slave router (e4200) is, master's -
    Setup of the wireless radios
    The result
    Here is the result for wireless bridge mode which works.
    And here working connection of my Netgear WNR2000 in working client mode.
    Tried Toastman's builds with same results. Any one got any ideas?
  2. eugene28

    eugene28 Serious Server Member

    Still looking for the solution to my problem.
  3. rs232

    rs232 Network Guru Member

    I'm not sure I understand what you're trying to achieve here, but the wireless client will create a NAT.
    1) what is exactly the problem?
    Independently from the answer:
    2) disable the WAN port (no dhcp) as your WAN will be the WAN instead.
    3) Then you need another class for the slave LAN:

    Internet ------(WAN)- master -(LAN) - -------- - (WLAN) -slave -(LAN) 192.168.2.x

    Having said that my experience with wireless client is limited to a single interface at a single frequency (2.4).
  4. FlexibleToast

    FlexibleToast Serious Server Member

    I'm having this exact same issue right now. I'm trying to connect my E4200 as a wireless client on the 2.4GHz radio and broadcast it back out on the 5GHz radio. I want it in wireless client mode because I want the NAT'ing and my own LAN. And just like you, it works fine in Wireless Ethernet Bridge mode, just not Client.
  5. eugene28

    eugene28 Serious Server Member

    Disabling the WAN port does not change anything. I just want to use client mode on my Cisco E4200 router. Can not figure out why my WNR2000 connect as wireless client with same settings and my e4200 does not connect.
  6. ciaccom

    ciaccom Addicted to LI Member

  7. ciaccom

    ciaccom Addicted to LI Member

    hi again,

    i verified, that this issue is present with tomato-RAF, Toastman and shibby releases (latest versions). i tried this howto:

    if you configure everything fo the first time, it seems to work - also WAN DHCP is working - my setup is "wireless client" with an E3000. after a reboot it's not possible to get any WAN IP/gateway and also signal quality is poor. wl0.1 (virtual wireless) never appears in "Overview/Device List".

    i think this is a general problem!

    anyone with a hint to a solution?

    thanks, ciaccom
  8. ciaccom

    ciaccom Addicted to LI Member

    .. and again,

    now i tried the Teaman release "1.28.2025 MIPSR2Teaman-RT-VLAN-PPTPD K26 USB VPN-NOCAT" and it's the same thing. i configured BASIC (WAN with DHCP, LAN with br0 and br1 incl. DHCP, WLAN 2,4GHz radio as wireless client), ADVANCED VLAN (unmarked port 4 for VLAN1, added VLAN 3 attached to br1) --> saved (router reboots). everything seems ok. Then ADVANCED Virtual Wiress (wl0.1 with my own SSID as Access Point) --> save. again, everything seems ok - the new "virtual wireless" SSID can be seen in my wireless environment, but i can't connect to it (WPA/TKIP encryption). i'm getting no IP address from the E3000 (this issue was the same as with a dd-wrt firmware).

    if i reboot the router, it never get's an WAN IP again (wireless client).

  9. eugene28

    eugene28 Serious Server Member

    Well. I have less complicated configuration. I only needed to connect as I wireless client and use other radio as an access point. Why did you use multissid anyway? I think my problem could be related with me using WPA2 personal instead WPA, but I am not sure.
  10. ciaccom

    ciaccom Addicted to LI Member


    does following setup really work (??):

    radio 2,4GHz as wireless client (as WAN access) | radio 5GHz as AP -- clients to this AP have internet access relayed over 5GHz to 2,4GHz radio?

    this would be perfect, if my clients understand 5GHz - have to check this.

    sorry, i can't give you any hint regarding your problem. is it not possible just to test the right encryption method.

  11. eugene28

    eugene28 Serious Server Member

    I have following configuration working. Wireless bridge with 5GHz radio and AP for 2,4GHz radio. At the moment I can not switch from WPA2 to WPA, but you can try and post your results. But again I see no problem with WPA2 when I connect my Netgear WNR2000 with Tomato as wireless client.
  12. ciaccom

    ciaccom Addicted to LI Member

    i tried yesterday to connect a notebook (with an Intel WiFi Link 5100) with my E3000 via the 5GHz radio. I even didn't see the Wireless Network/SSID of the 5GHz radio. have to try again ...
  13. eugene28

    eugene28 Serious Server Member

    Check in advanced-wireless settings you have put correct region for both radios. It caused me problem once.
  14. ciaccom

    ciaccom Addicted to LI Member

    you made my day! thanks for pointing out, that my setup (VSSIDD, etc.) is "complicated". now it's working with 2,4 GHz as "wireless client" (WAN with DHCP - 10.0.x.x) and the 5GHz radio as "access point". all clients get via DHCP an IP address in a separated IP-segment (192.168.x.x) and have internet access. perfect! :)

    if i can do any testing regarding WPA/WPA2 encryption for you, just let me know.


  15. nmalinoski

    nmalinoski Networkin' Nut Member

    Bumping this because I'm having the same problem in Shibby's latest firmwares (112, 114, 115) on both the N66U and AC66U. Wireless Ethernet Bridge connects, but Wireless Client does not. For the record, I do not have this issue with my WRT54G/GL routers, which are running Toastman 1.28.7634. The host AP is configured to use WPA2 Personal with AES encryption.

    When in Ethernet Bridge mode, I get a connection immediately and can get addresses from the host AP. Signal quality sits stably at about 32.

    When in Wireless Client mode, the router detects the host AP, but signal quality flops between 0 and ~18 and it never gets a DHCP address. Neither setting a static IP nor any other combination of security/encryption helps. The only configuration that actually seems to work is to disable encryption altogether, but that is undesirable.
  16. JJack

    JJack Serious Server Member

    @nmalinoski, Have you had any luck yet?

    I'm also running Shibby's 115 build on the RT-N66U. In Ethernet Bridge mode, I'm able to connect with WPA/WPA2 enabled. In Wireless Client mode, I'm able to connect as long as security is disabled. Immediately after enabling security on both the host, and client router, I'm unable to connect.

    I tried enabling STP on both routers, but that did not work either. I read somewhere that recent updates have made it so that STP is not necessary, but the developers have not confirmed that. I'm not convinced this is a bug in Tomato, but rather a configuration setting that we're overlooking. It would be interesting to know what Shibby says about 'Client Mode' on the RT-N66U.

    CHRISTOS ZAPITIS Reformed Router Member

    any update on this?
  18. nmalinoski

    nmalinoski Networkin' Nut Member

    Sadly, I don't think so. It's still not working on Shibby's 116 firmware, and by the lack of complaints, I'd have to say it's one of the lesser-used features (Meaning it'll get less attention).

    CHRISTOS ZAPITIS Reformed Router Member

    It can't be that hard to troubleshoot for someone in the know and fix...It works fine on dd-wrt. I use it often...
  20. eibgrad

    eibgrad Network Guru Member

    Until and if this is fixed, find an inexpensive wireless ethernet bridge and connect it to the wired WAN. This even offers the advantage of being able to use a different freq/channel from the rest of the APs, thus increasing throughput.

    CHRISTOS ZAPITIS Reformed Router Member

    I justed tested this feature with MIPSR1-116 K26 Mini, on a Linksys WRT54GS v1.1 and it works fine with stable throughput, however I would also like my ASUS AC66U to work too :(

    Could this point to a driver issue?

    CHRISTOS ZAPITIS Reformed Router Member

    What do you mean use a different channel from the rest APs ? Could you elaborate?
  23. eibgrad

    eibgrad Network Guru Member

    Use of wireless client mode on the router necessarily makes that radio dependent on the remote wireless AP to which it is connected. IOW, if I'm connected as a wireless client to the primary wireless over 2.4GHz on channel 6, and subsequently want to create a virtual AP off the same radio (i.e., repeater), it must use the same 2.4GHz and channel 6. And that reduces throughput for wireless clients using that freq on that AP (potentially by half). But by using a separate *independent* radio for the wireless ethernet bridge, you can use any channel you want for the AP that was previously providing the wireless client on the bridge. You’ve broken the dependency!

    Client mode is a convenience, but like any convenience, it comes at a price. And the price is performance.
  24. galabad

    galabad Network Newbie Member

    I got shibby's tomato client mode to work with wpa2-personal aes encryption on ASUS RT-N66R. WPA2 can often be finicky in getting dhcp to work. Here are the steps:
    -first make sure wpa2 security is working between the two wireless devices, this can be verified by the internet connected wireless device showing up in the 'devices' list in the rt-n66r. It will be listed without an ip until the next step is taken:
    -go to tools/system command page, and turn off the radio your using, such as with the command: ifconfig stop eth1
    -go to the basic page where you already entered the correct and working wpa2 information, and click save at the bottom to cause eth1 to be restarted.
    -go to the devices page again to verify that the rt-n66r has picked up a dhcp address from the internet wireless device.
    -you may have to wait a minute or two for dns to auto connect also.

  25. ustar_

    ustar_ New Member Member

    I am refreshing the thread, because I have same problem.
    I want to share WiFi smartphone connection and Tomato router should be a WiFi WAN client.
    It works when I set Wireless Ethernet Bridge, but I need Wireless Client, because from obvious reasons a smartphone should not act as server for all network!
    Unfortunately Wireless Client does not get DHCP, so no connection. Maybe a BUG in Tomato?
  26. Magister

    Magister LI Guru Member

    As far as I recall, wireless client only works with wireless security disabled, and it has been like that since the first Tomato by Jonathan Zarate? I remember maybe 10 years ago I tried it on various router and it only works in open mode. If you want security (WPA2) then use wireless ethernet bridge.
  27. rs232

    rs232 Network Guru Member

    I have few Wireless clients with WPA/WPA2 enabled for many years and went through many upgrades. They work great even though the assignment of the IP address via DHCP occasionally doesn't go as expected. Usually rebooting possibly even tweaking the wireless parameters will help. What I can confirm is that once the DHCP assignment works it always will e.g. it's a one off setting issue not something that comes up periodically.

    my 2 cents
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice