Problem with Wireless Connections

Discussion in 'Tomato Firmware' started by Riotblade, Jan 17, 2007.

  1. Riotblade

    Riotblade Network Guru Member

    I've just finished setting up a WRT54GL with Tomato 1.02 firmware. It has been up for about 1 hour and then all wireless connections suddenly drop. I go to device list on my wired computer and it shows that my wireless clients all have the br0 interface. I then clicked release next to each wireless client and I can connect again. Does anyone know why it does this?

  2. pharma

    pharma Network Guru Member

    Did you remember to clear the NvRam after upgrading?

  3. Riotblade

    Riotblade Network Guru Member

    No, I havent done that. How do I do that?
  4. bogderpirat

    bogderpirat Network Guru Member

    hold the reset button in the back of the box down for 30 seconds and then reboot the box
  5. pharma

    pharma Network Guru Member

    Under Administration section, go to Configuration and use the Restore Default Configuration drop-down menu to select the erase all data in NvRam memory selection.

  6. bogderpirat

    bogderpirat Network Guru Member

    or, take the pussy road, suuure :rolleyes:
  7. pharma

    pharma Network Guru Member

    Hehe, well I figure the more aware people are about the firmware, fewer questions will be asked in the future. :) Remember, Jon didn't put it in there for nothing ...
  8. digitalgeek

    digitalgeek Network Guru Member

    I would have suggested the same as pharma... that reset button is kinda ackward to get to (my router is up on a shelf out of normal reach, it's a pain power cycle or reset)
  9. Riotblade

    Riotblade Network Guru Member

    After being connected 1 day and about 2 hours, my wireless connections were dropped again. I had the same issue on WRT54G v6 with default firmware. If anybody can lead me in the right direction to fix this issue, I'd appreciate it.

  10. GeeTek

    GeeTek Guest

    When wireless clients are successfully connected and active, they should show up under "Eth1" interface. "BR0" is the wired interface that you plug into on the back of the machine. Unless the wireless clients are laptops that need to use DHCP, set them all for static IP and see if that stabilizes anything. DHCP should be the last resort for TCP/IP addressing.

    Edit - If your ISP changes your WAN IP every 24 hours, that may explain why everything resets. If your ISP interface device is already doing NAT for the LAN, it may also be causing DHCP time outs. Have you checked your WAN IP ? Is it changing ?
  11. Riotblade

    Riotblade Network Guru Member

    My ip remains the same. All of my devices have static IP's prior to the disconnects. When I say disconnect, I meant the wireless device was disconnected from the network. My wired devices were still running properly. Sometimes, it'll block my wireless devices from connecting to the network unless, strangely, I turn on one of my wired machines.

    Thanks for the support.
  12. GeeTek

    GeeTek Guest

    Smells strongly of hardware malfunction. Is the router running hot ?
  13. Riotblade

    Riotblade Network Guru Member

    When I feel the top of the router, it feels warm, not hot. I really dont see how I can have such bad luck with the WRT54 series.
  14. GeeTek

    GeeTek Guest

    Try a Buffalo next. There seems to be no logical reason for your outage. DHCP timeout should re-connect with a new lease automatically. Interferance will cause connections to drop, but when the interference is gone, the connection will be back. You mention 2 solutions for the problem. 1 - Click on the dropped connection and it will allow you to re-connect, and 2 - Connect a wired machine to the router. Sounds like you may be mis-interpreting co-incidence. When you are dis-connected, does the SSID of the radio still show up on the dis-connected wireless client site survey? When you click "Connect" on your SSID, what happens ? Does the router allow you to re-connect ? If not, does the wireless client give any kind of error or does it just keep trying to connect, and then finally go back to the "View Available Networks" screen ? Are you the only one with the router's password ?
  15. Riotblade

    Riotblade Network Guru Member

    When I get disconnected, sometimes it won't show up immediately. When it does show up, it'll keep trying to connect and go back to the wireless menu. Sometimes, it won't let me connect for 10 minutes - 1 hour (varies). I don't know what happens within the router but I usually use my wired machine to change the wireless channel and everything will be fine again.
  16. pharma

    pharma Network Guru Member

    Sounds like it might be an issue with your "wireless card" settings. If you've been changing wireless card settings you might want to reinstall your wireless card drivers (newer drivers, maybe) and see how your wireless connection runs at default card settings (except selecting proper channel). You might also want to see XP's WZC (Wireless Zero Configuration) enabled/disabled makes any difference.
  17. Riotblade

    Riotblade Network Guru Member

    This wireless card connects to my old BEFW11S4 and my Netgear without issues. It seriously can't be my wireless card since I have 3 machines which worked perfectly with BEFW11S4.
  18. pharma

    pharma Network Guru Member

    Well, you never know. :) I haven't had any wireless disconnect issues with this firmware and don't think many others here have either. Hopefully you'll be able find someone with your disconnect issues who can point you in the right direction.

    The only other suggestion I can make is to re-load the Tomato firmware, reset the nvram as I suggested above, and initially make only changes to get the wireless working. Once wireless is working than play with the other firmware settings.

    BTW, who makes the wireless card and model? One reason it might be the card is you mention the same thing happening to a wrt54g version 6 running default firmware. Someone in the Wireless Adapter forum might have a similar occurance.

  19. Riotblade

    Riotblade Network Guru Member

    I have a Dlink USB adapter and an Intel integrated (Laptop). Can it also have to do with external interference?

    Also, why are my wireless devices marked under br0 in logs? is my wireless connection. The only wired connection is supposed to be

    Also, I looked at the logs before I got booted. This is what shows:

  20. pcautschi

    pcautschi LI Guru Member


    I have the same issues with my WRT54GL and Tomato 1.02 and my F1000G wireless device. After a certain amount of time (a few minutes to some hours) the interface status switches from eth1 to br0 and my device can no longer be reached by other clients(wired) . Sometimes I need to reconnect twice until connection is sucessfull.

    I use my wireless with wpa+wpa2 encryption. NVRAM was resetted and and newly configured. I also tried different setting on my F1000G without success.
  21. converter

    converter Guest


    I'm also experiencing WLAN problems with Tomato 1.04.
    I'm using a WRT54GL v1.1. I've cleared the nvram before and after the flashing.

    The problem is as follows:
    After some minutes I cannot get any connection to the internet over WLAN. What strikes me is, that I am still able to connect to other PCs in my LAN. Just internet connections are blocked or whatever.
    I've checked the logfiles, but there is nothing to be seen according to the problem.

    Has anyone a solution to my problem?

  22. digitalgeek

    digitalgeek Network Guru Member

    If you are running windows try removing the WZC entries
  23. paped

    paped LI Guru Member

    I had a similar problem with a dlink card it seemed to be some sort of timeout issue presumably on the arp or similar table, my fix for this was to firstly reinstall the dlink drivers on the PC. Then do a wireless survey and ensure the no other wireless routers in the area was using the same channel (or the channel above/below the channel I used) and had a "strong signal", from this I moved it from channel 6 to another "quieter" channel. Then I change my card from a static address to a dhcp reserved address so it always gets the same IP address like static IP but always has to request the address from the router and thus update the relevant tables and the like. You will need the mac address of the wireless card(s) to do this and set the DHCP lease time to around 24 hours. I don't know if my fix was due to one or all of the above changes but it seems to work for me the wireless never has any issues now and is very stable.... hopefully it will help you and with moving the wireless to a quieter channel I seemed to get a bonus of better wireless connection quality and a bit of extra speed....!
    Also I moved my DECT phone base station from near my router as wi-fi and dect use the same 2.4ghz spectrum and can interfere which each other.
  24. azeari

    azeari LI Guru Member

    go check the conntrack under advanced, and click the count current link to see the number of connections currently in the table. If the number's suspiciously close to the max connections, try increasing it. the logs appear to show connections through the router being dropped due to a full ip conntrack table. 4096 max connections is a nice number
  25. Max Monroe

    Max Monroe LI Guru Member

    Now that you mention it, my laptop, connecting by DHCP over wireless, ALWAYS shows up as br0, from the moment I switch it on - yet it works. Sure, I haven't had it running for any significant amount of time, but it just always worked. Still, I was too under the impression that it should register as something-not-br0... Come on, people, wassup here with the wireless and the bridge...?!? :hmm:
  26. larsrya8

    larsrya8 LI Guru Member

    I think it's supposed to show up on eth1? My laptop sometimes shows up on bro0 though... still works. Must be something goofy with the GUI.
  27. Riotblade

    Riotblade Network Guru Member

    I'm still having the issues. 4096 Max Connections and only 200 running. It's really strange as everytime this happens, it'll output something conntrack related.
  28. balle

    balle Guest

    I have the same problem as connected. I have a Netopia 3351 DSL router connected to my WRT54GL 1.1 with Tomato 1.04. I have tried setting the Netopia router in passthrough mode, passing the IP from the ISP. I have also tried setting up the WRT54GL as a bridge, connecting the cable from the DSL router to one of the LANs (no Tomato :frown: ). Now I am running the default setup with one DHCP server in each router. All the setups mentioned have problems with the combination of the two routers (double NATing) and connection to the internet will stop after a short while (5-10mins). I have no stability problem using the DSL router with an old 3Com router or a laptop directly connected.

    I reread the the Linksys WRT54GL manual and found that if you are connecting two routers, the first one should have the internal IP address set to I changed mine from and now all connectivity except torrents are stable:thumbup:. I think this is what fixed it.

    I have tried changing some of the "Advanced-routing" settings, number of simultaneous connections and the maximum upload speed, none of which seem to work. I love tomato, especially the simplicity of Qos and the speed charts, and would appreciate if I could use it with torrents. Please help!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice