Problem with WRT54G v2.2

Discussion in 'Tomato Firmware' started by miss_headshot, Feb 3, 2008.

  1. Well, i have WRT54G v2.2 and i were with OpenWRT. Soon i upgrade the OpenWRT into Tomato 1.14, but i have problem with taking IP from DHCP. Every 3 hours my router renewing his ip for few minutes and i dont have signal for that time. I tried to downgrade to 1.13 (friend of mine told that its stabel and good firmware) , but when i tried with "upgrade" i recieve that message : Error erasing MTD block . The router restarting and power light start blinking. After that I go back into Tomato 1.14 from cmd with tftp. Today I saw that there's Tomato 1.15 already, but when i tried to upgrade my 1.14 i have the same problem : Error erasing MTD block and rebooting the router into power light blink. I cant put 1.15 or other version on Tomato with cmd, I dont know why. Just a Tomato 1.14 which is not good for me. I tried Erase all data in NVRAM and even tried from telnet to erase that MTD with: mtd-erase -d nvram but the problem is still there. I just cant upgrade my firmware to other. So if someone know how to help me... I'll be thankfull :)
  2. szfong

    szfong Network Guru Member

    unplug, depress reset & hold, add power, wait 60 sec & release reset. now try webgui upgrade, if still not working, you may have a slightly corrupted firmware. next time be more patient while flashing your router and stop tinkering with your browser while upgrading. you now, need to perform tftp upload of firmware. your still not at the point where you need a serial or a jtag connection. but if you screw it up further, then well ;-) ====> good luck!

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice