problems acquiring network address

Discussion in 'Other Linksys Equipment' started by peterw, Dec 12, 2004.

  1. peterw

    peterw Network Guru Member


    i'm having problems acquiring a networkaddress (DHCP) using a wireless connection.

    it can only be solved if i put a UTP cable in my computer. In that
    case the networkaddress is giving.

    i'm using firmware 1.02.5 on a WAG54G (EU version). i'm using a DELL laptop running XP/SP2.

    any pointers?

  2. Morpheus

    Morpheus Network Guru Member

  3. peterw

    peterw Network Guru Member

    I've upgraded the firmware in my WAG54G from 1.02.5 up to EU firmware 1.02.7.

    my laptop still could not acquire a network address.

    the only improvement I expirienced: enabling logging does work on this version (no javascript error).

  4. peterw

    peterw Network Guru Member

    problems acquiring network

    Just got a confirmation of linksys report that this problem is known. I'm advised to use a static IP address.
  5. TonyC

    TonyC Network Guru Member

    Connect your laptop wired into the WAG54G. Try accessing the web interface and changed the wireless channel--(1, 6 or 11), then restart your computer and unplug/replug the WAG54G's power cord. (Make sure to unplug the ethernet cable from your computer.)

    Try to connect to your wireless network and see if it's working.
  6. jmbillings

    jmbillings Network Guru Member

    I am having trouble with this as well. Just upgraded f/w to 1.02.5 (release notes claim DHCP was fixed?) but still no joy. Static addresses work ok, but it's a bit of a pain when people visit and want to connect.
    I dd a factory reset and also changed some of the wireless settings as people suggested in the sticky topic, but it still aint working.
  7. komUnec8

    komUnec8 Network Guru Member

    I have trouble getting an address on first connection of a wireless laptop to a WAG54G running 1.02.7 too, but usually manage to get one on the second attempt by 'repairing' the connection i.e release/renew IP.

    I wonder whether the problem is dependent on :-

    1) Whether you are using a .11b card in a .11g network. eg try setting the AP to only .11g if you are runnig .11g clients, or only .11b, instead of mixed mode.?

    2) The manufacturer of your wireless card.
  8. jmbillings

    jmbillings Network Guru Member

    I've done a little more testing on this DHCP problem.

    I logged some packets with netmon on my server, and interestingly, the DHCP request *is* reaching my server, and a DHCP offer message is sent out. But I'm guessing the machine never recieves it, because it eventually gives up and gives itself a 169.x.x.x address.

    So I dunno. I'll mail this info to Linksys to see if it gives them any clues but I am sure they would have tested this already!
  9. DJguignol69

    DJguignol69 Guest


    I have the same with mine. Frirmware is 1.02.9.

    My Wifi client is a PCMWIA MSI G card.
    If I connect my computer with a cable, DHCP works for LAN connection.*
    If I connect with wifi only, it takes a long time to read the network adress and Win XP give me an error message... and few seconds after, it manages to connect correctly.

    When I used WEP... it never worked and now I only use MAC and DHCP works in Wifi mode (but it takes a long time to read the network adress).
    I think that it depends of the quality of the signal because when I am far form the WAG54G, windows never achieve to read the netwotk adress.

    So just try to desactivate WEP and to improve wifi signal quality or to lower the speed by using b mode instead of g.

    If you have the same problem please tell us your Wifi adapter model.
    If you have a Linksys adapter, please tell us if there is the same problem.

  10. Somebody

    Somebody Network Guru Member

    I'm not sure if this is going to clarify the situation, but here goes:

    I have a Dell laptop running Win XP Home that is patched up to the hilt. It has an Intel 2200BG mini-PCI network adapter in it.

    I have a WAG54G that yesterday was loaded with firmware 1.02.9 AU

    Problem with not getting a DHCP IP address. So I installed the Dell A08 driver update for the 2200BG - same problem. Then I did a repair setup on the driver and everything started to work wonderfully. 54Mb connection and could download multi-megabyte files without problems.

    Today - I am a glutton for punishment - I installed the V3.30.15.0 drivers for a WPC54G Notebook Adapter - the result was an inability to get a DHCP IP address.

    After un-installing the WPC54G software I still had the same problem.

    So I did a system restore to a point before installing the notebook adapter drivers - all sweetness again!

    I guess the moral is - if it aint broke, don't fix it.

    But seriously, the inability to get a DHCP address may not just be down to the firmware in your WAG54G - it may be elsewhere in the software on your PC. I guess if I knew exactly where I could be a popular man, but I don't; though I thought it would be useful to share the experience.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice