problems after upgrading firmware - UPDATED

Discussion in 'General Discussion' started by keith73, Feb 26, 2005.

  1. keith73

    keith73 Network Guru Member

    I have a WRT54G with 3 pcs connected to it.
    2 of them connect directly through the ethernet port, 1 uses the wireless network.

    I just recently upgraded the firmware to v3.03.6
    After doing this, the 2 pcs connected through the ethernet ports have internet access. the pc connecting wirelessly gets no access. it cant even ping the router. PC 1 is on WinXP, PC 2 is using Mandrake 10 and PC 3 is using Win98SE. the settings for PC 3 haven't changed but it cant connect anymore.

    Here's the router's settings:

    DHCP is enabled with max DHCP users set to 3.
    Operating mode is Gateway
    Wireless Network Mode: G-Only
    Wireless Channel: 9
    Wireless SSID Broadcast: Disabled
    Security mode is disabled
    wireless mac filter is disabled
    Advanced Wireless settings are all set to defaults
    Firewall protection is disabled (each pc has its own firewall)
    VPN settings are all enabled
    there are no internet access policies set
    DMZ is disabled
    Qos is disabled

    I'm at a loss here. anyone have any ideas?

    - keith
  2. jagboy

    jagboy Network Guru Member

    it would make sense to enable ssid broadcast there are no gains to disabling ssid broadcast.

    try to make to put another comp on the wireless network and see if that works. if it does work it is one of the computers that have a problem. if it does not work it is the wrt54g.

    [/quote]DHCP is enabled with max DHCP users set to 3
    Wireless Channel: 9
  3. Esquire

    Esquire Mesquire Staff Member Member

    Did you reset your perform a hard reset after updating the firmware?

    You could leave the channel as is for now if you have a specific reason for using that particular channel, but enabling SSID can help with network discovery. However, I noticed you have not setup anything to protect your wireless network from being accessed by your neighbours (and disabling SSID Broadcast does not protect your network
  4. keith73

    keith73 Network Guru Member

    yes, I know.
    I am restricting by IP. I check the logs regularly and dont see access from anywhere else, and yes, I changed the admin password as soon as I plugged the thing in. I've tried wep, but had some issues. but that's for another discussion. I prefer not to broadcast the SSID so that any neighbors who might be looking dont see it. but SSID broadcast isnt really a problem.

    On pc #3, the name of the network does show up in the list and the icon for the linksys software has both a blue and yellow icon indicating it does see the router, but when I try to ping the router it does not get a reply. It also wont grab the dns server list from the DHCP settings. I have the LAN IP set to a specific IP that is in the range of the 3 allowed ips. It also doesnt show up in the DHCP clients table.

    by a hard reset do you mean the reset button in the back of the router or turning the power off and on again? I did try the latter after upgrading firmware, but did not try the reset button. I will try that.

    It has been suggested to me that I try factory defaulting the router. will that also revert the firmware back to 1.xx?

    thanks for the replies.
    - keith
  5. keith73

    keith73 Network Guru Member

    Update on upgrade issues

    ok, I've determined that the pc that can not connect wirelessly seems to be fine. the problem seems to be with the router. it is not even broadcasting the SSID when enabled.

    I'm going to try and reinstall the firmware, see if that corrects the issue.
    I've already tried factory defaulting the box and that didnt fix the problem.

    anyone ever run into this before?

    - keith
  6. JohnBurns

    JohnBurns Guest

    I have this problem - I am fine as long as I keep SSID broadcast enabled - but when I disable it, I can't get network to work. However with WEP encryption, MAC authentication, a software firewall (Sygate) in addition to the router firewall, I guess SSID disable is not really necessary. I did change my SSID to my own code which is secret combination of letters and numbers. I have read the Microsoft statement that SSID broadcast is NOT a suitable protection (assuming they mean if that is the only thing used) but most people seem to think you NEED SSID broadcast disabled. I can see two other wireless networks in my neighborhood, but they, like me, have a security enabled wireless network ( with a padlock showing on it - meaning you have to have a WEP key to get in). So, you think there are no REAL gains to disabling SSID broadcast? I hope so, because my network only works that way - with it disabled. Appreciate your comments. Thanks.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice