Problems connecting to a fileshare through a linksys router.

Discussion in 'Networking Issues' started by _mcm_, Sep 13, 2005.

  1. _mcm_

    _mcm_ Network Guru Member

    My problem is that I can't connect to a fileshare through my wireless WRT55AG linksys router. I have tried to connect to a SAMBA server and a Windows fileshare with no success. I can use SSH, VNC, SMTP, POP3.... through my router. I'am trying to connect from the wireless segment to the external segment.

    My network segment on the WRT55AG are:
    Internal interface (wireless & switched ports) are: 192.168.0.x
    External interface are: 192.168.1.x

    I have a cisco switch, a fileserver and another router on the 192.168.1.x network segment. The other router ( are sharing a internet connection and are the gateway on the 192.168.1.x network.

    I hope someone have a solution on my problem.
  2. Trawna

    Trawna Guest

    Did you ever find a solution to this? I have a similar problem.

    I have a BEFVP41v2 that is connected to the DSL modem. It's internal address is There are a number of computers including a laptop connected to it, and they can ping each other, share files and printers, etc.

    I also have a WRT55AG plugged into the BEF. It's external address is, and internal is It is configured as a gateway, firewall is off, no access restrictions.

    When the laptop is connected wirelessly, I can surf the internet and ping all the other computers on the network, but I cannot see or connect to any network shares. Also, when I telnet into my server ( if I'm idle for a few minutes the session freezes up, which it doesn't when I'm wired.

    Some other diagnostics. From the .70 subnet, I can ping and the entire .69 subnet. From the .69 subnet, I cannot ping or anything else in the .70 subnet.

    I have tried setting up a static route to the .70 subnet on the BEF, but to no avail. Maybe I did it wrong?

    Any other settings I haven't mentioned that could be causing me grief?

    Any assistance much appreciated.
  3. cove209

    cove209 Guest

    It's funny how often I see this issue (wireless systems can't browse ethernet systems).

    Other posts I have read recommend either differnet wrt54 firmware like sevasoft (I have not tested this) or using a bridge such as a WEP11.

    I have a network with the same issue and will be testing with a WEP11 to see if it cures what ails me. Er, fixes my browsing problem.

  4. _mcm_

    _mcm_ Network Guru Member

    I did never find a solution to my problem with my wireless linksys hardware and I would not use differnet firmware than linksys orig.. I have now changed hardware to DLink products and all their wireless routers is working with filesharing (SMB/CIFS) by default.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice