Problems getting time for router

Discussion in 'Tomato Firmware' started by mbourd25, Jan 27, 2007.

  1. mbourd25

    mbourd25 LI Guru Member

    Hi folks, I have a Linksys wrt54gl with tomato firmware 1.04 and I can't get the router to retrieve the time from an NTP server. It did it the first week then it just stopped.

    Is their a way to force it to retrieve the time?

    My setup is I have the linksys wrt54gl connected to a vonage linksys RTP300 which does the routing connected toa cable modem from videotron.

    Also, what can I do to get the log to work? The last reported log was on Jan. 1.

    Is their a way a clear the memory?

    Any help would be great.

  2. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Perhaps you need to enter the default gateway (IP of the RTP300) on your WRT54GL. Its possible it isn't getting out to the net.
  3. mbourd25

    mbourd25 LI Guru Member

    Hi, I just entered the default gateway in the wrt54gl, in the basic section, which has a ip of and the rtp300 has The ethernet cable between them is a crossover. I was told that I needed that to connect 2 routers together.
  4. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    The crossover cable is a good measure but most likely the internal switches should take care of it too. Are you using your WAN port on your WRT54GL to connect to the RTP300? It sounds like you are or else you would have them in different subnets.
  5. mbourd25

    mbourd25 LI Guru Member

    I'm not using the WAN port, I connected the xover on port #1 of the wrt54gl and on port #4 on the rtp300.
  6. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Wow, my eyes were playing tricks on me because I could have sworn you had 2 different subnets posted. Anyway back to the issue at hand. Can you telnet into the WRT54 and then ping the address of the time server? Also ensure you can resolve the name to IP if you are using the name instead.
  7. mbourd25

    mbourd25 LI Guru Member

    sorry for asking this stupid question but how do I telnet to my wrt54gl router? Also, do I need any of the services on the router to be one? I turned off the wan and the DHCP server.
  8. digitalgeek

    digitalgeek Network Guru Member

    check under the adminstration admin access and see if you have either telnet or ssh enabled.

    If you are running Windows:
    you can enter telnet from a command prompt

    or download putty :
    enter enter for host name and click on open.

    in OSX you can open a terminal window and enter the command
    ssh root@

    with any option and a user: root and password: (your password)
  9. mbourd25

    mbourd25 LI Guru Member

    Hi folks, I tried everything to get the time from an NTP server, even port forwarding the NTP port on my Linksys router RTP300. Can someone suggest something to me so I could get the retreival of the time from an NTP server to work on my WRT54GL router.

  10. Zaka

    Zaka LI Guru Member

    Check this thread (at the end):

    dnsmasq does not run in WET mode and may not be running for you since you are not using the WAN port.

    As per Jon (aka Tofu) the author of Tomato:

    You may be able to get around it by adding the following to the startup script:

    rm /etc/resolv.conf
    ln -sf /etc/dmresolv.conf /etc/resolv.conf

    Reboot afterwards or try it in telnet.

    Let me know if this helps,

  11. mbourd25

    mbourd25 LI Guru Member

    HI Zaka, thanks for your help but it didn't work. I added the lines you specified from Tofu in the Administration/scripts/Init part and it still doesn't retreive the time.

    This is starting to be frustrating.
  12. Zaka

    Zaka LI Guru Member

    I don't have the router in front of me so bear with me here........

    Can you ping from the router?? (using the [i believe it's on the admin pages] ping tool? By name and/or by IP?

    How about trace route?

    Both these functions use the internal info in the router.

    My trouble was that I could reach the ntp pool servers by IP but not by domain name. That was the DNSmasq issue.
  13. mbourd25

    mbourd25 LI Guru Member

    Nope, I can't do a ping or trace form the wrt54gl. It's like the RTP300 is blocking it.
  14. Zaka

    Zaka LI Guru Member

    Can you ping the gateway router @ from the ping function in Tomato?

    This may sound silly, but we need to start with the basics......

    Ok... I was just looking at the manuals for the RPT300 at linksys.

    They recomend that you use the RPT300 BEHIND the Tomato...


    Computers connected to the WRT not the RPT. See page 11 of the Installation and Troubleshooting Guide.
  15. mbourd25

    mbourd25 LI Guru Member

    So I should connect the wrt54gl first then the rtp300? That is weird since everyone that I talked to told me to connect the vonage router first then the wrt54gl, to make that the rtp300 has the control of the flow for phone calls (QOS).

    But should I setup something special to the wrt54gl if I place the vonage router after it? Some QOS settings?

    Thanks for all your help Zaka.
  16. Reiper

    Reiper LI Guru Member

    I have my Linksys PAP2 after my WRT54GL for my VoIP service. Just set a static IP for the ATA, go into Tomato's GUI in the Qos section set the Src IP (of the ATA) as the highest and put this on the top of the list. Really shouldn't have to do much else.

    As I'm not familiar with the RTP300 so this may not work for you?
  17. StevenG

    StevenG LI Guru Member

    Well, I had a similar situation and the same problem. I'm using a Buffalo WHR-HP-G54 with Tomato 1.06 as an AP (DHCP and WAN are off) for a Verizon Fios Actiontec router.

    I also couldn't get the ntp stuff to work in Tomato. I tried everything including all the stuff in this thread. (Very helpful forums by the way).

    Anyway, I resolved it by making sure I entered DNS servers (I use OpenDNS) in Tomato under Basic Network. I have no idea why it wasn't use the dns info from the gateway router (the actiontec), but this fixed the problem so I thought I'd share it in case it helps someone else.

    Any ideas why this did it? I'm also trying to figure out the difference in Admin/Misc for setting the device as "gateway" or "router". I'm not sure what the difference is or if this has something to do with it. It's set to gateway by default, and since I couldn't find info on it, I left it alone.
  18. m078

    m078 LI Guru Member

    I had the same problem, but I think I have resolved it by specifying the IP address of my gateway (in my case, WRT54GL running Tomato 1.06) as the first entry in Static DNS.

    PS Thanks to the previous poster for helping me to realise that the issue was DNS, and thanks to Der Kief for the Tomato FAQ, which led me to this old thread as I tried to resolve my problem.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice