Problems with games and WDS on two WRT54G routers

Discussion in 'Sveasoft Firmware' started by zass, Nov 20, 2004.

  1. zass

    zass Network Guru Member

    Hi everybody,

    My configuration:

    This AP is the DHCP server for both routers, firewall disabled and I do not have an internet connection plugged in, so on both routers internet is disabled.


    Finally I've got WDS to work properly on my network with two WRT54G routers. Now when I start CS, and I make a server, the computer on the second WRT54G cannot connect, because their computer sees it as the CS server is on that router. To point it out more accurately:

    Computer #1(, DHCP received) is on AP1. Computer #2(, DHCP received from AP1) is on AP2. The CS server is running on computer #1. When computer #2 tries to connect, it detects the server as, not as Does anyone know how to fix this? I have no portforwarding tables currently in my router, and I can reach the both AP's from both computers and vice versa. Everything works, except for this! I am currently using Alchemy pre5.4a.

    Thanks in advance,

  2. 4Access

    4Access Network Guru Member


    I'm not a Sveasoft subscriber so I don't have access to Alchemy, and I've never tried exactly what you're attempting, but I have set up a few Satori WDS connections...

    1. I'm assuming that you can ping computer #1 from computer #2?
    2. What kind of WDS connection did you use, P2P or LAN? If you're using P2P I would try LAN and see if it works any better.
    3. You don't have any software firewalls running on either of the PCs do you? If you do I'd seriously consider disabling them for testing purposes. (Don't forget about the XP SP2 firewall.)

    Good luck.
  3. zass

    zass Network Guru Member

    1. Yes, i can ping the computers
    2. I am using LAN WDS... I've also read about subnet WDS, don't know if that's better ornot?
    3. All firewalls are disabled, so that cannot be the problem.

    Thank you for your response!
  4. u3gyxap

    u3gyxap Network Guru Member

    Why do you have the same IP for the gateway? Should be something different.

    If you are seeing the CS server as - it means your second router is routing, not bridging the traffic. Type from




    Also, try to disable the routing function on, and if that does not help, try to change the IP addresses of the routers to and, while keeping the computers on the with mask.
  5. zass

    zass Network Guru Member

    I have disabled the router function on both routers, it says gateway in the Advanced Routing tab of the Setup part. THere is one item in the list there:

    Destination LAN IP Subnet Mask Gateway Interface LAN & Wireless

    Also when I change the IP address of the router, the DHCP server changes the first three digit groups(so 10.0.0.x), so I cannot set it to 192.168.1.x again. Maybe I have a wrong defenition of gateway in my head, can you please explain me what it actually is??

    When I traceroute from to, is sais that the route is from direct to When I traceroute from AP1) to AP2) it has no hops in between, so it seems like a direct connection.

    Thank you very much for your help!
  6. 4Access

    4Access Network Guru Member

    For the sake of troubleshooting can you connect both computers to the same AP? This would rule out any problems with WDS etc. If it still doesn't work that would suggest the problem is more likely with the CS server.

    Also, does Alchemy include the "AP Isolation" feature? If so you'll want to make sure it's disabled. (Doubt this is an issue since you can ping from one PC to the other.)

    Lastly you might try changing the "Loopback" setting. Honestly I haven't been able to find any solid documentation explaining exactly what this feature does (would someone be willing to point me in the right direction, remembering that I don't have access to the sveasoft forums...), but I have noticed a decent number of posts where this feature was the cause of trouble...

    Update: I've found more info regarding the Loopback setting and I'd be willing to bet it's causing your problem! Disable it and let us know if things are working any better.

    Info found here and includes a packet dump showing details of what's happening for those interested.

    Oh and just for the record the Sveasoft forums are publicly readable for free, you just have to register a forum account. :oops:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice