Problems with NET USE and NSLU2

Discussion in 'Cisco/Linksys Network Storage Devices' started by davidhs, Mar 5, 2007.

  1. davidhs

    davidhs Network Guru Member

    Hey I have a problem with a new NSLU2 that we have just bougth in my company, it have been updated to FW 2.3R63. Now on our old fileserver we used a logon script or batch file when the user turn on his computer.
    The net use command looks like this.
    net use p: \\Filserver\programs "password" /User:"username" /persistent:no
    On our old fileserver this worked perfect. But on the ne Linksys NSLU2 we get an error 5 Access denied, and I have of cause set up the same users on the NSLU2 as on the old fileserver. Now the wierd thing is when I run the command from MS-dos command line, it works. And I get my share. Also if make a new share from windows and login with the username and password from the command line, then again it works. So only when i run the logon script it doesn't work. I haven't change anything when trying in command line, just copyed from the batch file and then paste ind command line and enter. Can anyone help me with this problem, it should work as I see it.

    Best regards David.
  2. bripab007

    bripab007 Network Guru Member

    Was your old fileserver an NSLU2? Probably not, right?

    I suspect you must have a relatively small company if you're using an NSLU2 as a file server, so why not manually navigate to each user's share folder on the Slug and map a network drive letter for each of them, making sure that "Reconnect at Login" is checked?
  3. davidhs

    davidhs Network Guru Member

    The other file server was the new D-link DNS-323, but we had to many problems with this one. So bougth this. Yes you are right, we could just map the drives manualy and reconnect them, but this also give us some problems, we have three drives that are mapped, first of all, username on the computeres are not the same as on the fileserver, second, when we map manual and after a reboot the user has to go the drives to kind of getting the connection. Exable, one is working with the program solid edge and he opens his files on the fileserver, all our home drives are at the file server, if he starts this program up an tries to open his last file, he get a message telling him the location is't found. So then he can open the mappen drive in my computer and then go back to the program and then it works, so we allways have to do this to kind of activate the mapped drive. When we use net use we don't need to do this, and we can put the usernames in the logon script as well.

  4. d__l

    d__l Network Guru Member

    Does the batch file run correctly if you substitute * for the password and then manually enter password when prompted by the command line?
  5. davidhs

    davidhs Network Guru Member

    Yes I have to enter the password but same error, in the meantime I have found out that it looks like the computer log on to the NSLU2 with the guest account, now in the start of my logon script I use the command IF EXIST to check if a file is located on the server and if it is then the server is online and then i trie to map the drives with NET USE. Now i tried from windows to connect to a restricted folder on the server, and I get a message that there already is a connection with a different username og password and that it is not possible to have more then one username logged on, so I have to log out and trie to connect again. So i think that when i use the IF EXIST the server convert my to guest account, it is set to do this in the server.
  6. davidhs

    davidhs Network Guru Member

    Have solved the problem now, it seems to me that in the start when I use IF EXIST then I get logged in as a guest, so after this I tried using NET USE * /DELETE /YES to delete all connection and this works for me. So everything works now.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice