Problems with WAG54G V2 EU (ftp, downgrade, etc)

Discussion in 'Other Linksys Equipment' started by vpalazis, Jan 11, 2006.

  1. vpalazis

    vpalazis Network Guru Member

    I have a Linksys WAG54G V2 EU Wireless Gateway and I am located n Greece. I had firmware version 0.00.19. Unfortunately I couldn't FTP :( . I have tried using different software (ws ftp, cute ftp, etc) but I couldn't resolve this problem. I saw that others from different countries had the same problem too. I upgraded to firmware version 1.01.27Beta. My problem with FTP was fixed but unfortunately other problems came. My internet connection became unstable and very slow. :( I then tried to downgrade to older firmware. That was impossible!!!

    What should I do? Any ideas? Can anybody help me please?
    Thank you in advance
  2. ReDFlaG

    ReDFlaG Network Guru Member

    i had the same problem when downgrading the firmware: an error occured.

    I then make a load factory default, power off/ on, then reflash with downgraded firmware.
  3. Sterge

    Sterge Network Guru Member

    Hi there,

    I had several problems like this one. Check your messages (here at linksysinfo) and email me to sort it out.
  4. vpalazis

    vpalazis Network Guru Member

    Well thanks I have tried that already, but it doesn't work. I just cannot downgrade. Any other ideas?
  5. vpalazis

    vpalazis Network Guru Member

    Thanks for the message but until now I have no answer! Any other ideas?
  6. rapoto

    rapoto Guest


    I have trouble uploading using CuteFTP. I can do everything else (e-mail, WEB, etc., but cannot upload). I saw the UPGRADE FIRMWARE infos...

    How do I do that, or any input on how to solve the issue of not being able to UPLOAD using FTP software?

  7. CaltorStorm

    CaltorStorm LI Guru Member

    WAG54Gv2 = Dodgy Model

    I realise this is an old topic but just wanted to give some feedback here.

    I too had the FTP upload problem with my WAG54G v2 so I upgraded the firmware to 1.02.00. However this caused my ps2 (Playstation 2) to stop working online which it did before. I then tried various other firmware versions none of which would allow my playstation to work online. I therefore contacted Linksys via Livechat on their website and after explaining the full situation to the engineer they have agreed to replace the router. I think that the WAG54G v2 is fatally flawed. Not sure if it is the hardware or the firmware but I don't think it is possible to get everything working on that model. :wall: As that model is now end of life the replacement router will hopefully be a more stable model that actually has a firmware that works.

    As for downgrading the firmware I have found it to be very unreliable. Sometimes if I start the upgrade, wait a while and then press Cancel Upgrades it seems to have done nothing but the firmware version in the top right has changed. I'm sure this is not advisable though and once I had to press the reset button on the back of the router to get it working again.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice