Problems with WRT54G router (loses internet connection, firmware version downgraded)

Discussion in 'Cisco/Linksys Wireless Routers' started by Jaslyn, Dec 8, 2006.

  1. Jaslyn

    Jaslyn Guest

    Okay, I'm having this extremly odd problem with my internet connection. For the past 3 days I've been losing my connection to the internet every 5 minutes or so, and in order to fix it I'd have to restart both my router and cable modem (note: I've only tried disconnecting both together, not individually). However, a quick test with my ISP has confirmed that the link between my computer and them was fine.

    Anyway, here's the problem that I face. For the last 3 days I've been losing my connection to all my computers, and on all these 3 days it seems to happen around the same time. The quick fix for it was to restart both the modem and the router, however it happens every 5 minutes so it obviously can't continue that way. There was something that I noticed though. Every single time I lost my internet connection and I tried entering the router page (, I noticed (heck, who wouldn't) that the entire layout has changed. It downgraded to a very very old firmware version (2001), which I have no idea why it did such a thing, since the router has wireless, but that firmware version does not support it. There's no logic for it to revert back to a firmware version which shouldn't be there anyway. After restarting the router it goes back to the 2006 version, and my connection's fine for awhile, but eventually it loses it again.

    It actually brought me to think that maybe it's not the connection that causes the firmware to downgrade, but the downgrade in firmware that causes me to lose my connection as it's not competible?

    Hope someone can help me. I'm really have no idea what's wrong, and my stupid father's screaming away at everyone because he's simply an ass.

    Screenshot of 2001 firmware version (not mine).

  2. ifican

    ifican Network Guru Member

    Well theres no quick easy way to figure this out, but what i would do is this:

    Clear the router back to defaults and reflash the latest firmware. You do not state if this is third party or not. If it still does not work and if its not just factory code get it back to that state and call linksys and try to get them to rma it.

    Why its doing that who really knows, a guess is that its still holding both in nvram and the pointer for the newer code gets out of whack, could be a low voltage situation, but whatever it is, its causing the router to reboot and read the old code vs the new. The router should be fairly resilient to intermittent line voltage spike and dip. So as long as no other devices are having grave issue at the same time its got to be the power supply or the motherboad. Either way needs to be replaced.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice