Problems with WRT54GS, wireless, large file transfers

Discussion in 'Cisco/Linksys Wireless Routers' started by AMurderOfCrows, May 29, 2005.

  1. AMurderOfCrows

    AMurderOfCrows Network Guru Member

    I've about had it here...

    never used the wireless on *THIS* router till this week, except to browse the net once a LONG time ago. used to have a DLink though that worked great.

    Router: WRT54GS (serial says 1.1, sysinfo says 2.0)
    Firmware: Alchemy 1.0 public, alchemy rc6, offcial 3.17.4, Beta 4.50.5


    I started out by trying to install software on my new laptop over the wireless network. I set up the security properly, made sure everything was alligned, turned off Wireless Zero Configuration on the laptop, and tried to run the install file.

    I got an error saying "network name no longer availible" after about 30 seconds into the install

    i tried several times to install remotely, then i tried to transfer the files. smaller files went thru just fine, but it choked on an ISO of about 600mb.

    i reset and ran the network setup wizard a few times to make sure it wasn't a problem with the network settings. No joy.

    upgraded firmware to Alchemy 1.0 public. Weirdness happened here....a javascript pop up said the upgrade failed, but the web UI refreshed, saying the upgrade succesful. still no joy. EDIT: i think this is due to a corrupted FireFox installation. seemed to work ok in IE

    looked in the forums, found out about the commands for NVRAM. entered them in the Diagnostics page of the router setup GUI.

    Still no joy. in fact, i couldn't confirm that the CLKFREQ=216 setting did anything at all, as i could find no way to verify the clock speed. EDIT: was using the Diagonostics command interface instead of Telnet. None of the posts gave proper instructions for issue NVRAM commands, but i figured it out

    Frustrated, i looked some more and decided to rollback my firmware to an offcial one. went back to 3.17.4. Still no joy. Tried the Beacon setting, still wouldn't work.

    FInally, tried the beta firmware 4.50.5. now, instead of stalling out at 9 minutes remaining like it used to, it stalls out at 2 minutes remaining.

    I'm really upset.....not only did i lose Static DHCPd, all my firewall and port trigger/forwarding settings, but i *STILL* can't transfer large files over wireless.

    does *ANYONE* have a solution? i want my QoS and my DHCPd abilities back, and i need to be able to transfer my files to and from the laptop.

    EDIT: Tried out DD-WRTprefinal5 build 28.05.2005. back to stalling at between 6 and 9 minutes. set clkfreq via telnet, no change. can't figure out what to do next :'-(

    thank you
  2. malfeasance

    malfeasance Network Guru Member

    Clock Speed

    Do you know if you have actually set the clock speed?

    There are instructions I saw in a thread here of how to set it, but they were not quite right. They forgot the "set" command.


    nvram set clkfreq=216
    nvram commit

    Then check with:

    nvram get clkfreq

    I assume you already figured this out. Also, people have been getting good results with 235 as well, and speeds in between. I have heat sinks with ArcticSilver on my CPU's so I might worry less about overclocking's longterm results less than others might. However, I guess this is not a priority for someone whose router isn't performing otherwise.

    I have a GS v1.1 which seems to be the GS version of the G v2.2. I tried to set the clkfreq and bricked it. Got it back, though, with a little work. Had to hold the reset button down for over a minute. Anything less and it didn't reset to allow me back in. Maybe that isn't the right command, at least for my router.
  3. AMurderOfCrows

    AMurderOfCrows Network Guru Member


    Yeah i got the clock command right, i just didn't know where to put it in....finally figured it out via telnet.

    gonna reflash with alchemy 1 tomorrow to see if it helps...otherwise, going back to the beta and RMA'ing it this weekend

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice