Problems with WRT54GSv4 running v1.23 in AP+WDS mode

Discussion in 'Tomato Firmware' started by eegorr, May 21, 2009.

  1. eegorr

    eegorr Network Guru Member

    I am running two of these routers in my home. A couple of weeks ago I loaded Tomato v1.23 on a third (backup) router and ran it connected to my gateway router (running Thibor 15c) for a while, just to give me a chance to play with the interface. It seemed to work okay, so I set it up to replace my gateway router, and everything has been fine. I was even able to change the theme on this router, which gave me a chance to play with user scripts.

    A few weeks ago, I loaded the same version of Tomato on my remote ap router, cleared NVRAM completely (which I did with the gateway router as well), and set it up to run connected via AP+WDS. This is working fine, and I have two laptops connected wirelessly and a third computer connected via RJ45 thru the remote ap to my gateway router, and all have internet access.

    My issues are peripheral but they are puzzling, nonetheless:

    1) The time on the remote ap will not set itself. I have it set up exactly the way the gateway is set up, which is updating fine: time zone set properly, update hourly, and using the default NTP time servers (I also tried using the US servers setting).

    2) I tried to set up an alternate theme, the way I did with my gateway router, but I could not get it to work. After a little investigation, I found that none of the scripts (Init, Shutdown, Firewall, or WAN Up) will run! I put dummy "logger" commands in each script just to see if and when they are running but could not find corresponding entries in the log file. The scheduled scripts are not working, either, but I'm guessing that this is because the time has not been set.

    Could both of these problems be related to the same thing, like a daemon that did not start properly?

    Is anyone running a similar configuration? Any ideas?

    BTW, I have a CIFS drives set up that connects to a server computer connected to my gateway computer and that is working fine. I also have a 1MB JFFS2 drive set up in NVRAM.

    Attached is a clean log file starting with a fresh reboot. Note that each of the scripts has something like this in it:

    logger starting Init script...

    logger Init script completed.

    and there is nothing in the log file for any of them.

    Attached Files:

  2. sigma

    sigma Addicted to LI Member

    I have two routers in WDS, one of them is a WRT54Gv4 and the other one WRT54Gv2.2; the v4 is the main and i load a Thor MOD v5 firmware on it, and running smoothly, i have similar issues with my repeater AP, and after doing several things i got it properly configurated, this is what i did:

    Router MAC Address XXXXXXXXXXXX
    Router IP Address (using the next available after the main)
    Subnet Mask (same subnet in both)
    Gateway (put the routers main ip as the repeater gateway)
    DNS (its imperative to put the main router ip as your DNS as well)
    DHCP Disabled

    With this conf i manage to run one router (main with Thor MOD as i said so) and the other one (repeater with latest Victek MOD); both of them running with the same WL drivers to avoid errors between WDS.

    The second thing, i did have an issue with the skin change; but the thing is i realise when i read the logs the problem was simple, the CIFS not loaded properly due a fact of timming, you should try add in the firewall script section something like this...

    sleep 15 #This is it, 15 seconds of sleep give a chance to load the things in time
    mkdir /var/wwwext
    cp /cifs1/repe/custom.css /var/wwwext/custom.css

    The final lines are the load of the skin itself.

    I hope this may help you out. Grettings!
  3. eegorr

    eegorr Network Guru Member

    Thanks for your reply. I tried setting the static DNS address to that of the main router but nothing has changed. Everything else was already set up as you suggested.

    UPDATE: Since I started writing this reply more than an hour ago, the time has now updated itself! I went back and looked at the setup pages I saved from my Thibor setup and, sure enough, the DNS was set to the same address as the gateway, so this issue is resolved. Thanks for the tip!

    As for loading the skin, I already tried adding delay to the beginning of the script but could not get it to work. That is what led me to add dummy scripts for all four conditions, just to make log entries when they start and finish. From this, I learned that, for some reason, the scripts are never even being run!

    I am starting to think this may be a bug. What version of Tomato are you running under those mods, anyway?

    One more question - under Advanced/Routing setup, Miscellaneous section, should the remote router (non-gateway) be set to router or gateway? I've tried it both ways and it doesn't seem to matter. How do you have yours set up?
  4. sigma

    sigma Addicted to LI Member

    Well, first of all im glad the time setup configure works for you, second im tried the same skin loader script in a lot of Tomato versions, the 1.23 original, the Keith Moyers VPN mod, the Victek Mod, and the Thor Mod, in all of them works just fine; im curious where did you put the skin loader script? if you putted on the init section it wont work (as i said the delay boot normal time of the router), the script must be in the firewall section (i know you may experience abnormal responses from your router and seems not to work) maybe you need to restart your router a few times, but i recommend to you a way to discard things and inconviniences, set a telnet session o ssh and go to the dir where the router suppouse to copy the cifs files from if nothings there, maybe you need to check the spell of the lines one by one and make the resets. the last would be setting the lines manually in the telnet or ssh session something like "cp /cifs1/myrepeaterskin/custom.css /var/wwwext/" and very important give it some time to load properly, maybe a few seconds or a two minutes perhaps!

    Your question about Advanced/Routing setup my actual conf setup is: the main as gateway and the repeater as router (i also shut down practically all the features), and my latency times seems to improve due to inconsistencies in the original conf (both in gateway mode); i think the main reason is because when you use your router as gateway all the firewall, NAT, and special stuff works and make some interference beetwen routers, and when you use your repeater as a router all of that wont have any effect, they just shutdown in theory, as the wiki say

    I hope this help you out some how. Greetings!
  5. eegorr

    eegorr Network Guru Member

    I was loading the theme in the Firewall script, but it did not appear to be running at all. I messed around with the delays a bit but it mysteriously started working, even with little or no delay. After that, I copied my theme files to a JFFS partition so that the router would have a local copy of them, then I set up a scheduled script to update the JFFS version periodically from /cffs1.

    One thing I found out for sure was that the scripts were probably running when started with no delay but the process that accepts user log entries (logger) hadn't started yet, so there was no entry made in the log. That makes sense.

    As for router vs gateway in Advanced/Routing, I tried it both ways and it didn't seem to make any difference. Perhaps there is less overhead in router mode, but this router runs with almost no CPU load most of the time so I'm not going to worry about it.

    BTW, I tried loading Tomato v1.24, which was released a couple of days ago, and nothing would connect wirelessly! The router would connect to my gateway via WDS, but neither of my laptops could connect to it. They connected easily to my gateway router ap, which was still running v1.23. I switched back to v1.23 and all is working fine. I actually did this twice, just to be sure I hadn't done anything wrong.

    Have you tried upgrading to v1.24 yet? If so, did it work for you?

    Thanks again for your help...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice