Problems with WRT54GX v2 EU version

Discussion in 'Cisco/Linksys Wireless Routers' started by dionysosdale, Jan 9, 2006.

  1. dionysosdale

    dionysosdale Network Guru Member

    I have had problems with my MIMO routers (WRT54GX v2 EU) since i bought it.

    First I had problems with speed on my broadband. When accessing sites and downloading, I got poor speeds and responsetime. When i upgraded to EU firmware 2.0.10 things where getting better.

    Yesterday there were some problems with the power/eletricity in the neighborhood. The lights where blinking and my computers and equitment, including the MIMO router, rebooted several times during the day.

    After that i have had problems with my router again. I get internet access, but the router freeses for 15-12 secs every time i try to access internet. If i put on a ping -t on a site, i get good response times, but when i try to access a web page or something else on the internet, I get seven timeout on the ping, before the pinging continues. This happens no matter which machine i use.

    I tried connecting my pc directly to my ADSL modem, and it workes fine. So the problem is on my MIMO router.

    I also have problems upgrading the firmware now. I downloaded the WRT54GX v2 EU 2.0.12 firmware and try to install it on the routers web interface. I select the firmware and press upload. The status bar starts to count for 5 sec. then the screen gets blank. After waiting over 10 minutes just in case, i reboot the unit, but the firmware is not installed. I have tried this many times, from both IE and Firefox, and from several computers.

    Is there other people having the same problems as me with this router? I'm getting really fustrated with it. Please help me if somone have anything to contrbute with...

  2. dionysosdale

    dionysosdale Network Guru Member

  3. Astronut

    Astronut Network Guru Member

    Just been doing a search on 'WRT54GX-v2' and I came across this post. It's a couple of months old now and you've probably given up but here's the solution.

    I just got a WRT54GX-v2 and I was having the exact same problem upgrading firmware - progress bar starts and gets to about 10-15% then page goes blank.

    Connection is via ethernet.

    I searched on these forums and the solution that worked for me was to temporarily set the speed of the ethernet card to 10Mbps half-duplex before firmware installation.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice