PROSET Wireless 3945ABG - Not receiving a IP on WRT54GX

Discussion in 'Cisco/Linksys Wireless Routers' started by HansVDG, Feb 8, 2006.

  1. HansVDG

    HansVDG Network Guru Member

    Hi ,

    I just received a new laptop via work :

    Asus V6J - Yohan + PROSET Wireless 3945AGB + Win XP SP2

    I'm trying for a couple of days now, to receive a IP adres from my router.


    PLEASE HELP, !!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  2. howardp6

    howardp6 Network Guru Member

    What type of of encryption are you using? If you are using WPA install the WPA2 hotfix from the Microsoft website. If using WEP de-install the WPA2 hotfix, since it is known to cause problems with WEP. Try setting the router to use no encryption and see if you can connect. Do not use MAC address filtering and enable SSID broadcast. Is the router connecting to the Internet? It willl not give out IP Address if it is not connected to the Internet. Are you using a cable or DSL connection. Cable coonections require you to power down everything and then powering up the cable modem, router and computer in that order. Make certain you have latest generic Proset Wireless 3945AGB drivers from the Intel website installed. Is the Wireless 3945AGB set to use 802.11A? Make certain the the Wireless 3945AGB is set to 802.11G.
  3. HansVDG

    HansVDG Network Guru Member

    Encryption : I tried everything .
    Without encription : when acquiring IP :> problem

    I installed the latest drivers.

    I set the power management to MAX. Resolved one problem.

    Must I set ohter settings of the adapter.

    How can I remove the FIX. ???

    In the eventvwr of wireless , when trying to connect via WPA. => RSN duplicate message ( or something like that ) .
    PSK failed . ?????????

    Already tnx for the reply
  4. HansVDG

    HansVDG Network Guru Member

    Forgot something :
    When I received the laptop, It worked only ones. Then afterwards no more.

    I restored the laptop with the restore CD, but nothing works
  5. HansVDG

    HansVDG Network Guru Member

    DETAILED event log when using WPA :
    attach not working :
    #Event,Source,Time,Error Severity,Domain,User,Description
    1,MurocApi,02/08/2006 16:16:35,Error,General,Hans,AddExcludeListEntry- exclude list not supported!
    2,Dot1XConfig,02/08/2006 16:16:35,Information,Security,Hans,<State> Stopped (BUGGYWIRE2).
    3,EOU,02/08/2006 16:16:35,Information,Connection,Hans,EOUCONFIG: Received Authentication fail event.
    4,Dot1XConfig,02/08/2006 16:16:35,Information,Security,Hans,<Status> Stopped (BUGGYWIRE2).
    5,Dot1XConfig,02/08/2006 16:16:35,Error,Security,Hans,<Status> Possibly incorrect PSK key (BUGGYWIRE2).
    6,Dot1XConfig,02/08/2006 16:16:35,Information,Security,Hans,Stopping authentication due to authentication failure.
    7,Dot1XConfig,02/08/2006 16:16:35,Information,Security,Hans,Stopping authentication due to authentication failure.
    8,EOU,02/08/2006 16:16:35,Information,Connection,Hans,EOUCONFIG: Received Authentication fail event.
    9,Dot1XConfig,02/08/2006 16:16:34,Warning,Security,Hans,<Status> RSN multiple first message (BUGGYWIRE2).
    10,Dot1XConfig,02/08/2006 16:16:33,Information,Security,Hans,<State> Connecting (BUGGYWIRE2).
    11,Dot1XConfig,02/08/2006 16:16:33,Information,Security,Hans,<Status> Link up (BUGGYWIRE2).
    12,Dot1XConfig,02/08/2006 16:16:33,Information,Security,Hans,<State> Unauthenticated (BUGGYWIRE2).
    13,Dot1XConfig,02/08/2006 16:16:33,Information,Security,Hans,<Status> Link down (BUGGYWIRE2).
    14,Dot1XConfig,02/08/2006 16:16:33,Information,Security,Hans,<State> Authenticating (BUGGYWIRE2).
    15,Dot1XConfig,02/08/2006 16:16:32,Warning,Security,Hans,<Status> RSN multiple first message (BUGGYWIRE2).
    16,Dot1XConfig,02/08/2006 16:16:31,Warning,Security,Hans,<Status> RSN multiple first message (BUGGYWIRE2).
    17,Dot1XConfig,02/08/2006 16:16:30,Warning,Security,Hans,<Status> RSN multiple first message (BUGGYWIRE2).
    18,ZCfgSvc,02/08/2006 16:16:29,Information,General,Hans,Looking for a matching profile.
    19,ZCfgSvc,02/08/2006 16:16:29,Information,General,Hans,Scan found 1 networks.
    20,Dot1XConfig,02/08/2006 16:16:29,Information,Security,Hans,InitializeEx- initializing adapter list!
    21,IWA,02/08/2006 16:16:29,Information,Adapter,Hans,Link up event from the adapter.
    22,EOU,02/08/2006 16:16:28,Information,Connection,Hans,Received linkup event
    23,Task Tray,02/08/2006 16:16:29,Information,General,Hans,End scan event from the service.
    24,IWA,02/08/2006 16:16:29,Information,Adapter,Hans,Scan end event from the Service.
    25,Dot1XConfig,02/08/2006 16:16:29,Warning,Security,Hans,<Status> RSN multiple first message (BUGGYWIRE2).
    26,Task Tray,02/08/2006 16:16:29,Information,Adapter,Hans,Link up event from the adapter.
    27,Dot1XConfig,02/08/2006 16:16:28,Information,Security,Hans,<State> Connecting (BUGGYWIRE2).
    28,Dot1XConfig,02/08/2006 16:16:28,Information,Security,Hans,<Status> Link up (BUGGYWIRE2).
    29,IWA,02/08/2006 16:16:27,Information,Profile,Hans,Profile update/added event from the Profile database.
    30,Dot1XConfig,02/08/2006 16:16:27,Success,Security,Hans,CCX functionality enabled.
    31,MurocApi,02/08/2006 16:16:27,Information,General,Hans,Profile BUGGYWIRE2 for BUGGYWIRE2 being applied.
    32,Dot1XConfig,02/08/2006 16:16:27,Information,Security,Hans,InitializeEx- initializing adapter list!
    33,Dot1XConfig,02/08/2006 16:16:27,Information,Security,Hans,<State> Unauthenticated (BUGGYWIRE2).
    34,Dot1XConfig,02/08/2006 16:16:27,Information,Security,Hans,<Status> Started (BUGGYWIRE2).
    35,Task Tray,02/08/2006 16:16:27,Information,Profile,Hans,Profile orderupdate/update/added event from the profile manager.
    36,IWA,02/08/2006 16:16:25,Information,Adapter,Hans,Scan start event from the Service.
    37,Task Tray,02/08/2006 16:16:25,Information,General,Hans,Start scan event from the service.
    38,ZCfgSvc,02/08/2006 16:15:55,Information,General,Hans,Looking for a matching profile.
    39,ZCfgSvc,02/08/2006 16:15:55,Information,General,Hans,Scan found 1 networks.
    40,Task Tray,02/08/2006 16:15:55,Information,General,Hans,Networks available event from zero config.
    41,IWA,02/08/2006 16:15:55,Information,Adapter,Hans,Scan end event from the Service.
    42,Task Tray,02/08/2006 16:15:55,Information,General,Hans,End scan event from the service.
    43,S24EvMon,02/08/2006 16:15:54,Information,AppDriver,SYSTEM,Intel adapter(s) found.
    44,S24EvMon,02/08/2006 16:15:54,Information,AppDriver,SYSTEM,Getting List of adapters.
    45,IWA,02/08/2006 16:15:52,Information,Adapter,Hans,Scan start event from the Service.
    46,Task Tray,02/08/2006 16:15:52,Information,General,Hans,Start scan event from the service.
    47,S24EvMon,02/08/2006 16:07:36,Information,AppDriver,SYSTEM,InitializeAdapters.
    48,S24EvMon,02/08/2006 16:07:36,Information,AppDriver,SYSTEM,Removing all adapters.
    49,S24EvMon,02/08/2006 16:07:36,Information,AppDriver,SYSTEM,Add Intel Adapter.
    50,S24EvMon,02/08/2006 16:07:39,Information,AppDriver,SYSTEM,Adding adapters.
    51,S24EvMon,02/08/2006 16:07:39,Information,AppDriver,SYSTEM,Success: Adding adapters.
    52,S24EvMon,02/08/2006 16:07:39,Information,AppDriver,SYSTEM,FindAdapterChanges.
    53,S24EvMon,02/08/2006 16:07:39,Information,AppDriver,SYSTEM,Removing all adapters.
    54,S24EvMon,02/08/2006 16:07:39,Information,AppDriver,SYSTEM,Success:Removing all adapters.
    55,S24EvMon,02/08/2006 16:07:39,Information,AppDriver,SYSTEM,Adapter is Bound
    56,S24EvMon,02/08/2006 16:07:39,Information,AppDriver,SYSTEM,Add Intel Adapter.
    57,S24EvMon,02/08/2006 16:07:41,Information,AppDriver,SYSTEM,Adding adapters.
    58,S24EvMon,02/08/2006 16:07:41,Information,AppDriver,SYSTEM,Success: Adding adapters.
    59,S24EvMon,02/08/2006 16:07:43,Information,AppDriver,SYSTEM,Getting List of adapters.
    60,S24EvMon,02/08/2006 16:07:43,Information,AppDriver,SYSTEM,Intel adapter(s) found.
    61,S24EvMon,02/08/2006 16:07:46,Information,AppDriver,SYSTEM,Getting List of adapters.
    62,S24EvMon,02/08/2006 16:07:46,Information,AppDriver,SYSTEM,Intel adapter(s) found.
    63,EOU,02/08/2006 16:07:47,Information,Connection,Hans,EOUCONFIG: Received RF Toggle event.
    64,S24EvMon,02/08/2006 16:07:48,Information,AppDriver,SYSTEM,Getting List of adapters.
    65,S24EvMon,02/08/2006 16:07:48,Information,AppDriver,SYSTEM,Intel adapter(s) found.
    66,ZCfgSvc,02/08/2006 16:07:48,Information,General,Hans,Timer interval over-ridden : 30000 msec.
    67,ZCfgSvc,02/08/2006 16:07:49,Information,General,Hans,Restoring XP in control.
    68,Dot1XConfig,02/08/2006 16:07:50,Success,Security,Hans,InitializeEvTrace
    69,S24EvMon,02/08/2006 16:07:51,Information,AppDriver,SYSTEM,Getting List of adapters.
    70,S24EvMon,02/08/2006 16:07:51,Information,AppDriver,SYSTEM,Intel adapter(s) found.
    71,Task Tray,02/08/2006 16:07:51,Information,Adapter,Hans,Control switched from Intel PROSet/Wireless to Microsoft Client.
    72,Dot1XConfig,02/08/2006 16:07:50,Information,Security,Hans,InitializeEx- initializing adapter list!
    73,Dot1XConfig,02/08/2006 16:07:51,Information,Security,Hans,Successfully initialized XIXA!
    74,Dot1XConfig,02/08/2006 16:07:52,Information,Security,Hans,Initialization- new adapter (MAC=00:13:02:08:A8:52, port={77E013D1-10C2-42A3-AFF3-F58FBD6949FB}).
    75,Dot1XConfig,02/08/2006 16:07:52,Information,Security,Hans,<State> Stopped.
    76,S24EvMon,02/08/2006 16:07:52,Information,AppDriver,SYSTEM,Getting List of adapters.
    77,S24EvMon,02/08/2006 16:07:52,Information,AppDriver,SYSTEM,Intel adapter(s) found.
    78,Dot1XConfig,02/08/2006 16:07:51,Information,Security,Hans,CtaInit- acCTAInit FAILED (expected=0, actual=-21).
    79,Dot1XConfig,02/08/2006 16:07:52,Warning,Security,Hans,CTA plugin is not installed or supported.
    80,Dot1XConfig,02/08/2006 16:07:52,Information,Security,Hans,Xixa successfully attached to port {77E013D1-10C2-42A3-AFF3-F58FBD6949FB}.
    81,Task Tray,02/08/2006 16:10:04,Success,Connection,Hans,NCPA change event from the adapter.
  6. howardp6

    howardp6 Network Guru Member

    Do you have 802.11X enabled on your wireless NIC, when you are using WPA? If you do disable it. As for the hotfix the Hotfix is Windows XP Hot fix KB893357, You should look at the add remove programs in the control panel for it. Are you using WPA or WPA2? AES and/or TKIP. Have SSID broadcast enabled. Which firmware version do you have on the WRT54GX and which model of the WRT54GX do you have. If you have the latest firmware for the WRT54GX. use WPA/WPA2 Personal AES + TKIP. Make certain you type in the key exactly the same. You may have a choice of ASCII or HEX keys. Pick hex keys, since Linksys only uses HEX keys. Make certain that the key length specified is the length of your key. The Intel Proset NICs do not like short key. Are you using their client or WZC?
  7. HansVDG

    HansVDG Network Guru Member

    802.11X => enabled ( where to set , I only set to use g mode )

    No hotfix was installed ( not in list, but Laptop came with xp on it )

    I want to use WPA - TKIP

    SSI broadcast is enabled

    WRT54GX firmware : 2.00.12

    I use the intel client

  8. howardp6

    howardp6 Network Guru Member

    The 802.1X is usually set in the advanced security setting of the Wireless Client or the properties on the authentication checkbox of the wireless network in WZC service.
  9. phatteus

    phatteus Network Guru Member

    Same problem here:
    Acer w/ Yohan
    Intel 3945 ABG with latest driver
    Linksys WRT54GX4 with firmware 1.00.10
    WPA Personal TKIP, 13 digit key

    See's the network, autheticates, but can't grab in IP address.

    I happen to have a WRT54G (latest official firmware) too, so I set it up with WPA Personal TKIP and the same key and the wireless works fine, so I would conclude that the Intel 3945 doesn't like the WRT54GX.

    Maybe I can get my hands on the 1.00.12 firmware I keep hearing about.
  10. HansVDG

    HansVDG Network Guru Member

    My firmware : EU version
  11. howardp6

    howardp6 Network Guru Member

    Try changing the channel to auto, which turns off the adaptive channel bonding. Good luck.
  12. phatteus

    phatteus Network Guru Member

    I turned off the adaptive channel bonding, but no luck, same problem.

    Linksys support said that 1.00.12 wouldn't help me and that it sounded like an Intel problem. Guess we'll have to wait.
  13. HansVDG

    HansVDG Network Guru Member

    Problem solved for me.

    This was posted on the ASUS forum :

    I had the missing IP problem too... and as I wrote in an earlier post it suddenly went away. I then had to restore everything for another reason, but after the restore the wifi problem reoccured. Now after 6 hours of trying everything it suddenly started working again - and this time I actually think I found the solution, which works for me... Maybe it's not the solution to all of the issues mentioned in this thread, but anyway I post it :)

    I've found out that when I have my wifi on/bluetooth off (using the wireless console 2 or Fn+F2) I'm able to see som networks around. When wifi off/BT on I can't see any of course. But if I turn both off, and then BT on first, and then turn on wifi so their are both turned on (and in that particular order) I can see even more networks and it actually connects and recieves an IP-adress. As soon as I choose other combinations og BT/WIFI on/off or turn them on in another order the problem reoccures.

    I hope it'll be helpfull to someone too!

    I know it sounds too simple - but give it a try.

  14. DominicM

    DominicM Guest

    Thanks for that

    i have a V6J also, and could not work this out, it seems a bit odd that bluetooth needs to be on for wlan to work....

    this wasnt just a netgear problem for me, it was all wlans i tried to connect to.

    Asus technical support told me to uninstall and reinstall the driver. and wanted to take the notbook back for repair!!

    surely this is a bug, i hope they fix it in later revisions of the driver.
  15. phatteus

    phatteus Network Guru Member

    The bluetooth toggle didn't work on my Acer laptop and an interesting update:

    Today I got a new Mac Mini with the Core Duo. It can't connect to the GX4 via either Ethernet or Wifi!

    It connects fine to a WRT54G, so it certainly is the GX4.
  16. mlai

    mlai Network Guru Member

    I think the Intel Wireless NICs are very quirky with MIMO APs and TKIP encryptions. I have the Sony TX17GP. Prior to this, I had the TR1 and the T17GP. All of these use the Intel 2200BG chipset.

    When I connect to my WRT54GXv2 using WPA/TKIP or WPA2/TKIP, the laptops very frequently cannot associate. Sometimes when it associates, it cannot obtain IPs. And sometimes when it associates and get an IP, the laptop will drop the connection from anywhere between 5 mins to 60 mins into the connection.

    However, when using WPA/AES or WPA2/AES, the connections are flawless. The NIC can always connect to the APs and never drops connections.

    Try the same laptops with the same settings on WTR54GS and the WRT54GC, neither of these exhibit the problems with SRX series routers.....
  17. howardp6

    howardp6 Network Guru Member

    The TKIP only option does not work with either WPA/Personal or WPA2/Personal, Trey AES+TKIP. According to the WPA2 IEEE standard the TKIP will work for legacy none WPA2 clients.
  18. mlai

    mlai Network Guru Member

    Unfortunately, some clients (WPA/TKIP) cannot connect under AES+TKIP for most of the Linksys routers (mostly Windows Mobile 5 devices). The only Linksys router where I see this working is the WRT54GC which uses a Marvell chipset internally. None of the WRT54GS/WRT54GXv2/WTR54GS can work with WM5 devices in AES+TKIP mode.
  19. rcruzat

    rcruzat Guest

    Found one solution

    Hi there, I had the same problem with a dell inspiron an intel pro wireles 3945. I found two solutions.

    1.- Use Ubuntu and works fine.
    2.- After a while y found that when the computer is in battery saving modes (any), the card stopped reciving the ip address from de DHCP server.So just put in Desktop or office profile.

    Sorry for my pour english. Hope it work for all of you.

    Any questions at

    rcruzat (at)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice