[Ps Help] Problem reflashing WRT54GS

Discussion in 'Other Linksys Equipment' started by Deleted member 11179, Jul 18, 2006.

  1. Hi guys,

    Please help me.

    What happened was that I flashed my WRT54GS v4 with OpenWrt White Russian RC4 firmware.

    Got locked out as I accidentally input a password which I did not remember. Found a 'solution' posted on WRT's forums by an ex-developer: http://forum.openwrt.org/viewtopic.php?pid=16200

    I followed the steps listed:
    1) Login via Telnet, SSH or even a serial console
    2) reset to the default /etc/passwd file. On SquashFS images do that with
    rm /etc/passwd*
    ln -s /rom/etc/passwd /etc/passwd[/i]
    3) remove /etc/httpd.conf
    [i]rm /etc/httpd.conf[/i]
    4) reboot
    5) while rebooting it's recommended you start your web browser again
    When this is done you can login via Telnet again or set a new password in the webif.
    If all the above doesn't helped you've to erase the JFFS2 partition with:
    [i]mtd -r erase OpenWrt[/i]
    The good thing was that I managed to get into the console. Problem was that I could not update the flash rom using my browser. The page would reload back to the same spot and the rom would not be updated. Resetting it on the back would not help either.

    Also tried to use the tftp method to update the rom but it always says 'Timeout occured' even though I can access the router via telnet. Odd thing is that I can access the telnet at that same IP address So what does the tftp get a Timeout whereas Telnet has no problems.

    Also, ever since I followed the developer's instructions, I am not able to create or change the password in both the web browser interface and in telnet.

    Really appreciate it if someone can help me ... All I want to do is that change the rom back to linksys' official one to avoid this whole sage :(

    PS: As telnet is working fine (very strange thing is that I'm able to telnet the router regardless of whether I put the router to failsafe mode (http://wiki.openwrt.org/OpenWrtDocs/Troubleshooting#head-3b76effc0c1bf08b531bb8277c9108764e2021e3)
  2. Toxic

    Toxic Administrator Staff Member

  3. Thanks man. If only I had posted here earlier ... Took me 6 hours of frantic screaming and getting no where before I decided to ask for help.

    They really don't call you an 'Administrator' for no reason :)

    Thanks once again. Worked like a charm. Wondered why they didn't emphasis this feature ...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice