PS3/PSP Can't Get IP after installing Tomato

Discussion in 'Tomato Firmware' started by Ahlitah, Feb 25, 2008.

  1. Ahlitah

    Ahlitah Network Guru Member

    okay i've had this prob with the last 3 versions i've tried. I want to use tomato on my linksys wrt54gl. but with it installed on my router, my ps3 can't get an IP from DHCP on the router and same with my PSP. It keeps timing out. It works fine with linksys firmware but on tomato I just can't connect with those devices anymore.
  2. houman

    houman LI Guru Member

    make sure the SSID is input correctly on the PS3/PSP, I believe the default SSID from Tomato might be different than the Linksys firmware. Also might want to connect w/o encryption first to see if it works, then move on to encryption.
  3. Ahlitah

    Ahlitah Network Guru Member

    it finds the access point, and then moves onto getting an IP via DHCP sits there for 3 min then gives me a dns time out error. So the SSID is correct/

    then I was reading more on this forum about DHCP errors and such and disabled nat loopback / or fully enabled thing) thing and I got an IP but then it gives me a DNS error when trying to load anything.
  4. c007c

    c007c LI Guru Member

    What channel are you on, be sure its 1,6,11 ...Are you in mixed mode?
  5. Ahlitah

    Ahlitah Network Guru Member

    i'm on channel 6, though the ps3 is wired, and the psp is wireless. Yes I am in mixed mode as well.
  6. c007c

    c007c LI Guru Member

    Try B for a test with B only on the PSP...This was an issue in other firmwares like DD-wrt
  7. c007c

    c007c LI Guru Member

    I don't have a Ps3 but I have xbox360 and PSP. Both work on Tomato 1.16...I didn't have to do anything other than plug them in after upgrading from DD-WRT...The only thing I noticed migrating was weird leftovers in my nvram that caused other problems than yours that I couldnt explain. I had to choose the erase all memory in nvram option, start over, and they went away.... turns out just doing a reset didn't clear everything...
  8. Ahlitah

    Ahlitah Network Guru Member

    well that didn't work, but I found an option I thought I would try for the heck of it, and it seems to work even though I don't have a static ip..

    I put a check next too "Use Received DNS With Static DNS"
  9. c007c

    c007c LI Guru Member

    Thats weird. What firmware version are you running?
  10. Ahlitah

    Ahlitah Network Guru Member

    the latest 1.16

    I also checked reduce dhcp packet size across wan, don't know if that makes a diff or not.

    Seems to work now though....don't know why that option worked..I was about go back to to linksys org firmware, but I thought I would try every option and see what happens!
  11. PeterT

    PeterT Network Guru Member

    That option has nothing to do with Static IPs. What it does when checked is to suipply the DHCP client (ie the PSP) with whatever DNS IP addresses are supplied by your ISP along with whatever DNS entries you have coded on the Router / Basic setup screen. If thst is not checked, I believe you will only supply to your clients the values coded in the Router / Basic screen.
  12. Ahlitah

    Ahlitah Network Guru Member

    oh.. interesting... someone should explain what all these options do! I went to the wiki but nothing on this there.

    Guess thats why its working now!
  13. jpreynolds

    jpreynolds Guest

    Flustered PS3

    I must run my PS3 through a DMZ. If I do not, the PS3 network states that I have a NAT type 3.
    I would recommend trying running yours through a DMZ first to see if it works. If not there might be more underlying problems.:cool:
  14. Ahlitah

    Ahlitah Network Guru Member

    thanks but I didn't need to put it through a DMZ. As I said above just by enabling the "Use Received DNS With Static DNS" option, it magically started to work.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice