QOS not working properly in v23?

Discussion in 'DD-WRT Firmware' started by JensG, Dec 27, 2005.

  1. JensG

    JensG Network Guru Member

    I have been very pleased with the way QOS has been working with my SIP adaptor in v22r2.

    I updated to v23(dd-wrt.v23_mini_generic.bin), and set up QOS as it was in v22. But it didn't seem to have any effect. Using the Internet from our computers while speaking on the VOIP phone really disturbed the conversation, so I had to go back to v22r2

    The way I have set QOS up is as follows:
    Down: 920kb/s Up: 230kb/s (1024/256)
    LAN port with the SPA2000 adaptor is set to Premium, the others to Bulk.
    IP address for the SPA2000 adaptor set to Premium, IP's for other connected units set to Bulk.
    Added a service that I called VOIP covering UDP 16384-16482 and set that to Premium.

    This works very well with v22r2, but appearently not with v23.

    Any ideas why?
  2. will792

    will792 Network Guru Member

    I tested my installation of v.23 by running SBC Yahoo speed test while accessing my voice mail. It worked fine.

    I have a similar configuration as you do. My TA is SPA3000 and I gave it Priority by MAC, DNS, RTP and SIP port ranges are Priority, POP3 is bulk and the rest is not defined. My connection is 1500/328 DSL with real speed 1300/327. I use 1190/273 for QOS reservation. The codec for VOIP is G711u. The router is WRT54GS v.2.1 with mini version of dd-wrt.

    I still get the same mysterious message in the log "<4>kernel: ip_nat_mangle_udp_packet: undersized packet" as in v.22r2 but it does not seem to do any harm. It bugs me somewhat but once again no visible harm.
  3. yakety

    yakety Network Guru Member


    Is it normal that, when i am on the QoS menu, and I edit a service i have all services with 0~0 ??

    And I have created a service, I see it in the edition menu, but I can't select it in the principal page ?

    Thank you for your answers.
  4. will792

    will792 Network Guru Member

    Re: QOS

    Do you use Firefox? I had a similar problems in FF but everything worked as expected in IE. Some services have 0~0 but some are not.

    I decided to take a look at my configuration and to my surprize see all 0s, except in the service that I created. Either something got mangled or it does not display properly but did yesterday.

    I also see that protocol is L7 for everyting.
  5. danr

    danr Network Guru Member

    Try using MAC based QoS instead of Port based QoS.

    It works fine for me with my WRT54G v4. About 1.5 months ago, I tried Port based QoS and it didn't work. I was told that only certain hardware support it (although you said that you used it with v22). Since I went to MAC based QoS, it works great. I'm using it with v23 final, now.
  6. JensG

    JensG Network Guru Member

    Re: QOS

    You need to re-boot your router to be able to choose it.
  7. JensG

    JensG Network Guru Member

    I am back at 22-r2, and it works fine wit IP and Port based. I will just stick with that for now. Don't feel like experimenting any more right now.
  8. danr

    danr Network Guru Member

    Re: QOS

    L7 (Layer 7) filters are databased and not port based - so the ports should be 0~0.
  9. bytes2000

    bytes2000 Network Guru Member

    @danr is right, use MAC based QoS!

    if you use only services priority, the router has to guess what kind of traffic is passing; sometimes traffic identification fails or there are queued packets causing a small delay.

    In MAC based qos ALL the traffic from your phone will have a higher priority. (use premium)
  10. JensG

    JensG Network Guru Member

    So the IP and Port options are just there for show, without working at all? I would never have guessed that.
    In v22-r2 they work fine.

    But apart for that I am very impressed with the work Brainslayer and the other developpers have done.
  11. mozetti

    mozetti Network Guru Member

    I sure hope not. QoS is good for both MACs and Services. I was hoping to use it to tame my BitTorrent client and keep it from sending the router spinning. But, if QoS only works for MACs then it's pretty much useless to me.

    Anyone know if Brainslayer plan on fixing this? I haven't seen him around here for awhile.
  12. dellsweig

    dellsweig Network Guru Member

    I have not seen a problem using QoS for services, MACs, physical ports or address masks.

    It works great (8 PC's, 2 servers 2 VoIP boxes)
  13. danr

    danr Network Guru Member

    MACs and Services both do work. According to a posting about a month ago, the port based QoS only works with specific hardware.
    Someone actually mentioned what the hardware was, but I dont' remember.

    I have a v4, where I know it doesn't work . At least it didn't work a month ago. Truthfully, I haven't tried it with the final v23 - since I was told it was a hardware issue. Before I received the specific hardware answer, I created a ticket regarding port based QoS and nothing was ever done with it. It's interesting that the Linksys firmware has port QoS....

    I could never test it with v22 to see how the QoS works there.
  14. danr

    danr Network Guru Member

    Brainslayer is on vacation for the rest of the year. He said he's coming back to work on v24. There is at least one issue, which he said that he's going to put in a service update.
  15. will792

    will792 Network Guru Member

    Did you use FF for configuration? Something in v.23 code does not like FF. I could not even save any tabs in Administration, had to use IE.

    Also predefined services had different protocols and ports filled in but somehow the next day everything was reset to L7, ports: 0-0.

    I see that JavaScript array on QOSPort_Services.asp page contains this information so it comes from CGI script running of the router. Could not identify where filter_port_services_get function lives. It is the function that populates JS array.

    Something is not right here. I use FF 1.5 by the way.
  16. matrx

    matrx Network Guru Member

    complete newb here :)

    I'm trying to give priority to my VOIP adapter... would this work?

    under Ethernet Port Priority (QoS page):
    Port 1 (my computer) setup to Standard Priority with 100M max rate
    Port 2 disabled as it's not in use
    Port 3 disabled as it's not in use
    Port 4 (VOIP adapter) setup to Premium Priority with 100M max rate

    Nothing else on the QoS page changed (except that QoS has been enabled)...
  17. danr

    danr Network Guru Member

    You can give it a try - but I've been told only certain hardware support Port Priority. Otherwise, use the MAC priority instead. That works great for me and others.
  18. matrx

    matrx Network Guru Member

    Hmmm, okay, so how do I figure out the mac addresses for my computer (network card) and voip adapter? :oops:

    EDIT: Is it in my DHCP client list?

    EDIT 2: So I set the priority using the MAC addresses I found in my DHCP list (I was able to figure out what address belonged to what device)... so how do I disable the port priority feature (it's still set as noted in my last post) or should I just leave it?
  19. Couledouce

    Couledouce Network Guru Member

    Type "ipconfig/all" from a command line window (run cmd).
  20. Burrens

    Burrens LI Guru Member

    I can't seem to find the post were the hardware revisions of WRT54G/GS that do/do not work with port based QoS are listed.

    Does anybody have this info?
  21. swinn

    swinn Network Guru Member

  22. Burrens

    Burrens LI Guru Member

    Port based QoS will not work on later revisions regardless of what 3rd party firmware is used right?

    So MAC priorities are higher than service priorities?

    Example: 1st PC set to Premium, 2nd PC set to Standard, bit-torrent L7 service set to Bulk. If I am uploading a torrent from PC 1, will the torrent data get priority over data from PC 2?
  23. danr

    danr Network Guru Member


    NOTE: Ethernet Port Priority only works on older, ADM based, chipsets. That is, the Linksys WRT54G v1.0, 1.1, 2.0 and the WRT54GS v1.0.

    There were also postings in the official DD-WRT user group (the old one - they just changed servers last week.)
  24. Burrens

    Burrens LI Guru Member

    Wait, I just noticed that the notice says, "Ethernet," ports. I am assuming that QoS via TCP/UDP still works correct? I am really interested in TCP/UDP ports, and made a mistake by misreading, "ports."
  25. danr

    danr Network Guru Member

    The part that does not work for 'newer' routers, is the section labelled, "Ethernet Port Priority."

    That is, you can not set the machine connected to the physical network cable plugged into port 2, as "Premium" (for example).
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice