QoS not working? VOIP better with QoS turned off!

Discussion in 'DD-WRT Firmware' started by danr, Nov 6, 2005.

  1. danr

    danr Network Guru Member

    I'm using an MGCP VIOP Telephone Adaptor behind a Linksys WRT54G v4 with DD-WRT (wtd). I tried both Nov 4 and Oct 27 and find that QoS doesn't seem to be working properly for me.

    I set it to:
    A) Enable
    B) WAN
    C) upload and download tested to various rates between 80% and 95% of my speakeasy/speedtest results.
    D) Set Port 4 (my TA) to Premium
    E) Set other ports to Bulk (or Standard)

    When I'm on the phone and uploading a large file, I hear break ups in the phone calls on the 'other' side of the line (when I talk on the TA connected phone, the 'other' person hears break ups).

    When I turned OFF QoS, there were many FEWER breakups (probably since it had the total upload speed... about 385 kbps.... d/l I have 4780, so there are no problems).

    Am I doing something wrong? Someone said that he couldn't get QoS to work with Nov 4, but Oct 27 worked... which is why I tried Oct 27.
  2. daenigma

    daenigma Network Guru Member

    I use service level prioritization utilizing the 10/27 build (I also could not get the newest build 11/4 QOS working) and it works fine. But I have had experiences in the past just like yours and the best cure was to first do a hard reset on the back of the router for 30+sec then manually re-enter the settings. At least that is usually what cured the problem for me...

    (I have 8800kbs/768kbs)
    I set my upload to 85%
    I set my download to 95%
    Optimize for Gaming
    I manually enter RTP (premium) into QOS UDP/TCP 16384-16403 (click add/edit button then type in a service name, protocol, and port range and click add followed by a reboot of the router)
    I also add the following serviced which are already configured:
    SIP Premium
    DHCP express
    DNS express
    Bittorrent bulk
    Edonkey bulk
    FTP bulk
    Gnutella bulk
    (keep in mind that anything you do not add will have the default standard level set automatically)

    I leave netmask priority and mac priority blank.
    I also leave ethernet priority at the default premium levels.

    I am not a QOS expert or anything but this setup works well for me.
  3. danr

    danr Network Guru Member


    Hmmm, I decided to try Service based QoS
    hoping maybe that was why it worked for you and not me. Well, when I entered in services, it brought me to the Access Restrictions screen and turned OFF QoS! Then it locked me out of the router GUI. I had to reset to factory settings and start again.

    (I Used the following for my MGCP TA:
    UDP: 2427, 2727, and 30000-31000)

    I tried what I tried before, after the reset, still to no avail. With the 10/27 firmware it always slows everything down, quite a bit more than the amount I specify. Even then, I get breakups on my VOIP phone. (It's MGCP, behind the router).

    I also wonder if the router hardware version makes a difference, in terms of QoS compatibility with the firmware. I'm using version 4.

    Discounting the QoS itself, when I set the upstream/downstream limits for QoS and then test the bandwidth without using any other interfaces, I seem to get quite a bit less than what I specify.

    Do QoS changes themselves (changing u/l d/l rates or priorities) need a router reboot?
  4. danr

    danr Network Guru Member

    I'm going to bump this thread - since I made modifications to the previous message - but that didn't change the timestamp.
  5. danr

    danr Network Guru Member

    Just to update this thread. I was told (on dd-wrt.com) that PORT BASED QoS, "only works on the earliest [WRT54Gs] with the ADM6996L Chipset."

    When I tried MAC based routing, using the Oct 27 firmware, QoS works well.

    I still have the following question/issue:

    It just seems that there is less available bandwidth than I specified to reserve. Is that supposed to be that way?

    I specified 306 uplink (85% of 360) and 4553 download (95% of 4793).
    With only my PC running a test - it tests at 4321 /dl 290 u/l.

    When I'm on the phone, I get 4268 d/l 245 u/l and don't hear any problems on the "other" (upload) side of the conversation.
  6. daenigma

    daenigma Network Guru Member

    I have not used port based for at least four months so I was not aware of that issue, but currently I am running a WRT54GS V3 which I think is basicly the same a the G V4.

    I agree there seems to be a 3-5% lower max bandwidth that you set in the firmware although I do not know if this is due to the test files not being big enough fo the speed to ramp up or if there is an inherent loss due to QOS.

    I just went to the 11/9 (mini) build to test QOS and it seems to be working once again but I need to test it further.
  7. bigjohns

    bigjohns Network Guru Member

    configure your PC to premium using the mac address. Then run your test again.

    Premium is the only one that gets access to the FULL "pie" of bandwidth. (100% of the 95%)

  8. danr

    danr Network Guru Member

    (I can't try that right now, but:)

    Why should the standard device get less than 100% of the "pie", if the Premium device isn't haven't data sent through it? (Well, it's a VOIP TA, so there is probably a message going through every minute or so, regardless of if I'm on the phone.)

  9. bigjohns

    bigjohns Network Guru Member

    I think that the way that it works is:

    Bulk = 40%+ of the bandwidth
    Standard = 60%+ of the bandwidth
    Express = 80%+ of the bandwidth
    Premium = 100% of the bandwidth

    where the bandwidth = your set amount (% of actual available).

    The reason you use a % is for overhead, and for the fact that the real available bandwidth on a cable or dsl can fluctuate.

    Each class can "borrow" from the higher classes, but the minute a higher class stream needs that bandwidth, the 'borrow' is canceled.

    So some bit is reserved for that transition phase...

  10. danr

    danr Network Guru Member

    Even so, I'm surprised that so much is reserved above what is entered by the user...

    If we only want 2 classes (one being Premium, for VOIP), does it make a difference, in terms of available bandwidth, if the non-VOIP classes are Standard or Express?

    What does the "gaming" switch do? (I put it on, considering that both VOIP and gaming must be 'real time' - so I guessed it was apropos).

    I tried changing my PC to Premium and TA to standard... but there are latency issues on the hand off from atdn.net - so my test sites are crawling so can't really test it. (250 ms to any site which requires going through atdn.net)
  11. bigjohns

    bigjohns Network Guru Member

    In my network the ATA and my PC are both classed premium.

    Other stuff is classed lower. But I'm still running v22r2, so I can't tell you if v23b2 is any better or worse... I have to stick with whats' working, and when Brain Slayer and the world say V23 is bug-free and better than v22, I'll upgrade.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice