QoS slowing down upload...

Discussion in 'Tomato Firmware' started by Greebo, Jan 9, 2007.

  1. Greebo

    Greebo LI Guru Member

    I've just installed Tomato 1.02 on my WRT54GL 1.1, and was looking forward to both bandwith-monitoring and QoS. The bandwith monitor was just strange, it always showed about 10mb/s AVG inbound (my line is only 6/6mb...) on the WAN port (the eth0 was crazier...)

    Worst was QoS, I loved the menus, and the possibilities :biggrin: , but quickly realized something was wrong. I took a internet speed test, and with QoS disabled got about 7000kbps upload (only 6400down...:redface: ). When I enabled QoS, the upload speed dropped to about 3440kbps:confused: , no matter what I did with the settings.

    -I tried to disable all classifications, no difference.
    -Set the default class to highest; no difference.
    -Tried different upload speed (from 3600 to 10000); no difference.
    -With and without ack and icmp priority; no difference.

    When I disable QoS, my upload speed goes back up to 6-7mbps, and I can't think of more things to try...

    So, does anyone have any suggestions for more things to try??? A loss of 2600kbps upload is just a little to much......:frown:

    Greebo :cool:
  2. TerminatorHTK

    TerminatorHTK LI Guru Member

    I'm using QoS extensively with no issues, my bandwidth up is the same when using QoS or not. I really love the features of QoS in this firmware! Did you make sure to clear NVRAM when you updated to the Tomato firmware?
  3. tstrike2000

    tstrike2000 Network Guru Member

    Did you clear the NVRAM after you flashed to Tomato? Also, in the QoS Basic Settings for Outbound you could try putting the Max Bandwidth at 90% of your total upload and widen out the percentages for all the bandwidth priorities and test it that way. I currently have everything checked at the top with my Default Class set to Low and it's been working good for me.

    I've also had experiences especially when changing firmwares between Stock to Thibor to Tomato where I've had to reboot my PC and cable modem to get the speeds to properly work.
  4. Greebo

    Greebo LI Guru Member

    Ah, sorry, forgot to mention:
    I "upgraded" to Tomato from Thibor 15c, and the last thing I did before upgrading was fact.def.+ clear NVRAM. The first thing I did after installing Tomato was to clear NVRAM....

    QoS functions are working perfectly EXCEPT that I'm "losing" 2,6mbps upload bandwidth....


    edit: I'll try clearing NVRAM, rebooting PC and cablemodem tomorrow...
    I've tried lots of Max Bandwidth settings (including 90% of upload= 5528kbps), no difference at all...
    Why should I widen out percentages? (They're still at default).
  5. tstrike2000

    tstrike2000 Network Guru Member

    I'm still a little fuzzy on what the outbound classification % settings do in Basic Settings. From my understanding you can allocate bandwidth to a particular class (ie Highest, High, etc.). What that exactly does for you is the part I'm not completely sure of. You can widen those percentages so the classes all are set to use all of the uploaded bandwidth and only use the Classification tab to determine which applications you want to give outbound priority to. Just something to test. If you do decide to play around with the Basic Settings I would then Save your settings, reboot the router and reboot the cable modem...just to factor out any other variables.
  6. jbypuentes

    jbypuentes LI Guru Member

    i started having problems today with the QoS (after 4 days no probs)

    my lowest class (www) is getting all the bw while my hightes (xbox live) is getting almost nothing, the classes where switch.

    is there a way to prioritize by mac addy or ip?
  7. tstrike2000

    tstrike2000 Network Guru Member

    Yes, look around in the settings.
  8. tievolu

    tievolu Network Guru Member

    Here is my understanding of these settings...

    Each classification has two percentage values, which you can edit.

    The first percentage value is how much of a completely saturated upstream would be allocated to this class of traffic. This guarantees that the traffic will always have at least this amount of upstream bandwidth.

    The second value is the maximum portion of the upstream the classification can use if the connection is idle (i.e. set this to 100% unless you want to limit a class of traffic at all times).

    Once you've edited the values, you can see the bandwidth ranges for each classification on the right, calculated using the value you entered for your upstream bandwidth.

    For QOS to work properly and efficiently, the sum of all the values in the first column of percentage boxes should be 100%, and you must enter an accurate value for your upstream bandwidth. (Unless your upstream is extremely stable at a fixed value, it's usually best to err on the low side of your ISP's quoted upstream bandwidth by 10% or so. This may 'waste' up to 10% of your upstream bandwidth, but you should have very reliable QOS.)

    Hope this helps!
  9. Greebo

    Greebo LI Guru Member

    Still no go.....

    I cleared nvram, rebooted router + modem + pc, and I'm still losing the 30-40% of my upload bandwidth the moment I turn on QoS :frown:

    I tried changing some of the bandwidth percentages, but it didn't change anything (it shouldn't either, with only one upload connection (speed test) that connection should get all bandwidth... i think....)

    So it seems to work perfectly as long as upload bandwidth is below 3600kbps, anything above, it just caps... I'll probably have to chose between QoS or bandwidth then :wink:
    Oh well, if anyone has other ideas I could try, please let me know, else I'll just assume its my wrt54gl thats broken... :frown:

  10. azeari

    azeari LI Guru Member

    tis weird.. i have no such problems, though my line's a 10/1 mbps. i tried adjusting the qos uploads when someone was dling off my server, and i can see the results immediately in the real-time bandwidth charts.

    i'm actually getting 13.8mbps down :p me have a nice isp
  11. Greebo

    Greebo LI Guru Member

    Has anyone else tried/testet QoS who have a upload speed greater then 3600kbps?? My downloads work ok, of course, but for some strange reason my uploads are capped when QoS is enabled.....

  12. fastpakr

    fastpakr Network Guru Member

    For what it's worth, I ran a few quick SpeekEasy tests...
    Cable Modem straight to PC
    Download Speed: 11099 kbps (1387.4 KB/sec transfer rate)
    Upload Speed: 369 kbps (46.1 KB/sec transfer rate)
    Download Speed: 11338 kbps (1417.3 KB/sec transfer rate)
    Upload Speed: 369 kbps (46.1 KB/sec transfer rate)
    Download Speed: 13947 kbps (1743.4 KB/sec transfer rate)
    Upload Speed: 369 kbps (46.1 KB/sec transfer rate)

    Router, No QOS
    Download Speed: 14801 kbps (1850.1 KB/sec transfer rate)
    Upload Speed: 367 kbps (45.9 KB/sec transfer rate)
    Download Speed: 15006 kbps (1875.8 KB/sec transfer rate)
    Upload Speed: 367 kbps (45.9 KB/sec transfer rate)
    Download Speed: 14864 kbps (1858 KB/sec transfer rate)
    Upload Speed: 368 kbps (46 KB/sec transfer rate)

    Router, with QOS
    Download Speed: 8994 kbps (1124.3 KB/sec transfer rate)
    Upload Speed: 217 kbps (27.1 KB/sec transfer rate)
    Download Speed: 9138 kbps (1142.3 KB/sec transfer rate)
    Upload Speed: 218 kbps (27.3 KB/sec transfer rate)
    Download Speed: 9036 kbps (1129.5 KB/sec transfer rate)
    Upload Speed: 216 kbps (27 KB/sec transfer rate)

    All of these are taken with Tomato 1.04 on a Buffalo WHR-G54S. It appears that the Tomato flashed router has no effect on in/out speeds as long as QoS is disabled. Enable QoS and there's an instant hit on throughput in both directions. I'd be happy to post any QoS settings info that might be relevant...
  13. der_Kief

    der_Kief Super Moderator Staff Member Member

    Hi fastpakr,

    what are your max upload/download bandwidth settings ? Maybe you define outbound rate to low ? What are your QoS settings ? Maybe here is the problem. Please recheck your Setup !

  14. fastpakr

    fastpakr Network Guru Member

    Nice catch, and yes - I feel like a moron. Settings were 1000 in/200 out. Switched to 14000 in/350 out and got this:

    Download Speed: 12599 kbps (1574.9 KB/sec transfer rate)
    Upload Speed: 330 kbps (41.3 KB/sec transfer rate)

    Question though - given that the first three tests without the router in place were below 14k, what would you suggest setting as inbound max?
  15. der_Kief

    der_Kief Super Moderator Staff Member Member

    why limit the inbound bandwidth ? This is from the readme:
    Although there is an option to limit the download speed, it's not really recommended in most cases since what the router is really doing is dropping packets, which means they may need to be re-sent again over a slow Internet link.

  16. larsrya8

    larsrya8 LI Guru Member

    Because usually dropped packets means (to the server) that the connection is slower, so after the initial commotion the server will send the packets slower. At least, that's the way it is supposed to work. It isn't very good when trying to limit different classifications in a dynamic fashion though.
  17. pharma

    pharma Network Guru Member

    What der_Kief states from the Readme is correct since the router is dropping packets that might have to be re-sent again. Initially I fooled around with limiting inbound packets, but found it wasteful and wasn't very efficient. It's kinda like putting a "speed limiter" in your car when the goal is really trying to go faster. I found the best thing to do is to decrease the number of connections and/or speed inside your bulk download applications (bittorrent, download mgrs, etc ...), while keeping the overall internet "flow" to your computer constant. Remember, the default settings on most torrent applications don't consider anything else you might be doing on your computer. Resource synchronization is achieved by lowering/decreasing many of these settings.

    Hope this helps.
  18. azeari

    azeari LI Guru Member

    well the way i do qos is to put my bulk connections like p2p and bt together with other bulk traffic, and pirotize other specific traffic above them. seems to work well for me with >4096 concurrent connections. i'm on a 10,000/1,000 line here
  19. pharma

    pharma Network Guru Member


    That's kind of what everyone is doing for controlling UPLOAD bandwidth and it does work fine. What people shouldn't be doing is "castrating" themselves by messing with the firmware's DOWNLOAD bandwidth -- it's best to control this as I mentioned above by throttling back number of connections/speed in the torrent/download application. :)
  20. Reiper

    Reiper LI Guru Member

    How do you control download speed in IE7 or Firefox?
  21. pharma

    pharma Network Guru Member

    I think most people really don't want to control the download speed for browsers because they are not a bulk or batch transfer application. If anything you want response to be as fast as possible.
  22. Reiper

    Reiper LI Guru Member

    I'm just trying to get standard downloads (xbox demos, misc internet downloads, etc.) from impacting my VoIP. I guess we don't ever do any p2p stuff... Like I mentioned in another post, I'm giving Tomato's download Qos a shot by only limiting a certain class and tying that class to large downloads. We'll see if it works! :)
  23. pharma

    pharma Network Guru Member

    One thing that also helped me was changing some of the default memory settings in the bittorrent application. One was "Pack memory pool when it's usage is less than: 80%". On large downloads I found my Internet browsing and other activities suffered ... the browser became sluggish like something was hogging the memory (4 gig). I played around with the default torrent memory setting of 80 and found by reducing it to 50 I cound attain the same torrent download speeds, surf the web like NO torrent application was running, and listen to streaming music on RealPlayer -- all at the same time. This change along with reducing the number of torrent connections per job (max 60 inbound/max 60 outbound) gave me what I was looking for -- being able to download torrents, surf the web, listen to internet radio simultaneously and have something leftover for other internet activities.

    In my post above that's what I mean perhaps the best place to start looking is the bittorent/download applications themselves.
  24. nricciardi

    nricciardi LI Guru Member

    I have the same problem

    I have the SAME problem
    5mbps upload link

    If I turn off QOS, I can upload at 4.8 Mbps.

    If I turn on, upload goes down to 3.4 Mbps.

    Now the interesting part.

    If I setup upload link to 1 Mbps, my upload speed decreases accordingly.

    BUT if I setup it up as 8 Mpbs (higher than what I actually have), upload does not change at all. It stays at 3.4 Mbps.

    I tried everything I could to make this work and I'm running out of options here.

    This is a WRT54GS v4, upgraded to Tomato from Linksys original, right out of the box.

    I'd appreciate any suggestion.

    Edit/Delete Message
  25. GeeTek

    GeeTek Guest

    nricciardi, try to find a real world upload speed of your connection by using online speed testers. Then set the MAX bandwidth in QOS basic settings to 95% of the measured amount. See if that corrects the regulated percentages that you see when QOS is enabled.
  26. nricciardi

    nricciardi LI Guru Member

    Thanks, but it does not work

    It does not work.

    Please see the attached file.

    It shows part of the speed on utorrent upload.

    My link is 5mbps up. I tried to setup the QoS uplink at

    5000 kbps
    4700 kbps
    4100 kbps

    And also

    8000 kbps

    It does not make any difference. When I switch QoS on, upload speed goes down (easy to see on the graph). When I turn it off, upload speed goes back up again.

    I have no idea how to solve this.

    I also tried a second WRT54GS 1.1 that I have here (my backup unit) and I have the exact same issue.

    I'm using the latest version of Tomato, upgrades just this morning.

    Can this be a CPU problem? Something like the router not being able to process the QoS calculations? A memory issue? I don't know.

    Attached Files:

    • ut.jpg
      File size:
      14.2 KB
  27. GeeTek

    GeeTek Guest

  28. nricciardi

    nricciardi LI Guru Member

    Results are consistent

    GeeTek, thank you for your help.

    This is what I got WITHOUT Qos.


    And this is what I get when QoS is ON.


    Now, how do we explain that?

    My backup router (the GS 1.1) was using DD-WRT until 2 weeks ago and I never had this problem. Now that I´m using Tomato on both, I'm seeing this behavior. Do you know where can I contact the developers of Tomato to give them this feedback?

  29. GeeTek

    GeeTek Guest

    Using QOS is going to cost you a small amount of bandwidth. It cannot function if it does not have some accurate limits. If the limits of your QOS settings are more than the actual amounts, QOS will not work at all. Try setting your MAX Bandwidth download speed to 12360 (13.01*.95) and the MAX upload to 4278 (4503*.95). Then your speed regulator will work. If you still cannot control your speed, then we need to help you with your QOS rules and classes.
  30. nricciardi

    nricciardi LI Guru Member

    I did that already


    I tried everything you can imagine. I'm not messing with download, just upload Qos. And I defined MAX bandwidth as 4100, 4200, 4500, 5000, even 3800. The results are always the same.

    I also know that QoS is going to cost me some bandwidth. But 1.3 Mbps is too much, don´t you believe? Jes.... 1.3 Mbps is a LOT of bandwidth to be wasted in something like that.

    I'm convinced that there is a problem in Tomato with upload links greater than 3.5 Mbps (around that).

    I have two routers here, two WRT54GS. One of them is version 1.1. The other is V4. Both show the same problem.

    And if I take one of the routers and flash it with DD-WRT, for example, the problem goes away.

    So, based on this side by side experience with my two routers and different firmwares, I'm inclined to say that there is a problem with Tomato QoS when (and only when) your upload speed is greater than 3.5 Mbps.
  31. GeeTek

    GeeTek Guest

    Sounds like you may be correct. I'll set up a LAN router to see if I can regulate more upload speed that 3.5 M.
  32. GeeTek

    GeeTek Guest

    On your QOS Basic settings, set all outbund and inbound categories to 100%. Then run your speed test at dslr again and you should get the speeds that you have programmed in the maximum fields. I'm not gonna have a chance to set up a test router until tonight, but if your test traffic is in Med or Low classification, you will only get the speed that it's class is set for. Also, there is a trigger point of 512k for port 80 in the default rules. You may be hitting the trigger point and having the traffic get re-categorized automatically. That is why I want you to test with all categories assigned to get 100% bandwidth, inbound and out, just for the test.
  33. der_Kief

    der_Kief Super Moderator Staff Member Member

    Hi nricciardi,

    whats your settings about 'prioritize ICMP' and 'prioritize ACK' ? If they are enabled try to disable them (especially the ACK one).


  34. nricciardi

    nricciardi LI Guru Member

    Here you have it

    der_Kief and GeeTek,

    My setup was already the way you asked me to do.

    I'm attaching a screen capture of my settings.

    Thank you for taking the time to help me.


    Attached Files:

  35. GeeTek

    GeeTek Guest

    Funny, I don't see 4278 on your screen shot, and I see a whole row of 1% starting values, which require a ramp up as the router reacts. Try 4278 for MAX and 100% in ALLLLL fields, and you will get 4278.Then you can back track a little to see what slows it down. I never use range settings on my own home router. My "From" and "To" speed range is always the value that I want that category to have, and it works perfectly for me. I'm glad you posted that screen shot !

    Edit - Also, your inbound field is nowhere close to the value you actually have nor the value I recommended. Not reading the Wicki and Stickie is bad enough, but to ask for advice, and then ignore it makes it difficult to want to help you.
  36. horatiub

    horatiub Network Guru Member

    I have the same problem. QoS is slowing down my upload and my download as well. My usual upload is between 1200kbs-1500kbs but when I enable QoS, it goes down to 300kbs. Same thing with my download, down from 16MB to like 12MB.
  37. nricciardi

    nricciardi LI Guru Member


    I did what you asked and the results are still the same. Still around 3.5, 3.6 Mbps.

    Regarding the inbound, I'm not using QoS on inbound. Anyway, I changed everything to what you asked and the results did not change.

  38. GeeTek

    GeeTek Guest

    I don't have a GS model of radio with me now, but I will borrow one so I can test with your exact hardware. My internet connection is only 5m * 384k so I'll have to route a local IP and test between 2 local computers. In the mean time, you may want to mess around with port speed settings under "Advanced" "Miscellaneous" to see if it may be doing funny stuff. I doubt it is the problem, but you never know. Also, if you have not yet done an NVRAM clear in the software, you should. It is under "Administration",
    "Configuration", "Restore Default Configuration". Use the drop down box to "Erase all data in NVRAM (Thorough)". Converting from DDwrt and not clearing NVram has been know to cause lots of problems.
  39. nricciardi

    nricciardi LI Guru Member



    All this is happening on two wired computers, both running Windows XP SP2.

    No wireless involved, ok?
  40. njeske

    njeske Network Guru Member

    i've noticed this as well on a Buffalo WHR-G54S. qos is working in regard to prioritizing packets. however when qos is not enabled, i can upload a lot faster over my vpn to work than i can when qos is enabled. even when vpn is the only thing using upstream bandwidth, and is set to high priority, it is slower than when qos is disabled.

    qos is needed, so we're dealing with it for now. however some sort of solution would be appreciated. let me know what i can do to help.
  41. GeeTek

    GeeTek Guest

    I now have all the hardware. I'm going to configure and test. Will modify post shortly with results.
  42. nricciardi

    nricciardi LI Guru Member

    The problem is real

    I spoke with Jon, the author of the firmware, and the problem is real.

    According to him, "The burst setting was on a fixed value. It was fine at "normal" speed, but I guess it didn't go very well with the higher rates."

    He is preparing a new version that will fix this issue.

    In the meantime, telnet to the router and do

    nvram set debug_keepfiles=1
    service qos restart
    sed -e 's/burst .k//' < /etc/qos > /etc/qos2
    sh /etc/qos2 start

    That will fix the problem and the QoS will work fine with upload links faster than 3.6 Mbps. If you mess with the QoS setup, you will have to input the commands again.

    That's it folks. Keep your eyes open because a new version is just about to pop-up.

  43. njeske

    njeske Network Guru Member

    is it really only on links faster than 3.6Mbps? cause i notice this issue both at my dad's house (WHR-54GS) on a 384k upload, and at my house (WRT54G v4) on a 512kb upload. Both routers see about a 10% drop in upstream throughput when QOS is enabled. My dad only gets about 360k (375k - 380k w/o qos), and I only get about 470k (485k - 500k w/o qos).

    i certainly appreciate jon finding and fixing this issue quickly, but i wonder if anyone else with cable/dsl speeds similar to my setup can test and report back.
  44. GeeTek

    GeeTek Guest

    I have just spent the last 5 hours testing and testing, and came to the same conclusion. I apologize for being snappy with you nricciardi, and also need to find me a bit of crow to eat. Anyway, I do have some interesting things to report. Before I started testing, I connected my laptop to the desktop w/ a cross cable. Q-Check reported 95.143 Mbps every test. I programmed the GS v.2 W/ Tomato 1.04, put WAN and LAN on different subnets, QOS off and ran Q-Check loops to the desktop. I get wildly random results ranging from 10 Mbps to 22 Mbps, never higher. I had a WHRg54S with DD-WRT V. 24 2-15-2007 release (or there-abouts) that I was testing DD-WRT universal repeater mode with. (Repeater mode works great W/ that 1 release). Anyway, I ran some loop tests through the buffy W/ DD, and got 28.141 Mb very consistent. I then flashed that buffalo up to Tomato 1.04 and my loop tests to the desktop jumped to 54 Mbps, solid, every test. Helluva shine there for Tomato. I set up an FTP server in the desktop, and spent about 3 hours coming to the conclusion that 3.6 Mbps is as much as QOS will allow out. All my data would consume a few pages, but I can summarize it somewhat. With QOS disabled, FTP to from the laptop to the desktop according to Tomato graphs bounced between 28 and 45 Mbps. Almost always right around 32 Mbps. I was sending a 3.7 Gb ISO file, so it would run for 20 or 30 minutes at a time. I created a QOS rule on the Laptop MAC, all ports and protocols and assigned it to class "A". The value you use for the "Outbound MAX" field means pretty much nothing. I set it for 10 Mbps, 20, 54, 80, 92 and 111 Mbps. For any and all "MAX" settings, as long as the percentage of which was below 3.6 Mbps, would regulate the outbound rate very accurately to exactly that amount. Even when MAX was set to 111 Mbps (11 meg faster than the lan connection of 100 Mbps) and the % of class "A" was 2%, the outbound rate regulated to exactly 2.22 Mbps.
    In summary -
    1 - The GS V2 radio is a DOG.
    2 - Buffalo radios are twice as fast and very consistent as compared to the GS V2.
    3 - Tomato 1.04 allows data to flow at exactly twice the badwidth as compared to DD-WRT V 24 2-15-07 release.
    4 - My plate of crow is hot and ready.

    Edit - Spelling
  45. larsrya8

    larsrya8 LI Guru Member

    So version 1.06 should benefit everybody with a broadband internet connection running QOS?
  46. nricciardi

    nricciardi LI Guru Member

    Yes, 1.06 has the problem fixed. QoS is running here and my upload speed goes all the way to the limit I define. No more caps at 3.6 Mbps.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice