QoS was working, now broken

Discussion in 'Tomato Firmware' started by ray_burnz, Sep 8, 2007.

  1. ray_burnz

    ray_burnz Guest

    I was using the latest official build of Tomato and was using QoS to make sure that my Vonage phone and web/e-mail would take priority over background downloading such as BitTorrent.
    I enabled QoS, configured the rules, and it was working beautifully.

    I decided to give the build with OpenVPN posted on this forum a try but was unable to get the OpenVPN component to work correctly.
    (at this point, I only tried it for a day and did not test if the QoS settings were still working).

    I went back to the official build but have not been able to get QoS to work since!
    I have double checked and triple checked and am 100% sure they are the same settings I was originally using.
    For example, the traffic from my Vonage phone that I have classified as Highest priority is being classified in the default class of Low.

    I have reset to factory defaults and cleared nvram from the backend, held down the reset button on the back of the router, even reflashed the firmware, but none of these steps has solved the problem.

    Another peculiar thing is when I enable QoS the power LED on my router keeps blinking.
    When I turn QoS off, the power LED goes back to solid green.

    Anyone have any ideas what I am doing wrong?
    (I will try to post some screenshots)
  2. ray_burnz

    ray_burnz Guest

    Hopefully these screenshots help.

    Attached Files:

  3. GeeTek

    GeeTek Guest

    FOr one thing your QOS rule for vonage specifies and the connections chart shows
  4. ray_burnz

    ray_burnz Guest

    OK that was stupid of me.
    I changed (and .3) to the (and .103).
    Hit save, rebooted the router for fun.
    Rules still don't seem to be working.
    And that damn power LED still flashes when I turn QoS on...
  5. ray_burnz

    ray_burnz Guest

    Also I have noticed that when QoS is on, either immediately or eventually I can't seem to get any network connectivity past the router.
  6. GeeTek

    GeeTek Guest

    Sounds like you need to pour some beer on that router and then buy a new one.....
  7. ray_burnz

    ray_burnz Guest

    Other than buying a new one, isn't there anything else I can try?

    I once tried setting up the same QoS rules on a new WRT54GL 1.1 for a friend but ran into the loss of connectivity problem...I blamed his router and he returned it.
    And now the same thing is happening to me (in addition to the QoS not working!)

    Is it possible another setting somewhere in Tomato is causing a conflict?
  8. azeari

    azeari LI Guru Member

    not that i know off. It would help if u gave a list of changes you did to the router so far (= anyway, you might wanna put dest port 53 for dns as the highest, since most web-bound requests goes through that stage first

    Edit: hmm didn't read tt u even reflashed the firmware >_< hmm.. did you check the logs for any strange stuff?
  9. ray_burnz

    ray_burnz Guest

    I haven't added in any scripts or changed the firmware in any way.
    I just go through the backend and setup things like static dhcp, dyddns, and wpa2 for wireless.

    I have to admit my QoS rules aren't perfect and not erasing some of those default DNS rules would help with web/e-mail.

    I'm not much of a log-head so my question for you: anything you want me to do specifically before giving you the log as a txt attachment? Reboot, try to use my Vonage phone, maybe even dance in the rain?
  10. ray_burnz

    ray_burnz Guest


    Hoping someone sees this and knows the solution.
    I'd rather not go back to dd-wrt!
  11. GeeTek

    GeeTek Guest

    If you do a complete nvram clear and the power light starts flashing when you turn on QOS then you have a hardware fault. Clear the nvram and just turn on QOS. If the power light starts flashing it is beer time, and you need not waste any more time with it !!!
  12. ray_burnz

    ray_burnz Guest

    Thank you for the advice, GeeTek.
    I'll do it as soon as I get home from work.
  13. Toxic

    Toxic Administrator Staff Member

    reflash the firmware using a newly downloaded Tomato firmware. just incase you firmware you have flashed with is somehow corrupt.
  14. ray_burnz

    ray_burnz Guest

    Miracles do Happen!

    I made a last ditch effort to somehow, someway salvage the router.
    I figured I would take all important steps in one big process so nothing could be left out that I would have to try later.

    First I:
    1) Cleared nvram from tomato web admin.
    2) Held down reset button on back for 30 secs, unplugged power, replugged power, continued to hold down reset button for 30 more secs.
    3) telnet into router and clear nvram manually.

    Download Tomato firmware and flash with freshly downloaded version.
    Repeated 1-3 above.
    Configured router with various settings such as WPA2, dyndns, qos, etc.

    To my amazement the power led was not flashing and the qos graphs showed my vonage phone was top dog again!
    I'm not sure which step it was that fixed the problem but I'm glad this trusty old WRT54G V2.2 is still alive and kicking!

    Thank you to everyone for your suggestions and help.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice