Quick VPN Name Resolution?

Discussion in 'Networking Issues' started by cpyne, Dec 17, 2005.

  1. cpyne

    cpyne Network Guru Member


    I'm connecting into a WRV54G with firmware 2.37 using QuickVPN. I connect successfully and can ping the IP addesses of other machines, but not their machine names initially. After I've been connecting for a while, (maybe 30 minutes?), I can ping them by name and I get a response with ".linksys" at the end.

    Does anyone know what is used for name resolution over Linksys VPN and if there's a way to refresh the client that is connecting immediately? Any other suggestions?

    Note: This is a small network with one server and 2 desktops. It is not not running WINS or DNS.

  2. cpyne

    cpyne Network Guru Member


    PS - I just tried this again and was immediately able to ping one comuter after connecting. I then tried to ping another machine which didn't work. Right after that I tried to ping the original machine again which failed. These pings were about 5 seconds apart.

    Does anyone have experience with this? I'm assuming this is some type of name resolution service that is built into the router. Would setting up WINS or DNS help this?

    C:\>ping bill2

    Pinging bill2.linksys [] with 32 bytes of data:

    Reply from bytes=32 time=24ms TTL=127
    Reply from bytes=32 time=118ms TTL=127
    Reply from bytes=32 time=21ms TTL=127
    Reply from bytes=32 time=60ms TTL=127

    Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 21ms, Maximum = 118ms, Average = 55ms

    C:\>ping billsnotebook
    Ping request could not find host barrows. Please check the name and try again.

    C:\>ping bill2
    Ping request could not find host bill2. Please check the name and try again.
  3. jdascott

    jdascott Guest

    Once connected to the VPN, run an nslookup from a command prompt. Immediately it should you what the default name server is that you're connection is using. Try typing in a host name at the prompt and hit ENTER, see if it resolves there or not.

    Two other things to try :

    The other thing to check is your NETBIOS over TCP/IP settings in the your network adapter properties (TCP/IP > Properties > Advanced > WINS tab). See if it's set to DEFAULT, ENABLED or DISABLED. It looks like the DEFAULT setting could be flaky, as Windows determines whether to use it or not. You can try swapping that setting around to see what result you get.

    Also, you could try removing the domain name LINKSYS on the router and see what happens. Maybe that extension is causing things to act weird.

    Good luck!


    "Linksys is the Yorx of computer routers!"
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice