QuickVPN 1.2.5 released

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by ZeGhostbear, Jul 31, 2007.

  1. ZeGhostbear

    ZeGhostbear LI Guru Member

    Found a new version dating from 2007-07-27 under downloads for the RVS4000. Hopefully this takes care of some of our issues. Here are the release notes:

    QuickVPN Client v1.2.5 Release Note



    1. Support Windows Vista in addition to Windows XP/2000.

    2. Updated the OpenSSL library (libeay32.dll and ssleay32.dll) from v0.9.8c to v0.9.8d due to some known vulnerability issues. For more information, please visit http://www.openssl.org/

    3. Fixed an issue with the Status Window showing Tunnel Connected but the tunnel is in fact not established. With v1.1.2 (or newer) QuickVPN client will ping the LAN IP address of the remote QuickVPN server before it shows the tunnel is connected. If the client cannot successfully ping the router's LAN IP within 1 minute, it will pop up a message, asking if the user wants to wait for the connection. Users can choose to wait or quit. This also requires newer firmware on the QuickVPN server side. Currently only RVS4000 v1.1.x and WRV200 v1.0.29 (or newer) support this.

    4. The Help page has been updated to include some descriptions of the status and error messages.

    5. Hide the passwords logged in wget_error.txt and wget_stop_error.txt.

    Known Issues:

    1. There is a known issue with Windows XP SP2 Firewall - ICMP packets are always dropped by the Firewall when the Firewall is enabled. The issue will cause the QuickVPN Client not being able to establish a tunnel with the remote QuickVPN Server successfully. Microsoft has released a patch to fix this issue. Once you install the patch, the issue should be resolved.

    2. QuickVPN Client v1.2.5 has an interop issue with RVS4000 firmware v1.1.09 and v1.1.11 (beta). However, QuickVPN Client v1.2.5 does work with RVS4000 firmware 1.0.x. New firmware will be released to fix the interop issue.

    3. QuickVPN Client v1.2.5 has an interop issue with WRVS4400N firmware v1.0.12, v1.0.13 and v1.0.15 (beta). New firmware will be released to fix the interop issue.

    4. Users need to have the administrative rights in order to use QuickVPN Client. This is a constraint posed by the Windows operating systems.
  2. spudd

    spudd Guest

    I have the same problem (stuck at verifying network) with the release version 1.2.5 from linksys for Vista. Has anyone had any success with QVPN and Vista?
  3. evilbart

    evilbart Guest

    downloaded it and tested it on VISTA (business): it works !!!
    i was able to connect to a WRVS4400N running Firmware Version: V1.00.15

    Another happy user here !

  4. florenceit

    florenceit LI Guru Member

    i have been running a protocol analyzer while trying to connect, it LOOKS as if the dns queries against the vpn server are going unanswered.. i was getting some checksum errors related to udp and tcp offload settings on my gigabit ethernet card. i disabled both and the checksum errors are gone.. but still no connect.

    there is a string of dns queries to the vpn server, then a ping,
    that scenario repeats endlessly (as reported, during the verifying network section).

    looks like this beta has to go through another iteration.. welp, looks like im still not installing vista yet. :frown:
  5. ChrisTransAm78

    ChrisTransAm78 LI Guru Member

    I really need this fix. Is there an update. All my XP machines work and now everyone sells Vista as the standard. Any ETA?

    But of course I will be ready to help test if need be.

    Many thanks!
  6. swiego

    swiego LI Guru Member

    Any idea what this means?

    3. QuickVPN Client v1.2.5 has an interop issue with WRVS4400N firmware v1.0.12, v1.0.13 and v1.0.15 (beta). New firmware will be released to fix the interop issue.

    What is the interop issue and any idea whether it might be fixed this calendar year? Since the three firmware revisions listed above are the only ones available with this router so far, should I take this to mean that in August 2007 the WRVS4400N VPN router still has no supported Vista VPN client?
  7. ChrisTransAm78

    ChrisTransAm78 LI Guru Member

    Please fix for the 4400! I'm begging!!!!
  8. Macsmasher

    Macsmasher LI Guru Member

    Where can I get an older firmware version for the RVS4000 that will work with this? I'm currently running 1.1.09, and the the connection won't complete.

    And can I even install an older firmware version?
  9. lazybeagle77

    lazybeagle77 LI Guru Member


    I have an WRVS4400N VPN Router and am also experiencing the same "Verifying Network" problem. I am using QuickVPN 1.2.5 and it works fine on all XP SP2 machines. However it wil not work on Vista Business or Vista Ultimate.

    Has anoyne else out there managed to get QuickVPN working on Vista to connect to this Router ?

  10. ChrisTransAm78

    ChrisTransAm78 LI Guru Member

    Is there an ETA for a fix? I have the 4400 as well.

  11. Cougar35758

    Cougar35758 Guest

    Using WRVS4400N, QuickVPN 1.2.5 and Firmware 1.00.15 and still having the problem of system locking at "Verifing Network" stage of conneciton on my Vista Ultimate machines, not the XP SP2. Being new to this site and the VPN setups responsibilities, how often does Linksys listen to the user and fix the problems?
  12. moshi16

    moshi16 LI Guru Member

    i just got mine working on RV082 using QVPN 1.2.5. I know WRVS4400N and RVS4000 have interop issue with 1.2.5 (based on the release notes).. no ETA on the fix though
  13. Hudsonhawk

    Hudsonhawk Guest

    I installed QuickVPN 1.2.5 installed OK Vista business.
    tried to connect to 2 RV082 V1.3.5 still hangs on "Verifying Network"
  14. Toxic

    Toxic Administrator Staff Member

    have you guys tried deleting the account details within the Router then re adding them? do you still get "Verifying Network" again?
  15. Toxic

    Toxic Administrator Staff Member

    This site is not run by Linksys. if you look at the amount of updates that are being pushed out by linksys for QVPN my guess is they are working on it. however it takes the individual to report problems to Linksys for the issue to get fixed. AFAIK Linksys's crystal ball doesn't work very well unless users give input to linksys.

    They do frequent these forums but dont give any feedback in here since they are not paid to surf the net all day:)
  16. JohnRF

    JohnRF LI Guru Member

    I called Linksys today (1-800-546-5797) and after spending an hour with level 1, I was told that "they are aware of it..." and I should have an answer soon (maybe within 2 days).

    I couldn't get any more information than that from them.

    Vista Home Premium, RV042, QuickVPN 1.2.5
  17. anhchangvuive

    anhchangvuive LI Guru Member

    I using QVPN 1.2.5 on Win XP. When the Connect to RV042 not working.
    Can you show me about the config VPN on RV042 using QVPN 1.2.5.

  18. klubar

    klubar LI Guru Member

    I've tried QuickVPN 1.2.5 on Vista Ultimate connecting to a RV082 without any success. For the time being, I'm stuck firing up a W2K virtual machine under vista and then conneting. As much as I love Vista (it really is an improvement) it's too bad that the software vendors didn't get on the bandwagon.
  19. JohnRF

    JohnRF LI Guru Member

  20. bigmountain

    bigmountain Guest

    Per MacMashers message. Any ideas for a WRV4000 running 1.1.09. Do we know when Linksys are likely to issue a new release?

    Glad I found this forum. At least I will no longer be wasting hours dicking around thinking it is something I have got wrong!
  21. Toxic

    Toxic Administrator Staff Member

    A new beta version of QVPN has now been released.
  22. Toxic

    Toxic Administrator Staff Member

    too bad MS had to change everything on a so called backward compatable OS. I must say I do like many new features on Vista, but the amount of problems it caused for vendors makes me think MS has one agenda, and stuff the rest of the world.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice