QuickVPN connects but no network

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Big_Joe, Mar 2, 2006.

  1. Big_Joe

    Big_Joe Network Guru Member

    I am stumped. I have gone thru the setup guides (thanks for those) and finally got QuickVPN to connect to my WRV54G. The software seems to be working properly. It goes thru its connection routine and then I get the green light in my task bar.

    I still can not see any of my network resources. I check for a IP address on my local network but I do not see anything listed as a network device for QuickVPN. I tried to access my home network server by name and IP address to no avail.

    Have I missed something in the setup? Am I doing something wrong in how to get to the server? Any help would be appreciated.
  2. TazUk

    TazUk Network Guru Member

    Can you ping anything on the remote LAN ?
  3. Big_Joe

    Big_Joe Network Guru Member

    Yes. I was able to ping the the IP address of the router and then I was able to ping the server address.

    However, I still can not make any sort of connection to the server or access any of the shares.

    I also have the Windows default firewall disabled on the server.

    One thing that bothers me is that the QuickVPN software does not appear to show as a device and does not get an IP address assigned to it. I have used other VPN clients in the past like the Cisco and Fiberlink VPN clients on other machines and they did not work this way.

    Is this normal for the QuickVPN? How is it supposed to work?
  4. TazUk

    TazUk Network Guru Member

    QuickVPN uses Windows built in IPSEC services so wont show up as a specific device. From memory I don't think it shows up with it's own IP under IPCONFIG.

    Is there a firewall running on the host PC?

    What does doing an NBTSTAT -A ip_of_server from the host PC give you?
  5. Big_Joe

    Big_Joe Network Guru Member

    I do not have any firewalls running inside my network at this time. Only the server was running the Windows firewall but I currently have it disabled while I am trying to get the VPN up and running.

    Sorry about the newb question, but did you mean that I should run netstat -a on the server, or by host you meant the test box I am running the QuickVPN client on?
  6. TazUk

    TazUk Network Guru Member

    Yep :)
  7. Big_Joe

    Big_Joe Network Guru Member


    Thanks for trying to give me a hand with this. After mucking around with it for a few more days I decided to simply replace it with a Cisco 851W.
  8. strongob

    strongob Guest

    I was hoping that there would be resolution to this problem as I am having similar difficulties. I am brand new to vpn (planning to use it with an upcoming emr implementation). With the help of this forum, I set up a rv042 and can connect with quick vpn. However, I cannot ping the router or any computers at my office network. Neither can I create a network place to a shared folder. The only encouraging thing is that the tcp/ip proprties have the router ip as the preferred dns server.
  9. QuimaxW

    QuimaxW Network Guru Member

    I to am having this exact same issue. In my test environment, I have my main DSL router in "Bridge" mode so I could set up two networks; one with my WRT54G, and one with the new WRV54G. It worked flawlessly here in that setup. Both routers had an external IP from my provider and I was able to VPN with QuickVPN to the WRV network and see a system w/ shares behind that.

    Now. I have the WRV setup w/ a PPPoE internet in the next city. By lowering the MTU on my client (to 1462), I am finally able to get QuickVPN to connect. However, the only device I can actually even ping is the router. I can also access the router's setup page from the internal address. However, I am unable to access any of the systems on the network from the VPN. Cannot ping them either.

    netstat -A ipaddress tells me that when I try connecting to the address it states that it's trying, then just quits after a while.

    Any thought?
  10. GerkAZ

    GerkAZ LI Guru Member

    Same/similar problem with additional info...

    I'm trying to connect to my office using QuickVPN installed on the remote client which is on a home network behind a linksys router. The office has an RV082 installed with the latest firmware. The remote client does establish a connection to the RV082 and I can ping the other PCs on the office network. But I cannot connect to any of the office PCs to access their file shares when connecting through the router on the remote network. When I try to establish a connection (e.g. "net use..." at a command prompt or type "\\[machine ip]" in the WinXP Run... command) I recieve the following error message after about 5 minutes - "The specified network name is no longer available". Windows XP firewall is disabled on both ends. I've attempted with Norton AV disabled on both ends.

    However...if I connect the remote PC directly to the cable modem, I can connect to the office PCs and access all file shares. So why am I not able to connect through the router??

    I've tried two different routers at the remote location. First a WRT54G, don't know what version number but I assume it is ver 1 since there is no version number on the tag and it was purchased long ago. The second router I tried was a WRV54G running firmware v2.37. In both cases I have enabled IPSec PPTP and L2TP passthrough.

    BTW, I originally tried to set this up with the WRV54G at the office and had the same result. After reading user feedback in the newsgroups about that router I purchased the RV082 thinking this would solve the problem.

    So far Linksys tech support is just having me jump through hoops seemingly in an attempt to get me to go away. Any ideas would be greatly appreciated.
  11. neverl8

    neverl8 LI Guru Member

    same here

    If you see the post I had created, I'm having the same issues. I guess I should of read before I posted. Does anyone have an answer for this??
  12. RobMohr

    RobMohr Guest

    RV042 - Quick VPN connection problems - Firmware V

    I have been tryng to get a client -> gateway VPN connection established at my office. So far I have sucessfully established a connection using the built-in PPTP server and the Microsoft PPTP VPN client, and also using the Linksys QuickVPN client.

    I am concentrating mainly on the QuickVPN method because of the IPSec security provided. Setup required that I reprovision the office network using the 10.X.X.X addressing scheme required by the QuickVPN solution. The RV042 was assigned an address of, and DHCP enabled to provide addresses to the workgroup PC's in the range

    The office LAN is configured as a workgroup (not an NT Domain) of mixed Windows 2000 and WinXP Pro PC's and a Windows 2000 server. The Windows 2000 server is Running WINS. Each of the workgroup PC's has it's TCP/IP configuration pointing to the WINS server ( and also has NETBIOS over TCP/IP enabled.

    On the remote side I have a WinXP Pro PC sitting behind a Linksys RT31P2 (3-port broadband router with two phone ports (vonage)). IPSec passthrough and PPTP passthrough are enabled on the RT31P2. The WinXP machine's TCP/IP configuration is also set to use the address of the WINS server

    After configuring a user account on the RV042, I was able to quickly (hence the name I guess... too bad the name isn't QuickFunctionalVPN) establish a VPN connection. I can ping all machines in the office workgroup, both by IP and by name.

    I can enter a UNC (i.e \\SERVER, or \\WORKSTATION) and I will be presented a login dialog. After entering an appropriate password for the remote PC, the PC and a list of it's shares are presented in Network Neighborhood. If I click on one of those shares however, explorer hangs until it finally times out with the follwoing error "\\server\share is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions". I contacted myself and said... Well, yes I do.

    From a command prompt I can enter a NET USE command such as:

    net use g: \\server\share * /user:username
    Type the password for \\server\share: ******
    The command completed successfully.

    A NET USE command reveals:

    Status Local Remote Network
    OK G: \\server\share Microsoft Windows Network

    Typing G: and enter yields:


    Looks good so far. Now a DIR,

    Volume in drive G is FILESRV
    Volume Serial Number is 7C4B-8932

    Directory of G:\

    File Not Found


    There is about a 30 second delay between the Directory of G:\ message and the File not Found.

    A nbtstat -A to the office WINS server yields:

    Local Area Connection:
    Node IpAddress: [] Scope Id: []

    NetBIOS Remote Machine Name Table

    Name Type Status
    SERVER <00> UNIQUE Registered
    SERVER <20> UNIQUE Registered
    SERVERNET <00> GROUP Registered
    SERVERNET <1E> GROUP Registered
    SERVER <03> UNIQUE Registered
    ADMINISTRATOR <03> UNIQUE Registered
    SERVERNET <1D> UNIQUE Registered
    .__MSBROWSE__. <01> GROUP Registered

    MAC Address = XX-XX-XX-XX-XX-XX

    (Names have been changed to protect the innocent ;)


    List of transports currently bound to the browser

    1 \Device\NetBT_Tcpip_{054B9923-6972-46A5-8395-46EBC2371207}

    BROWSTAT VIEW 1 yields:

    C:\>browstat view 1
    Remoting NetServerEnum to \\WORKSTATION1 on transport \Device\NetBT_Tcpip_{054B9923-6
    972-46A5-8395-46EBC2371207} with flags ffffffff
    2 entries returned. 2 total. 31 milliseconds



    Master Browser: WORKSTATION1


    Status for domain \\SERVERNET on transport \Device\NetBT_Tcpip_{054B9923-6972-46A5-8395-46EBC2371207}
    Browsing is NOT active on domain.
    Master name cannot be determined from GetAdapterStatus.

    NBTSTAT -r yields:

    NetBIOS Names Resolution and Registration Statistics

    Resolved By Broadcast = 99
    Resolved By Name Server = 37

    Registered By Broadcast = 6
    Registered By Name Server = 2

    NetBIOS Names Resolved By Broadcast

    After a series of NBTSTAT -A commands addressing each remote workstation by IP address, a NBTSTAT -c yields:

    Local Area Connection:
    Node IpAddress: [] Scope Id: []

    NetBIOS Remote Cache Name Table

    Name Type Host Address Life [sec]
    PC5 <20> UNIQUE 545
    PC2 <20> UNIQUE 537
    SERVER <20> UNIQUE 477
    PC7 <20> UNIQUE 547
    PC6 <20> UNIQUE 545
    PC3 <20> UNIQUE 535
    PC4 <20> UNIQUE 540
    PC1 <20> UNIQUE 492

    So, although I seem to be able to grab a name from WINS, NetBIOS broadcasts are *NOT* being passed through the quickVPN tunnel.

    I do not yet have an explanation for the lack of ability to list the contents of a share after it appears to have been connected sucessfully.

    I am open to any and all suggestions as to what to try next.

    Another interesting quirck is that with the QuickVPN client connected, I was able to add a remote machine (WORKSTATION1) to my explorer Network Neighborhood via UNC, and was able to map and browse the share. I even tried opening a file (jpeg) with success. This would tend to indicate a permissions problem going the other way, however I checked that the account and passowrd I used from the remote side were included in the share.

    The office to remote share that was mapped via UNC was from WinXP on the office side to WinXP on the remote side. If I try to go the other direction from the remote to the WinXP machine in the office it times out as described above.

    I have not yet tried UNC mapping a drive from one of the WIN2K machines at the office to the remote XP machine.

    Any advice on what I may be doing wrong would be appreciated.
  13. nindustrial

    nindustrial Network Guru Member

    similar problem

    im having the same problem (me too? ;)

    i finally got quickvpn working, thanks to the posts here, but cannot see the windows shares remotely. does the user that is setup in the router for vpn-access ALSO need to be setup as a windows user that has permissions to the remote machine maybe? i thought i would get prompted for a windows username and password when trying to access the share, that is separate to the vpn username and password.

    i have tried nbtstat -a for the remote ip (10.57.133.xx) but it responds with 'Host not found'

    the tcp/ip properties for the local client do switch the preferrred dns server to the remote routers internal ip ( which means something is working, but no windows shares..

  14. Fulien

    Fulien LI Guru Member

    Another Similar Problem

    Hi all,

    After reading through this thread, i realize i am not the only one with problems with the RV082 Quick VPN. When i just got my router i tried the QuickVPN and it did not work. It got stuck during one of the connecting processes. Then i upgraded my Firmware to 1.3.2 and used the latest Quick VPN software linksys have released. Then it proceeded further than where it used to get stuck. However it reaches the task "Veryfying Network" and takes about 10 mins and says Timed Out" I have practically tried everything, including changing the MTU Values. I believe i used the version 1038 for the VPN Client.

    Any insights on this anyone?

    and sadly this is not the only issue i have with the RV082 since i upgrade it to 1.3.2
  15. ReRun

    ReRun Network Guru Member

    Something I have noticed about the QuickVPN and a not so quick timeout on "Verifying Network" in my case was relieved by going into the VPN settings for the Non-quickvpn page and turning all my tunnels off. I think I also read somewhere that you can use Quickvpn or native vpn but not both.

    As far as opening file shares goes, I did not have a problem with it when I only used IP addresses. I don't think Quickvpn properly passes network names. Whatever config you folks are using to even get the names to work is beyond me but I would try it by IP address \\\documents and see if it works. It did for me. Just can't get RDP to open to save my life.

    OH, and as far as the other posts of having to connect directly to the Internet instead of being behind a router like the rest of the world, welcome to the club. I think there has to be a way to do this. VPN is usless if you can't use it in a hotel or coffee shop. I think the devil is in the details. We need a former cisco employee here.
  16. Fulien

    Fulien LI Guru Member

    ok i will try that. Does that mean i have to disable to the PPTP VPNs as well?

    Well when i have users VPN in using PPTP they have to use IP addresses as well to connecto to Local LAN resources. I think the reason behind this is because, the windows Network names uses "Network Broadcasts" to connect to the devices on the network and its known that the routers DO NOT forward network broadcasts to other networks. So even though you are VPN in i guess it doesnt forward network broadcasts to those users.

    Well i have users connecting to my network uing the same PPTP VPN who are behind firewalls.. I never got this quick vpn thing to work at all to try anything.

    Also.. i was told my one of the so called "Linksys online technitians" that the quick VPN client should be the only IPSEC Vpn software installed on the the computer for it to work. Apparently multiple IPSEC VPN software cannot reside on the machine simultaneously. According to the technitian that is.. I my self have no proof of it.
  17. DocLarge

    DocLarge Super Moderator Staff Member Member

    It's a fact (see the "Quickvpn Setup Guide" for confirmation). Quickvpn must be the "only" vpn client on your computer or it will not establish a connection. You "might" be able to get around this by turning off the service of any other vpn client you might be running...

  18. ReRun

    ReRun Network Guru Member

    I just retested some of this myself for the work I am doing on my own post. I left a PPTP tunnel active in my router settings. I tried QVPN and it worked. I though, WTH, I guess I was wrong. So I looked in the router and found that, earlier I had changed the IP from when I was trying this at another location. As soon as I corrected the PPTP settings to show my own WAN IP, QVPN broke with the same errors, a long, draw out "Verifying Network" and then an error. I double checked everything else I had changed and nothing would re-enable QVPN. I tested two more times even after that. In the middle of the 2nd test, after it had sat for a few minutes, I went to the router remotely and disconnected the PPTP VPN I enabled earlier, and in about 2 seconds, I got my connected popup from QVPN. I will post my other findings now to my own topic to further my issues also.

    I don't doubt that having another VPN client installed on your system affects QVPN but I know you can have Windows configured for other VPN Security polocies and it not affect it but only 1 can be active at a time as far as I can tell.
  19. Cornloaf

    Cornloaf LI Guru Member

    I have to administer two different networks for a client. In one location they got the RV082 and in the other location I was able to purchase all the equipment so they got a PIX515e. I have been using the Cisco VPN to connect to the PIX515e with no problems. After they bought the RV082, I figured I could get the Cisco VPN to work. I didn't.

    So I get the QuickVPN running and it works fine. I'm working on their network for a week and then I run into a problem. QuickVPN will connect, but it just hangs on Verifying Network. I check the forum and go through all the postings and see that you can only have one VPN application. I uninstall the Cisco VPN, reconnect and it hangs at the verifying network page. Now I am pissed because it is the biggest pain to uninstall any security related program on my laptop because of my security chip software. I must have spent 4-5 hours trying to get this to work. I checked my laptop and made sure that my wired connection was disabled since I was using wireless.

    The next morning I connect and it works. Now I am completely confused. I trace back what I did differently and that's when I realize that my cell phone was charging with the USB cable the night before. I have a Smartphone and when it connects to Active Sync, it creates a little network so it can use the computer's Internet connection or vice versa. I pulled out my phone and plugged it in and QuickVPN failed to connect. Running an IPCONFIG brought up a list of 2 IP addresses on my laptop, hence the confusion with the VPN.
  20. StonerMeister

    StonerMeister LI Guru Member

    Its important when using QuickVPN to ensure that all IP Schema is different. When you use QuickVPN you are routing traffic thru two to three networks depending on your configuration.

    Here is a configuration I know that works

    QuickVPN Remote IP 192.168.3.X
    RV082 IP 192.168.2.X
    SBS Domain 192.168.200.X

    Your problems should resolve if you make sure you IP Schemes are different. Hope this helps
  21. omoskowitz

    omoskowitz Guest

    I can't remove vpn client off my laptop ....help
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice