Quickvpn connects but you cannot ping or use network shares

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by matarvai, Mar 13, 2007.

  1. matarvai

    matarvai LI Guru Member


    I have following problem. I can open quickvpn connection just fine, but I cannot ping any computers on network only linksys router. I also cannot connect to network shares with \\ip address\sharename

    I don't know what to do. I have tried with different how to manuals, but no luck.

    Any ideas what could be the problem?
  2. Toxic

    Toxic Administrator Staff Member

  3. matarvai

    matarvai LI Guru Member

    I know netbios won't work, but I should see with ip address. And I should be able to ping servers. But that won't work either.
  4. ifican

    ifican Network Guru Member

    Are there firewalls on the machines in question that you are trying to get too?
  5. DocLarge

    DocLarge Super Moderator Staff Member Member

    Once you connect with quickvpn, open up windows explorer and do the following:

    1) Click on tools and choose "map network drive"
    2) Choose a drive letter
    3) In the folder field, enter ip address and the "share" name of the folder you want to access (i.e., \\\remote
    4) Look under that folder text box and click on "connect using a different name"
    5) If you're running an AD domain, enter a user account that's recognized by the domain to include a password. If you are running a workgroup, then enter the name and password on "that machine" that it recognizes; click ok when finished
    6) Click ok again; if you're credentials and the permissions to access the share are correct, you should be able to get in now.

  6. matarvai

    matarvai LI Guru Member

    There is only windows firewall on xp where quickvpn is and that is disabled. On server there ain't firewalls.

    I am as domain administrator on both machines, and with pptp client everything works fine. But it won't work with quickvpn.

    I have enabled https on router. Shutdown snmp and upnp. Also my quickvpn user password has eight characters.

    I really don't understand what is the problem. Also Greenbow client works perfectly, but I don't want to buy those licenses. I would like to use quickvpn.
  7. B4rT

    B4rT Network Guru Member

    I got this problem too , problem is quickvpn client cant start IPSEC protocol ,
    If you connect with quickvpn and restart IPSEC service manualy ,all is working ok .
    Still dont now how to fix this :(
    It is something with Active Directory Security Policy
  8. aviegas

    aviegas Network Guru Member

    Is your machine part of a "M$ domain"? The #@$@^% IPSec implementation under Windows can become really screwed with Group policies coming from the "Domain" controller (the one that "Domainates" the machines on the network).
  9. PASWebAdmin

    PASWebAdmin LI Guru Member

    I have this same problem, except one machine here in my office is able to connect with QuickVPN, my workstation cannot.

    I can establish a connection, and if I type really fast I can ping my server and even get a connection to a share, but right after that share shows up for me in explorer, if I try to open a sub-folder, it gives me the hourglass and eventually tells me the network resource is unavailable.

    This happens with and without firewalls in place (on both ends).

    The Green Bow works for me with a Group VPN connection, but I need to use QuickVPN for several locations.

    I have restarted IPSEC here, but I'd be interested to hear about the Group Policy settings on the AD - any input?

    Also, is there a registry tweak I could make on my workstation that might allow this to work? The machine here that will connect properly has been on a Cisco VPN before, and I suspect that there was some registry tweaking that went on to allow the connection. Suggestions?

    (And no, I am not trying to connect both of them at the same time - I realize that won't work behind this NAT router here in this location.)

  10. askingnv

    askingnv LI Guru Member

    Similiar problem - can't ping after QuickVPN connects

    I am experiencing a similar issue with the QuickVPN => RV042. Using the 1.047 / 1.038 and the newest 1.1.00 VPN client, I get a variety of failures.

    I have 4 RV042s that I manage. I have 2 separate pairs of connections between different offices.

    Office F (Static DSL) <======> (Static DSL) Office E

    Work (Dynamic Cable) <======> (Static DSL) Home

    While at home, I was assisting the director in her VPN from a remote site (Las Vegas to be exact) into the Work Router. She wanted to run Remote Desktop to pull some items from the database at work. (See next post for the description of that failure). She could not connect via PPTP, which is our usual way to connect and RDP. I talked her through the setup of the QuickVPN, remoted into the Work router from home and set up the Client side. I watched her log in (after several hours of playing with the setup), show online then she reported that she was disconnected. The RV042 showed her online still.

    <Problem Description>

    With the 1.100 VPN client, I get the initial connect string then it fails to complete the connection to the RV042. No data passes at all.

    With the 1.047 and 1.038 VPN Clients, I can connect to the RV042, but can not access the network at all - can't even ping the router! Any attempt to ping results in 4 "Negotiating IP Security" responses.

    From researching this on the web, Microsoft and http://www.securityfocus.com/infocus/1526, I expected 4 failures. Repeated attempts to ping have the same results. This was not what was found on the web sites for a successful connection...

    When I PPTP into the router (from a different location), I can observe the QuickVPN connection - shows online for the user. When the QuickVPN fails after 2-5 minutes, the connection still shows online. Any attempts to reconnect result in an immediate error that says something about the IP addresses of the server or client is wrong. I'll capture it next time I am testing.

    When the client connects, I ran IpConfig /all and the VPN connection does not show at all. The first DNS entry is the RV042 Router's LAN Ip address.

    When I am connected via PPTP, there is a entry for the network that I have the PPTP connection to.

    1. Has anyone figured out a solution to this problem of a QuickVPN connection succeeding but not being able to connect to the network?

    2. Why does the QuickVPN connection not show up in the Network connections?

  11. ainarso

    ainarso LI Guru Member

    I have some problem with RV042 v1.1 firmware QuickVPN and My english is very bad. Maybe someone can ask Linksys support why QuickVPN doesn't work?
    Additional question - may I upgrade RV042 v1.1 to firmware or it's only for RV042 v1.0 ?
  12. wylieinc

    wylieinc LI Guru Member

    Quick VPN issue - same issue

    I am having the same problems described by Askingnv.
    Manual restart of IPSec service didnt help.

    I am trying to connect to my office down the street. No AD involved.
  13. aviegas

    aviegas Network Guru Member

    QuickVPN is just a shell on top of Microsoft's IPSec code, that is based on security policies not on a connection or interface as other implementations use. They only way to know it's on/off is to query the IPSec policies.
    MS code is ugly and hard to debug a bad "connection".

    QuickVPN will show as connected as soon as the shell code requests, using HTTPS, a dynamic tunnel to be create and the random PSK to be sent in return. This PSK will be used by the MS code to establish the "tunnel".

    If you are using Windows XP, have you checked this?


    If you are running Vista, so far I've never seen a successful IPSec tunnel to a RV0xx router from a Vista machine using MS code.
  14. ainarso

    ainarso LI Guru Member

    This update didn't help. Is there any alternative non-commercial vpn client available?
  15. aviegas

    aviegas Network Guru Member

    QuickVPN is a "proprietary" protocol, so there is no alternative.

    If you can live with multiple users sharing the same PSK, you can go with "Group VPN". There are several clients available (commercial) and it can connect directly with Windows XP/2000, but configuring these guys manually for dynamic connections is not for the faint of heart.

    I like TheGreenBow VPN client. Works fine with RV0xx in "Group Mode", but they are not free.
  16. grep1

    grep1 LI Guru Member

    Sorry I'm a real newbe with this. Does this mean using the RV042 and the QuickVPN utility I cannot access shared resources by name? If I can't than how do you access them?

  17. DocLarge

    DocLarge Super Moderator Staff Member Member

    Normally, you'd have to access them using the "IP Address" of the device; however, I think Toxic has just posted an update somewhere in this forum that quickvpn supports browsing via Netbios by now.

    I'll check with him to see that is the case and not wishful thinking on my part. :)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice