quickvpn.stuck at 'verifying network',tried everything.Help

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by dougD, Jun 21, 2006.

  1. dougD

    dougD LI Guru Member

    Hello all, I have a client who has cable internet with a Linksys WRV54G VPN router. I want to use quickvpn but it always fails at 'verifying network'. I have the client installed on windows 2000 and xp systems. The machines have no other ipsec software and I have the windows XP firewall disabled. The office where the wrv54g is installed in has a ip range of 10.x.x.x and all the client locations have 192.168.x.x. I have read all the sticky notes here and have gone through most messages looking for similar problems but nothing has helped. The wrv54g has it's mtu set to auto but I have tried all combos of static mtu numbers starting from 1492 to 1350 and lower. One thing that may be related is I cannot get a good ping from the clients location. I tried ping -f -l www.yahoo.com 1472 with + or - 10 numbers and always get 'packet need to be fragmented but df set' error. Not a good ping ever. Should I get comcast to come out and check the cable modem's signal levels?
    I'm really looking for any next steps to take so I can get a good quickvpn connection.

    Thanks for any info.
  2. ReRun

    ReRun Network Guru Member

    Did you setup anything in the PPTP section? If so, disable it. This is under Security/VPN on the WRV54G.
  3. ccbadd

    ccbadd Network Guru Member

    I always have that problem on machine with both ethernet adapter and a wifi adapter. I have to disable which ever one is not active. If both are active, I disable the wifi radio.
  4. dougD

    dougD LI Guru Member

    Thanks guys for your ideas and things to check. I believe the pptp is disabled but I will verify today. Also great idea about disabling the other adapter that's not being used.

    Thanks again.

  5. dougD

    dougD LI Guru Member

    Well guys, I tried all the suggestions but I still get stuck at the verifying network. Any other ideas? I think I should get comcast out at the site to check the signal levels for the cable modem.

    Oh and my backup plan is hamachi. Anyone have any good results using it?


  6. djdconsulting

    djdconsulting LI Guru Member


    I tried "Hamachi" because I needed a solution for a Mac to connect to a Windows machine remotely and since Linksys doesn't have QuickVPN for Mac I thought this might work.

    I played around with "Hamachi" and thought it may be a good alternative for a "VPN" solution. It requires you to install the software on all machines that you wish to connect and it is quite simple to do. HOWEVER, it is very slow and depending on your internet connection between machines can adversly effect it too. Also, being that it is "peer-to-peer" it is possible that someone out there could find your group and access your machines.

    I tried opening up MS Word and Excel documents and it was just too slow. Bottom Line is that I got rid of it after a couple hours of testing and found out it really wasn't for me. Try it though, it may work in your environment!
  7. DocLarge

    DocLarge Super Moderator Staff Member Member

    MTU normally becomes an issue (or at least in my experience) "after" you've connected with quickvpn. For instance, my quickvpn connection would drop 3mins into a session consistently. When I changed the mtu, I had a good connection from there on out. "Verifying network" almost always comes down

    - Two vpn clients loaded
    - One of the 50 vpn tunnels open on the router (it has to be one or the other; you can't run quickvpn "and" an IPSEC tunnel at the same time)
    - The WRV54G loses internal sychronization due to quickvpn shutting down during a session or there's been a large file download; both of these require the unit to be rebooted to clear the "verifying network" problem

    Incidentally, turning pptp on or off doesn't effect quickvpn performance because it (initally) looked for a connection on port 443 until the latest release (I believe 60443 is now an additional port). I use to wonder this also until it was verified that the WRV54G doesn't pass GRE (Protocol 47) or allow forwarding to port 1723.

    I will say I've had the occasional anomaly where quickvpn wouldn't work for nuthin' even when it was the "only" client on the computer. I chalk situations like that up to the OS, to include particular applications. The best way to achieve good quickvpn connection (even though it's so damn finnicky) is to monitor "everything" you load on your system. This way, if it stops working, you have an easier point of reference.

  8. dougD

    dougD LI Guru Member

    Hey Doc, On your sticky for quickvpn you have the following info

    2) Security ---> VPN Page

    Ipsec: Enable
    PPTP: Enable
    L2TP: Disable

    However you just mentioned to me - "One of the 50 vpn tunnels open on the router (it has to be one or the other; you can't run quickvpn "and" an IPSEC tunnel at the same time"

    So should I disable everything on the vpn page so the ipsec,pptp and l2tp will read 'disabled' ??


  9. Toxic

    Toxic Administrator Staff Member

    Doug. QuickVPN uses IPSEC afaik.
  10. DocLarge

    DocLarge Super Moderator Staff Member Member


    you don't have to do that. The PPTP and L2TP options will "never" be a factor that hinders quickvpn connectivity. The IPSEC, however, must be enabled regardless in order to allow incoming quickvpn/IPSEC vpn tunnel connections. It's safe to say, IPSEC needs to "always" be enabled.

    Don't confuse having "IPSEC" enabled with "having one of the 50 IPSEC tunnels enabled (waiting for a connection). In my experience from what I've seen with "my two eyes," depending upon the router you are connecting from, the WRV54G won't except an IPSEC third party client session, a site-to-site connection, or a quickvpn client connection on a WRV54G at the same time. You can have a third party IPSEC client session and a site-to-site connection, but a quickvpn client session won't connect if "any" of the internal WRV54G 50 IPSEC VPN tunnels are enabled.

    Here's the rub: if I had my Netgear DG834G router running on my local subnet, I could have a site-to-site connection running from the DG834G to the WRV54G, and "still connect out" with quickvpn and connect! How crazy is that!?!?!?

    Forgive me for mentioning this, but the DG834G is an awesome little router. FYI, it runs a solid tunnel between it and the WRV54G..

    Quickvpn is finnicky, 'nuff said... :)

  11. YesTech

    YesTech Guest


    I have been fighting with this myself, wondering why it is so "finicky" as another respondent phrased it. I think I may have just discovered the source of "finick", at least in my case. My network layout has 2 main offices, each with RV042 VPN appliances, and a functional tunnel defined between the two so that all network resources can be shared. In each city there are also folks who need to work from home, and QuickVPN is the logical poison for that. Client accounts are created in the respective RV042, the latest version of QuickVPN is installed in the user's home PC, and joining the office network remotely is a snap, right? Well, most of the time, yes. But other times it either stops at "Verifying Network" for about 10 minutes, or immediately goes to "the remote gateway has stopped responding".

    Tonight I have been setting up a new PC to send to a remote office, and, logged in as the local admin, installed, configured, and tested all of the necessary software including QuickVPN. I then logged into the user's account (non-admin), fired up QuickVPN, and everything looked good up until a very extended "Verifying Network" that eventually failed. I then logged back in as the admin account and it worked fine, back to the non-admin user and it failed. I then modified the QuickVPN shortcut to run with "alternate credentials", quit the instance in the system tray, fired it up again, this time providing credentials for the admin user, and it worked right off the bat.

    In short, it appears that the QuickVPN client must be run by a user with admin privileges. That is obviously a bad thing for those of us that actually want to protect the network. However, I can see where QuickVPN would need admin privs, as it is mucking about in the IPSEC config, in DNS client config, and in the routing tables. I'm going to see if I can kick off the program with stored admin credentials and have it already running for each user that logs in.

    In your case, if you're not using an admin account, give that a whirl and I just bet it gets you further down the path.

    Doug Campbell
  12. dougD

    dougD LI Guru Member

    Thanks for all the great suggestions. However I'm still not able to connect to the router from any machine. I did notice that VPN Tracker just released a updated version of their mac vpn client that now adds linksys vpn support. So I will hopefully be able to connect via the ipsec mac client and if so maybe I can talk my client into one of the non linksys ipsec software windows based vpn clients available. I was shooting for free and easy. I do think I will have my client call Comcast back so we can have the modems levels checked since I have a funny feeling something is not 100 percent.


  13. dougD

    dougD LI Guru Member

    Hey guys, I wanted to update this thread with the info that I got the Linksys Wrv54g vpn working with the linksys quickvpn client. All I did was perform a factory reset and put the *exact* same settings I had in the router prior to the reset and it worked !

    <banging head against wall !>

    So if anyone else reads this post and before you start pulling your hair out, reset to factory defaults first and start adding settings and test.

  14. Toxic

    Toxic Administrator Staff Member

    glad it worked for you
  15. EyeWallInc

    EyeWallInc Network Guru Member

    From what I can see this is a problem with the client, not the router or remote host. I say this because I have multiple sites set up and once I get hung up on the verifying network message I get the same result if I go to another router and try to connect.

    I have the same problem whether other VPN clients are loaded and in the systray or not, so I don't think they're interfering.

    The only way I've been able to resolve this is to physically power the client machine off for at least 20-30 minutes come back and connect. Don't ask me why but this works every time on my laptop and desktop machines, over both broadband and dial-up.

    Whatever the cause, Linksys is as puzzled as we are, and are very little help. Perhaps we need to call more so this is promoted to "bug" status.

  16. ReRun

    ReRun Network Guru Member

    Some of the things I have had to do to get mine working jive with DougD. The 1st one of these I did, I first tried the XP IPSec methed before QuickVPN. At the time, I did not know you can't have the IPSec stuff in the router setup to your IP AND use QuickVPN from that IP as well. The hardware reset seamed to be the cure for me until the next customers setup came along. This one, I played around with to find out what really works. Here are a few things I learned:

    Before a firmware update, get the firmware downloaded and then do a hardware reset on the router to dump all your settings. Get in and do the update before doing any of your setting changes. This keeps fields that Linksys changes from firmware to firmware free of boogers.

    QuickVPN will not save your password. This results in users keeping passwords simple so they can type them in each time. This is very dangerous. I up in random alpha-numeric user names that the QVPN software will remember and let the user keep his password simple. This makes it hard to crack but there is a limit to what the username can be in length. I have had this change from time to time. I tell you, you wouldn't think this would mater but this is EXACTLY what I have seen. Started with a 63 char. username and it connects all the way to the "Verifying Network". From what I understand, the username/password has happed already and the random PSK is already downloaded into the Freeswan settins but it STILL hangs. I have dropped the username down 10 char. at a time and get connected somewhere around 20 characters.

    If you have people connecting with Win 2k & XP IPSec, don't set the router directly to the IP of the client if you plan on also letting people use QuickVPN. Set the IP to ANY instead. If you try to create a QVPN connection from a IP listed in the IPSec section, it will hang on "Verifying Network".

    Frankly, I think QuickVPN is a joke. I have made a IPSec connection with a MTU of 1490 but on the same computer, I have to drop this to 1400 to get QVPN to work.
  17. bongua

    bongua Guest

  18. drmorien

    drmorien Guest

    Try This

    I have been playing with this verifying network hang issue with a couple RV016 routers. If you do an IPCONFIG you will see your regular Ethernet and the VPN Ethernet connections. I have a static wired Ethernet so I do an "IPCONFIG /release" command from a DOS prompt, setting the VPN connection to I then try and connect and it works. It may take a minute at the "verifying network" stage, but it does connect. Disconnect, do the ipconfig /release and try again and it works. Could someone else try this and verify that is a workaround? Thanks!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice