R63, my drive only works in port 2 now?

Discussion in 'Cisco/Linksys Network Storage Devices' started by SeanFL, Sep 27, 2005.

  1. SeanFL

    SeanFL Network Guru Member

    I was having an issue writing to drive attached to usb1 (it was formatted with the initial firmware release, so it must be ext3 I believe.). Worked fine one day, then the next I can't write to it.

    So I upgraded to R63 and now I can't use that drive on usb1...only usb2. That goes against what their release notes say (for whatever that's worth!)

    SO...anyone else have the same issue?

    I have R25 still saved on my machine...but don't have R29. If I want to go back to R29, anyone post a link to it?

    Also, what should I try to get write privileges back to the drive? Even when it's plugged into usb2, I can't write to it.

  2. d__l

    d__l Network Guru Member

    Have you scandisked the HD recently? Do that if you haven't first. Also shut off UPnP if it is enabled on the NSLU2.

    Have you tried powering off the NSLU2, then the HD, then disconnecting the HD, then powering on the NSLU2 until it is ready, then powering it off, reconnecting the HD to usb1, powering on the HD, and then powering up the NSLU2? Don't try accessing the HD until the until the NSLU2 beeps that it is ready.

    People have reported curing this read only problem going through steps similar to the above procedure. This may be an indication that your drive enclosure isn't 100% compatible with the NSLU2.

    Edit: This method may not work properly because your drive was read only before you upgraded the firmware.

    On R63, the NSLU2 supports ext3/FAT32/NTFS on usb1 and an undocumented ability to support multiple drives of the same type through a hub on usb1. It supports ext3/FAT32 on usb2.
  3. SeanFL

    SeanFL Network Guru Member

    scandisk did it...I can now save, delete etc. I decided to backup everything from the drive and reformat just to make sure all is fine. I format it, and ... everything is still there acording to the file manager.

    anyone else not have a format take? Just for clarification, I have an ext3 drive plugged into the usb2 port.

    would you advise me to not go NTFS yet? Do I understand correctly that if I want to use NTFS I need to format it on my local machine, then hook it up to the NSLU2, right?

    thank you for your help. Sean
  4. d__l

    d__l Network Guru Member

    Glad that scandisk worked for you to open the write funtionality!

    Yes, the NSLU2 can't format a disk in NTFS or FAT32. You would have to format it attached to a computer if you want those formats.

    If this is critical back up data, I wouldn't use NTFS or if you do use NTFS for critical data, you should have two drives, NTFS in usb1 and ext3 in usb2, and copy your back up data to both.

    Frankly I'm not clear if ALL the functionality: shares, user, passwords, backup, etc. of the NSLU2 works on the NTFS drive when both an NTFS and ext3 drive are connected. None of that functionality works if just the NTFS drive is connected.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice