R7000 "random" reboots

Discussion in 'Tomato Firmware' started by Bunsen, Mar 22, 2019.

  1. Bunsen

    Bunsen Reformed Router Member

    I just upgraded to the newest FreshTomato [2019.1]
    When I upgraded, it checked the "clear nvram" box.

    I've put most of my config back in place, but it did reboot a few times during the configuration.

    I'd like to see if there is anything in the logs... So I try refreshing the log page several times - I haven't been able to catch anything that points me to a possible cause, but I assume I'm missing the error due to the reboot and loss of the log.

    Is there a way to get the logs to go someplace else for easy parsing?
     
  2. eibgrad

    eibgrad Network Guru Member

    I would still do a reset *after* the firmware is successfully installed, despite having checked the "clear nvram" option *during* install.

    As far as the syslog, you can reconfigure it to write to persistent storage (jffs, usb drive) instead of /tmp by going to Status->Logs->Logging Configuration->Syslog and providing a custom path. Or else have the syslog sent to a PC running Visual Syslog Server.
     
  3. Bunsen

    Bunsen Reformed Router Member

    A through nvram clear seems to have done it.

    Thanks as always!
     
  4. Bunsen

    Bunsen Reformed Router Member

    I replied too soon. It still happens.
    Now logging to jffs.
    Its done it twice since making the log location change - but it doesn't seem to be helpful.
    The only entry in the log is that my vpn made its connection, next are messages from Jan1 8am.

    The only other change I made recently was a Plex server upgrade.
    I've turned off the server, and I'll see if it stays up over night. [more than 2hr would be a success]

    I saw some others reporting Plex making their router reboot as well, but older articles. Maybe its back?
     
  5. Bunsen

    Bunsen Reformed Router Member

    No good. still an issue. Reboot once every 2-10min.
    Turning off VPN/Adblock/ipset script - if its stable.. turn one on at a time.
     
  6. pedro311

    pedro311 Addicted to LI Member

    First, turn off Adblock and see what's going on.
    If no change, ipset rules (you can copy them here, BTW).
     
  7. Bunsen

    Bunsen Reformed Router Member

    I had vpn/adblock/ipset off - still had the reboots.
    I decided to do another thorough nvram clear, and add one setting at a time.
    ONLY Added my PPPoE info, and 5GHz wifi settings - I'll let this ride for an hour to make sure it's not the router itself.
     
  8. Bunsen

    Bunsen Reformed Router Member

    good news/bad news.

    Good news: I think all my required settings have been configured
    Bad news: The rebooting has not come back, so I have no idea what the cause was.
    weird....
    Thanks for checking in.
     
  9. Bunsen

    Bunsen Reformed Router Member

    I know this is old.. but i have an update...
    When I had recreated my config the way I wanted manually. Excluding the 2.4Ghz wifi.
    All has been fine.

    Friday I re-added the 2.4Ghz radio to add an older security cam before leaving for the weekend.
    Once I readded it, let it run for a bit I left the house. Soon after, I started receiving restart alerts.

    I'm home again, and disabled the radio, and all is fine again.
    So... either the 2.4Ghz radio hardware is causing the issue - or the config causes it. I assume its hardware because surely at least a few other R7000 users are using 2.4Ghz and aren't complaining.
     
  10. eibgrad

    eibgrad Network Guru Member

  11. Bunsen

    Bunsen Reformed Router Member

    That's an interesting find, thanks for linking it. I think it's unlikely the issue in my case though.
    The camera is a fair distance from any other device [usb or wifi]. It uses a microSD card for storage.
    https://support.dlink.com/ProductInfo.aspx?m=DCS-5222L "Type A"

    The possibility I didn't include above is that it could be the camera sending weird traffic that causes the crash?
    I guess I'll try enabling the radio on the router without joining the camera to the network.
    At this point it's just an academic exercise - the camera is due for an upgrade [since it doesn't appear to be able to use the 5GHz connection].
     
  12. Magister

    Magister LI Guru Member

    I also have random reboot every few days on my R7000 since either 2019.1 or 2019.2, but I have minimal settings, only some static IP, 1 openVpn server, some access restrictions. No adblock, nothing else.
     
  13. Bunsen

    Bunsen Reformed Router Member

    - Have you tried turning off the 2.4GHz radio?
    - I also had a theory that it might be related to the DDNS - set it to a 10min schedule to see if it starts rebooting every 10min... I haven't had a chance to test.
     
  14. Magister

    Magister LI Guru Member

    I have some devices that are 2.4GHz only so it may be hard to test... or I can turn on my old E3000 to try.
    However I have a DDNS, forcing a "next update" works and no reboot.
     
  15. Bunsen

    Bunsen Reformed Router Member

    @TrueDis We're having reboot issues too.
    I seem to have "resolved" mine by disabling the 2.4GHz radio. Are you able to test the same?
    btw - which router?
     
  16. digixmax

    digixmax LI Guru Member

    I am following this thread with great interest since I have been holding off updating my home-gateway router R7000 which has been running fairly reliably with 2019.015-beta since it was first released. I had a few unaccounted-for reboots over the months but nothing seemingly alarming.
     
  17. Magister

    Magister LI Guru Member

    I tested something interesting... I'd like other people with a R7000 to test it.
    To easily check if the router rebooted, in the system command webpage I did a
    gpio enable 14​
    to light the last LED on the right. So with a quick glance I can see that if the led is off, it means the router rebooted.
    Yes, it works, 2 times I saw the led off, and when I checked the homepage I saw an uptime of a few hours, meaning the router rebooted.
    BUT what's interesting also is that maybe 3 times in the month, the led was off when I checked, but the router had NOT rebooted. It means that something, after a few days (be it 1, 3 or 7) switch off the led!?!??! What's playing with gpio 14 in the R7000? Is this a memory leaks?
     
  18. Bunsen

    Bunsen Reformed Router Member

    @Magister I have set "gpio enable 14"
    I do have a script that sends a prowl alert when a reboot happens, so as far as I know I no longer have the reboot issue, but I'll see if the led goes off.
     
  19. Mercjoe

    Mercjoe Network Guru Member

    I would not trust the new LED light changes. I randomly lose the USB 2.0 and 3.0 lights on my R7000. If I unplug a drive and then plug it back in the lights come back on. Sometimes they go out in a few hours, other times it takes days.

    I do not lose any functionality but the lights seem to turn off randomly on my router.
     
  20. Bunsen

    Bunsen Reformed Router Member

    @Mercjoe I saw in the latest firmware [2019.2] the changelog mentions lots of LED work/mapping being done. Are you on the latest? I'm still on 2019.1.
     
  21. Mercjoe

    Mercjoe Network Guru Member

    I am on 2019.2. I have not experienced any random reboots and other than the cosmetic loss of a few LED lights it has been rather stable for me.
     
  22. Bunsen

    Bunsen Reformed Router Member

    @Jacky444 I saw you were having "random" reboots also [although on a different router AC3200] - We're dealing with the same in this thread.
    I'm going to assume you are configuring this through a wired connection [correct me if that's wrong].
    Can you try disabling both radios [or at least the 2.4GHz] and see if it still reboots? I believe my issue was "resolved" by doing this. I understand it's not for everyone as you may have a need for 2.4GHz, but just another data point to test.
     
  23. Jacky444

    Jacky444 LI Guru Member

    I'm sadly back to AT and I'm not reflashing for some time now (work). I did upgrade AC Wireless drivers on newest firmware I'm working on and it still works just fine.
     
  24. Magister

    Magister LI Guru Member

    9 days ago I disabled 2.4GHz, and re-enabled it a few seconds after. I still have 9 days uptime, will see...
     
  25. TrueDis

    TrueDis LI Guru Member

    Netgear R7000. I cannot disable 2.4ghz on my network as some of my stupid devices don't support 5ghz.
     
  26. user17600

    user17600 Serious Server Member

    Another data point: my R7000, purchased in May 2016 (in case there are undocumented versions) has been running flawlessly for 27 days (since the 2019.2 release). At one point it was running a version of Shibby (before FT brought out more frequent updates) for over 8 months without a reboot.

    I do keep it on a laptop cooler, to maintain the CPU and internal temps of about 50°C / 120°F. Otherwise this thing runs pretty hot (north of 175-180°F).

    I am running built-in adblock, with 11 blocklists making for a total of 479,217 entries, and I run P2Partisan from the CIFS for IP range blocking. I have 2 teenagers using the internet, so this router is working hard (if for nothing else than checking those adblock lists).

    On 2019.1, I had 2 random reboots, neither triggered by anything I could identify. One occurred during my work hours, so I noticed it. The other was only noted because the uptime was shorter than I expected. The router and cooling pad are both on a UPS so it wasn't due to a power glitch.

    I have no insights on why some of you may be having random reboots, except to wonder if, as with many routers 2-3 years old, if the heat is finally getting to the main board. Random reboots, loss of wifi and such are symptoms of long-standing overheating, and no electronic device likes heat for long periods, even if "designed" for it.

    My E3000 and N66U both died from heat-related causes. Thus the laptop cooler for my current router.
     
  27. JimDeee

    JimDeee New Member Member

    I also recently upgraded to 2019.2 from 2018.3 and have this random reboot issue on my R7000. I don't use VPN, adblock or have anything plugged into the USB ports. CPU temps are fairly stable at 65 degC.

    I can't turn off the 2.4 GHz radio to test as I have devices that aren't 5 GHz compatible.

    So far the longest uptime I've seen before reboot is 4 days.
     
  28. Magister

    Magister LI Guru Member

    Connect with a cable, then disable 2.4GHz, wait a few seconds, re-enable it. I was like you with reboot every 1-4 days, now I'm at 23 days without a reboot.
     
  29. JimDeee

    JimDeee New Member Member

    Ok, I've done that...now we'll wait and see.

    If this works, does anybody have an idea why it works?
     
  30. Magister

    Magister LI Guru Member

    Some config were removed like the TX power then re-enabled, I guess when the WL was launched with its parameters there was some wrong one.

    I am almost certain it was a kind of memory leak because I noticed my LED on gpio 14 that I used to toggle manually after boot, after a few days would be off by itself, so something was overwritting memory somewhere. Disabling/Enabling WL certainly reset some parameters and now it works fine, my LED on gpio14 is on for 24 days meaning the router didn't reboot.
     
  31. Bunsen

    Bunsen Reformed Router Member

    @Magister I'm glad it's working for you - but I don't think restarting the radio is the fix.
    In my case I need to keep the radio off, or the reboots start again when the radio is restarted.
    But again - glad it's working for you. What ever it was/is.
     
  32. jradams76

    jradams76 Network Newbie Member

    I have 2019.2 installed and just recently started getting the random reboots. Has anyone figured it out yet or will a fix be in 2019.3?
     
  33. Bunsen

    Bunsen Reformed Router Member

    @jradams76 I'm still trying to find clues. I've recently added more logging to some scripts that I run to see if it'll catch something. Other than that, I don't think we're any closer.
     
  34. jradams76

    jradams76 Network Newbie Member

    Thanks I look at the logs but I don’t see anything useful either. I turned off qos as the router seemed to be working ok beforehand and started doing this after I enabled but it still reboots randomly. It will go for a couple hours and then reboot so I guess that’s better than the 10 min rebooting. I can try shutting off the 2.4 wireless and see if that helps. I currently have vpn running with maybe 10 static IP addresses so I shouldn’t have a lot in the nvram.
     
  35. JimDeee

    JimDeee New Member Member

    After restarting the 2.4 GHz radio my R7000 router lasted 7 days before a random reboot, which was longer than the 4 days I was getting before. But it doesn't seem like a permanent fix.
     
  36. boricacid

    boricacid New Member Member

    I registered to these forums just to add I also get the same issue with both 2019.1 and 2019.2. I did not try anything earlier than these two. I turned off 2.4ghz completely and disabled my VPN server and am still getting random reboots. I really hope we can figure this out because it's really annoying when it happens while gaming or streaming.
     
    jradams76 likes this.
  37. JoeDirte

    JoeDirte Networkin' Nut Member

    It's concerning to see all these posts of R7000 owners experiencing random reboots. I have an R7000 running 2019.2 with only 2.4Ghz enabled. It's never rebooted on its own. Only when commanded by me. I'll certainly chime in if I ever get a random reboot.

    In case it matters: I'm bridged to my ADSL modem and use PPPoE on the R7000. Not using multi-WAN.
     
  38. HorseCalledHorse

    HorseCalledHorse LI Guru Member

    I was getting random reboots on my R7000 running FreshTomato 2019.1 but they stopped when I turned off the built-in Adblock and started running a script instead. Since that time I've been up for 80 days, stable as hell - so stable I haven't upgraded to 2019.2.
    Like JoeDirte, I'm bridged to my cable modem, no multi-WAN. Running 2.4 and 5 GHz wireless.
     
  39. Bunsen

    Bunsen Reformed Router Member

    @HorseCalledHorse That [turning off the built-in adblock] was one of my first steps. This is not that - at least for me.
     
  40. Bunsen

    Bunsen Reformed Router Member

    @pedro311 I think it's great you want to help [I saw your msg in the main thread] I think anyone in here is willing to help.
    We've mentioned the logs do not show anything at the time of reboot, its just a crash.
    I think we all realize just complaining about it isnt useful, so what can we do to collect some useful/actionable info?

    Is there a way to make the system logs more verbose?
     
  41. Bunsen

    Bunsen Reformed Router Member

    A thought just occurred to me: The only non-standard thing I'm doing is using "ipset" - of those who have this issue: using ipset?

    I'm not even sure if that's considered unusual.

    Other than that:
    I do use VPN client with split routing.
    And DDNS is configured with https://www.dyndns.com/
    JFFS is enabled for a few scripts..and now saving logs there

    None of the following:
    - Ad Blocker
    - Webserver
    - USB [Just found this was enabled. but I wasn't using it... now disabled]
    - QoS
    - Multi-wan
    - IPv6
    - TOR
    - BitTorrent
    - FTP
    - File Sharing
    - Media Server
    - NFS
    - SNMP

    I've found the Administration>Debugging>Console Log Level.. Changed it from 1 to 6.
    Update after the weekend.
     
    Last edited: Jun 14, 2019 at 5:30 PM
  42. jradams76

    jradams76 Network Newbie Member

    As another try I reset the router to factory settings in FreshTomato by using a paper clip to hold the small button in till the router rebooted. I then only applied the following settings so far:
    - Setup OpenVPN to connect to my LAN while away from home
    - I have a Linksys e4200 router acting like a access point
    - Also use duckdns to help with the IP changes by my provider

    I do not have QoS turned on yet as I wanted to wait to see if I start getting reboots.
    No Static IP addresses yet

    I'm happy to say I'm at 1 day and 15 hours. Usually it reboots around the 18 or 19 hour mark. Maybe something was still stuck in the nvram? and that reset helped clear things out? Ill report back in a couple days to see if its still reboot free.
     
  43. pedro311

    pedro311 Addicted to LI Member

    Good, let us know.
     
  44. masster

    masster LI Guru Member

    I am on FreshTomato 2018.3 and the router (R7000) reboots as soon as I connect with my 2.4GHz device and start downloading some files. Disabling 2.4GHz radio helps in this case. Lucky I don't have many "2.4GHz only" devices so I can live without that but I am not sure if it is hardware or software issue when it started for many of us aproximately in the same time.

    I use only internal ad-block + usb file sharing + dnscrypt-proxy.
    No VPN or QoS.

    I use a script for turning off all LEDs after boot. I have noticed that after several days without restart some of them were turn on by itself and sometimes the 2,4GHz radio was disabled by itself so I had to manualy enable it.

    Now I've disabled 2.4GHz radio and in next days/weeks I will be checking the router for unexpected reboots.
     
  45. pedro311

    pedro311 Addicted to LI Member

    I presume, you clean NVRAM, before this report?
     
  46. masster

    masster LI Guru Member

    I cleaned NVRAM before upgrade to this version and right after the upgrade. It was a year ago. Then I did my configuration. Router run stable for couple of months without issues.

    The reboots started 2-3 months ago and I did no changes.
     
  47. Bunsen

    Bunsen Reformed Router Member

    @pedro311 I assume you're asking If I did a nvram clear? Yes I did.
    Changing the console log level has not changed anything - It does not look more verbose.
    I confirmed it changed here:
    Code:
    root@Study:/tmp/home/root# cat /proc/sys/kernel/printk
    1   4    1    7
    root@Study:/tmp/home/root# dmesg -n 7
    root@Study:/tmp/home/root# cat /proc/sys/kernel/printk
    7    4    1    7
    
    I tried starting the 2.4GHz radio again [just because I know this causes a reboot for me, but apparently not everyone]. Reboots occur roughly every 10min, but the log indicates nothing.
    So, how can I collect info you can use? Any help is appreciated.

    @masster Are you collecting logs?
     
  48. masster

    masster LI Guru Member

    I was only checking /var/log/messages during "crash" but there was no entry with error message at all.
    It just crashed, restarted and kicked me out of course.

    If there is some other method how to collect different logs I am willing to do so.
     
  49. Bunsen

    Bunsen Reformed Router Member

    @masster I configured the log to go to jffs so that after the crash I'd be able to look to see what happened. Unfortunately, it's not showing anything useful.
    So, I'm also looking for a way to get more log data out from right before the reboot. Even changing the console log level has not worked.
    I'm open to suggestions
     
  50. Bunsen

    Bunsen Reformed Router Member

    Good news(?)/bad news: My family bought a wifi enabled vacuum robot. It only connects to 2.4GHz; so I added an older DIR-868L to the network as a wireless bridge [WDS] on the 5GHz band to allow the vacuum to connect to the network on the 2.4GHz radio.

    So my update...
    The Good(?): Since making this change, I have not had any random reboots. It's only been 2.5days, but that's longer than was typical before this change. I do not believe adding a router to the network fixed the issue.
    The Bad: This does NOT help determine root cause and I'm not sure of next steps.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice