Really odd problems with briding on a WRT54G

Discussion in 'Networking Issues' started by jennam, Sep 25, 2006.

  1. jennam

    jennam Guest


    I've been beating my head against a wall for days trying to replace my existing access point with a Linksys WRT54G. The setup - to me - is a very simple, yet I'm having no end of problems.

    Essentially with my current AP (non Linksys which Im wanting to replace), I have my switch plugged into the LAN port, and nothing plugged into the WAN port. I have a default route set on it on the LAN port to my central firewall which also manages my ADSL connection. Essentially, the AP just acts as a simple wireless bridge onto the LAN - nothing tricky.

    What seems to be mind-bogglingly difficult is creating the same setup on my WRT54G. I've tried the standard Linksys firmware and Im unable to even ping devices on the LAN or access them. I've tried openwrt, and i've tried other WRT firmware images - all to no avail.

    When I do tcpdumps on the wireless side of the WRT I can see the ARP requests coming in from the LAN, I can see the replies, but they dont seem to make it back out to the vlan on the WRT that's bridged into the LAN. It's almost as though the bridge is 'broken'.

    Can anyone shed some sort of light or ideas on what I might try - I'm seriously at the point of pulling my hair out in frustration. It's almost as though the device only wants to act as a router - never a simple bridge - which is exactly what I want to avoid as I have a central router/firewall for that already!

    Looking forward to any ideas/suggestions/help that anyone can provide :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice