Recovering a seriously dead WRT54G v1.0

Discussion in 'Cisco/Linksys Wireless Routers' started by josh, Feb 11, 2005.

  1. josh

    josh Network Guru Member

    Hello all,
    last week my trusty wrt54g v1.0 started to continuously reboot after a few days following a custom firmware upload (Alchemy 5.x I think). I tried to downgrade to a previously known good version but the problem didn’t seem to stop. Somewhere in between going back to official firmware via the auto update utility and holding the reset button for 30s the router stopped working completely. I’m posting this in the vain hope that someone else has come across a similar situation and can give me some recommendations.

    Here are the symptoms;
    - When power is supplied, the power and diag lights come on very very briefly (less than 1s) and then go out. Other than that nothing else lights up;
    - No physical link lights on the LAN or WAN ports when plugged in;
    - No WLAN signal;
    - No response to ping to and needless to say therefore tftp is useless as physical link is never established;

    Things I’ve tried so far (which is pretty much everything I could find on the net)
    - Holding reset for 5, 10, 30s or more;
    - As above while plugging in power;
    - The unit has a AMD AM29LV32DB flash chip, tried shorting out pins 15/16 and 16/17 despite probably being the wrong ones but nothing. I couldn’t find any pinouts for this chip anywhere.
    - Removing the mini PCI from the main board, same behavior;

    At this point I’m thinking it may be actual hardware failure, possibly power supply related as I’m pretty much out of ideas to try. I’ve read about the JTAG technique but I think it only applies to v2.0 hw and above if I understand correctly. Open to any suggestions on how to recover life back to my trust linky which seems to have been bricked forever at this point.


  2. Morpheus

    Morpheus Network Guru Member

    try shorting pin 16 to the Antenna socket.
  3. Hadrien

    Hadrien Network Guru Member

    Similar Problem

    I'm going to try to tack my problem onto this thread so as not to create a new one.

    I did quite a few searches but could not find any info on my specific problem.

    I obtained a WRT54G v1.1 from a friend and decided to try to put Alchemy rc5 on it. Well I defaulted the router, then uploaded the BIN file and the WRT54G never came back up. After trying numerous things I finally found info out on the web and here, that if I short out the pin 15,16 on the Intel flash chip that I can flash the formware back to an old one with TFTP. I tried this, and it says the BIN file gets uploaded via TFTP no problem, but even after letting the router sit for 10min or more then rebooting it, I get nothing but a blinking power light. The weird thing is, the unit still responds on, but I get wacky response times.

    I was wondering if there was anything else I could try before attempting the JTAG recovery. My soldering skills are not the best (I would also need to buy a soldering iron and most of the parts) I saw a few JTAG cables on ebay:

    ...and wasn't sure if they would work or not.

    Any other ideas? Thanks in advance guys!

    PS - Sorry to thread jack ya, my problem seemed similar.
  4. josh

    josh Network Guru Member

    Thanks just tried that, stil no joy. I think the bootloader part is toast perhaps, JTAG may be the only possible way at this point. But I haven't read anywhere about JTAG working for v1.0 hw. Any ideas?

  5. Morpheus

    Morpheus Network Guru Member

  6. Morpheus

    Morpheus Network Guru Member

  7. Hadrien

    Hadrien Network Guru Member

    I tired this site as well Morephus. This is what put me in my specific situation. The oddest thing is that no matter how many times I reboot the router, it almost seems stuck in this mode as described on voidmain's site. I can ping and older firmware uploads show as "successful" though tftp but dont seem to "stick"

    Newer firmware gets an error about loading about 90% of the way with TFTP, the power light goes solid and TFTP gets a "No response from server" error with the progress bar stuck around 90%.

    I haven't tried setting my NIC to 10mb half duplex, which I will do here in a few minutes and try uploading a new and old firmware.
  8. Hadrien

    Hadrien Network Guru Member

    Well I revived the WRT54G v1.1. It was most likely luck but I got most of my ideas from here. Here is what I did:

    - Shorted pins 15,16 again so that the router was able to respond to (it was stuck in this mode anyway, which was my problem, but I shorted them again just in case)
    - Flashed the WRT54G with the 1.42.04 firmware from Linksys FTP using TFTP
    - Once the blinking LED went solid I held in the reset button for 30sec and it finally started to blink steadily and thenreset solid again
    - BAM! The router was back and defaulted
    - Since I was feeling adventerous I flashed it with Alchemy 5a and now it works great!

    Thanks again for the ideas guys.
  9. vekken

    vekken Network Guru Member

    WRT54G v1.0 w/AMD flash

    I have the EXACT same problem and josh is the ONLY post that describes it just like mine with the power & diag lights just flashing and going out and then nothing. I've tried shorting the suggested pins, etc... nothing works.

    My router was working fine, I upgraded the firmware to HyperWRT_2.0b4_G and continued to use the router just fine for MONTHS. All of the sudden it just stopped and ALL of the lights on the unit were flashing on and off, on and off. I unplugged it and tried again, same thing with the lights. Eventually this stopped and all I got was the power & diag lights flashing for just a tiny bit when you plug it in and then nothing.

    I was not trying to upgrade the firmware when the problem occurred. This leads me to believe it is a real hardware failure or power supply issue.

    Is there anything else I can try?

  10. pneum

    pneum Guest

    Thanks for the info! I have a WRT54G v1.0, and it froze on me after flashing to the Satori firmware. The diag light stayed on, and I couldn't access it through my browser. I thought it was dead for sure, but following the advice here (and Void Main's uber-helpful pics), I got it breathing again, and reflashed. My router now has a second lease on life.

    For those of you trying this with a v1.0, the flash chip is located under the daughterboard, which pops out easily. I then grounded pin 15 to the ~cm sq ground pad below and to the left of the flash chip. That got it's heart beating again!
  11. noyk

    noyk Guest

    I have the same problem as well. Just an hour or so ago, i was using wireless and lan then it stops working. It's only ever had linksys firmware on it although it's been upgraded a few times. Purchased about 2-3 years ago and has been running fine ever since.
    Why has this happened to so many people so recently!!! Any ideas?
  12. Talljeeper

    Talljeeper Guest

    non intel

    I have a v.1 WITHOUT the intel can I perform this "short" to revive my recently dead 54g.
  13. velocity7

    velocity7 Network Guru Member

    I have exactly the same problem. The router just died for no reason; continuously went on and off. I unplugged it for five minutes, and when I plug it back in, the Power and Diag LEDs blink for less than a second, and then disappear. Now I don't know what to do with the thing. It was using official Linksys firmware (4.00.7 IIRC).
  14. yosoyjay

    yosoyjay Guest

    Similar problem.

    I have a v1 wrt54g that recently died. No LEDs or anything.

    I probed about with a meter and found that none of the chips had any voltage, but there was +5V dc in some parts of the power section of the board.

    I had some guesses as to which components could be bad. I made a jumper to get the +5 to other parts of the board and then I got the same symptoms you described, two LEDs very quickly lights up.

    I'm also getting a high pitched sound that could be a cap, but they show no signs of bulging or any of that nonesense. Could it be a cap?
  15. Corianus

    Corianus Network Guru Member

    WRT54G V1.1

    My WRT recently did the same thing you are all talking about with the lights flashing, or just the diag light. I found that the problem was with the 5 volt, 2 amp power supply. I temporarily hooked the router up to 4 AA batteries and it booted and worked fine till the batts died shortly after. I also tested the power adapter with my volt meter. The meter would read 5 volts, but if I put it under load using a 6v light bulb, it would not work. After this, it suddenly died completely. I found a similar adapter in my basement and tried it. The router works perfectly. All this after I went out and bought a new one. Doh! Anyway, the old power supply is 5 volt, 2 amp. The power supply I have is 6 volt, 1.4 amp. I wanted to know if anyone out there has alot of experience in this field. The new router is 12 volt, 1 amp. So, I have some questions. I have heard that the new router V3 can accept from 5 to 40 volts DC. Is this true? What about my old V1.1? Will I kill it by using the 6V 1.4A supply, or will I lose some signal because it is only 1.4A? I would like to turn this router into a bridge. I put some firmware on it which I downloaded here, and changed the appropraite settings, but I cannot get it to work.
  16. pauldy

    pauldy Network Guru Member

    Chances are you will kill the power supply before you kill the router. Its trivial to add a voltage regulator to most any electronic device. Most consumer electronics have some type of voltage regulation and are able to cope with a range of input voltages. If I remember right the WRT54G has a zeiner diode capable of regulating between ~5-20Volts. With a 6V 1.4A you will have about 8.4W of power and with the original power supply you indicate about 10W of power. So if the router loads to the maximum power output of the power supply chances are you will kill it first. On the other side 12V at 1A provides about 12W giving a little more headroom that the original power supply, this could be why the change was made.
  17. Corianus

    Corianus Network Guru Member

    Power Supply

    So if I use my 12 volt 1 amp supply from the V3 on the V1.1, it should not blow it up?
  18. PCGuru

    PCGuru Network Guru Member

    Re: Power Supply

    I would not run a version 1 on 12 volts! :eek: I don't have a version 1 to check but I would expect that it depends on the power brick for regulation. You may be getting by with the 6 volt, 1.4 amp. brick because it isn't regulated and the voltage is getting pulled low enough to prevent any problems. Later models used post regulators in the unit to drop the voltage of the brick, they also are more power effcient and require less current. If the post regulator is a linear design, you need at least .5 volts overhead for low dropout linear regulators and 3 volts for typical linear regulators, i.e. you will need 5.5 to 8.5 volts minimum to get 5 volts out. Typical linear regulators will work with up to 35 volts input but it will depend on the current requirements and heat sinking. Also, the input filter caps may limit the input voltage to much lower values. If they are using a switching type post regulator, depending on design, it might work with input voltages anywhere from 3 to 30 volts.
    The short answer is replace it with the OEM part if you aren't well versed in power supply design.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice