recovering from bad firmware openwrt-g-code.bin to linksys-c

Discussion in 'Linksys Official Firmware' started by aditya_technologies, Mar 10, 2005.

  1. aditya_technologies

    aditya_technologies Network Guru Member

    Hello Sir
    we are having the well known problem of not being able to recover from a bad firmware.
    The problem goes as follows:
    We had linksys-wrt54g firmware image in our linksys box.We wrote openwrt-g-code.bin onto the original linksys code.bin using boot_wait=on. IT WORKED FINE!!!!!!
    But when we tried writing back the linksys-code.bin over openwrt-g-code.bin then it didn't work. Browsing through the links i found that "if we are not able to ping the box then we should use one of the tricks of shorting the 15/16 pins of flash" but our box was being pinged but we could not access admin browser.So we didn't short the pins.......but we tried writing the linksys-code.bin again on linksys-code.bin and everything started working fine. WE WERE AMAZED as to how did it worked ???????
    We tried testing it again........thinking that the logic may be "if we port same firmware 2wice it works !!!!!!" and the next set of but's came in. We were not able to write the openwrt-code.bin idea why ????? and for that matter not even linksys-code.bin..........
    If you some idea please ping us fast ...........
    waiting for ur replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice