Reduced Bandwidth using Ethernet on FreshTomato/Wifi Not Reduced

Discussion in 'Tomato Firmware' started by Xplorer4x4, Sep 9, 2018.

  1. Xplorer4x4

    Xplorer4x4 LI Guru Member

    I did a clean install of Fresh Tomato yesterday on an ASUS rt-ac56u. It seems my desktop connected via Ethernet is only getting about 50 Mbps download when it should be just over 100 Mbps. I can run a speedtest from an Android phone on WiFi and get speeds over 100Mbps. Why is it my wired connection is half the speed it should be?
  2. pomidor1

    pomidor1 Networkin' Nut Member

    Adwanced/Miscell. ctf on
  3. Xplorer4x4

    Xplorer4x4 LI Guru Member

    This did not fix it.

    Sent from my moto g(6) plus using Tapatalk
  4. koitsu

    koitsu Network Guru Member

    Could be lots of reasons. Almost impossible to cover them all.

    First step above all else: test LAN transfer speeds between the desktop and another LAN desktop. This rules out packet forwarding, QoS, BW Limiter, and a whole other bunch of stuff. The only fabric used in that traffic flow is switching fabric. Be sure to test both directions (sending to another desktop PC, and downloading from another desktop PC); this is especially important to rule out duplex issues (especially if you have NICs which are 100mbit only). Check the PHY link speed in your OS to see what's been negotiated.

    If you have speed problems between LAN PCs, then the problem is likely with link speed or duplex, autonegotiation vendor incompatibilities (yes they exist still even in 2018, and even on gigE links), shoddy Ethernet drivers, a NIC that's crapped out, physical cabling issues, or a firewall on the desktop PC is that is essentially bottlenecking throughput due to excess CPU usage. Narrow it down through troubleshooting (disabling or replacing one thing at a time).

    If transfers between LAN PCs are OK, then that brings into question your settings on the router. You'll need to do a full write-up of all the changes you made from stock/default settings (yes, all). You can exclude giving literal MAC addresses (just use XX:XX:XX etc.), but everything else needs to be provided.

    P.S. -- When you did a "clean install" of FreshTomato, did you do a thorough NVRAM reset afterwards? If not, you should, followed by manually changing all the settings needed. Also, did you use the Config Backup/Restore feature or did you manually set all the settings you want in the GUI? Yes it matters.
  5. Xplorer4x4

    Xplorer4x4 LI Guru Member

    I was on a Toastman build released a few months back. I booted into recovery web ui and flashed back to stock. The oldest stock firmware available on asus website. From there I let the stock firmware do 2 OTA updates. After the final OTA, I rebooted the recovery web ui and I flashed Fresh Tomato Arm. freshtomato-RT-AC56U-ARM-2018.3-AIO-64K.trx I configured the router manually from there.

    For testing sake, I rebooted to recovery, flashed firmware again. From the default configuration, I changed the login password, configured my WiFi Networks and enabled ctf. Otherwise everything else is the default. Speedtest results are still the same. ~75 Mbps download when I should be about 110 Mbps. The results are the same with ctf on and off.

    NOTE: My settings by hand were no different then what I ran in Toastman with no issues. Also only my download is limited. My upload is where it should be about 10+ Mbps.
  6. Xplorer4x4

    Xplorer4x4 LI Guru Member

    Also I do not have another Dekstop or any other laptop anything to test the network besides 2 android smartphones and this desktop. However, I did reboot to recovery, flash stock, upgrade to latest firmware ota. Then flash asuswrt-merlin. Erase NVRAM. Reboot. Still not able to get full download speed. I left all settings stock in merlin for testing, as I did with Fresh Tomato, except the username and password. Even with Merlin the download speed is only hitting about 75-80 Mbps.

    Everything was fine untillI went from Toastman to Stock to FreshTomato.
  7. Sean B.

    Sean B. Network Guru Member

    Have you tried reflashing the Toastman build you were running and checking if your speed returns? If it doesn't, then you have a hardware problem of some sort ( internal with the router, or external such as cabling, power supply, or the client device you're testing with ) or the OEM updates done when you loaded the stock firmware have changed something in the CFE that has altered the performance of the router.
  8. Xplorer4x4

    Xplorer4x4 LI Guru Member

    I finally got around to testing Toastman build and got the same result. I disconnected the router and hooked my desktop right to the modem for diagnostic sake. Turns out to be a problem on my ISP's end. They did over the phone troubleshooting with no luck. They did find some programing errors and corrected it. Problem remained. Tech will be here tomorow to see what the problem is.

    Thanks for the help guys!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice