Refined unbricking process -- my experience may help you

Discussion in 'General Discussion' started by CFD339, Oct 16, 2005.

  1. CFD339

    CFD339 Network Guru Member

    After reading several versions of the unbricking process, mostly involving an attempt to connect pin 16 on the flash rom to one of many other things (depending on who's instructions you follow) I realized all any of these were doing was grounding out pin 16.

    Folks, the easiest ground to get hold of is the external metal around the antenna connector. So many smart people are spending so much time hunting for a ground, when all should know that the outside of that connector would OF COURSE be grounded.

    That makes a really easy place to tag an alligator clip or one end of a wire. If you want pictures posted, respond to this and I'll be happy to send them.

    For what it's worth, I have a WRT-54g version 4.2 and have it running now using hyperWRT with WDS at 81mw. If anyone needs, I can describe the whole process. I found sveasoft alchemy and satori didn't work with the version 4.2 of WRT-54G, that the White Russion RC did seem to but I didn't feel like getting that into the configuration, that DD-WRT bricked the thing repeatedly in both v22 and v23 beta. I'm quite happy with HYPERWRT though.
  2. jagboy

    jagboy Network Guru Member

    if you can explain your debrick method i will be more than happy to get this in the debrick guide.....(see my sig) and pictures would be great...i am always looking for new ways of debricking......
  3. CFD339

    CFD339 Network Guru Member

    Will post more -- here's the q & d

    No time right now but I'll follow up with details.

    Q&D is to just jumper pin 16 to anything with a ground during power-up. Easiest ground is the outside ring of the antenna connector. Its big and easy to either clip with an alligator clip or jam a probe into by wedging it against the inner plastic ring.

    In linux, its easy enough to ifconfig a secondary address on a port to the same network then start a tftp upload with rexmt and timeout 60.

    More later.

  4. crawdaddy

    crawdaddy Network Guru Member

    I think I super-bricked my router. When I tried the shorting tricks I got 1 ping through before it went to timing out again. Before I started trying to debrick it through the shorting methods, the router appeared to be fine according to the lights, but there was no DHCP or anything. I guess next step is to try the JTAG, but I have no clue how to do it...
  5. CFD339

    CFD339 Network Guru Member

    No need to do the jtag thing.

    get your linux command prompt going, set up your tftp client with

    rexmt 1
    timeout 60
    mode octal

    Unplug the router, then with all those set in tftp, type the

    put firmware.bin

    command and let it keep trying while you plug in the router. When you see it send packets, you'll know it worked.
  6. CFD339

    CFD339 Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice