Remote Access

Discussion in 'Tomato Firmware' started by jetusus, Sep 11, 2007.

  1. jetusus

    jetusus LI Guru Member

    I've got a question. just wondering I've been having problems accessing my router remotely. I've enabled remote access. And whilst i'm remotely away i believe I would enter http://XXX.XXX.X.XX:8080. the x represents routers ip address and the 8080 would be the port. And nothing happens. usually a logon screen would/should pop up and allow you to enter your user id and password. This has been and issue. I have tried it with another persons router using the original firmware for Linksys wrt54g and was successful. Any Ideas?
  2. GeeTek

    GeeTek Guest

    Put an "S" in your HTTP ?
  3. rcordorica

    rcordorica Network Guru Member

    Yup! I made the same mistake before. :halo:
  4. danix71

    danix71 LI Guru Member

    It depends.

    Attached Files:

  5. ifican

    ifican Network Guru Member

    I would say then try another port, maybe your isp is blocking 8080.
  6. jetusus

    jetusus LI Guru Member

    Thanks in advance for the help.I added the "s" and changed the port to 8890(not sure if it isalso being block,How do i check?) and made sure i changed the config settings. Still no logon screen. :(
  7. MIKE_

    MIKE_ Guest

    router or gateway mode

    i have had the same problem while running tomato firmware

    try setting your linksys to gateway mode...

    in tomato:
    - routing

    Mode -> router || gateway
  8. jetusus

    jetusus LI Guru Member

    Router appears to be already set to gateway mode and still no luck. :(
  9. danix71

    danix71 LI Guru Member

    First thing first. You must use a DDNS (i use one that is recognised by tomato 1.07, even if I don't have a dinamic adress till now but a static one). Okee. Then, set the port 80 in remote administration (http or https -try first http (I know is not secure) - ONLY FOR A TRY, DOESN'T SUPPOSE TO REMAIN PERMANENT). Ok. THEN TRY !
    You should put in any of the browsers, the adress of the router not mentioning the port, but only the adress. What is the result ?
  10. Low-WRT

    Low-WRT LI Guru Member

    Just to be clear, you say the "x represents the routers ip address", the x should represent the WAN IP address.
    When I had a static ip, I did it just like you say and it worked fine...maybe try a completely different port, like 1234.
    I don't think it matters, but try rebooting the router.
  11. danix71

    danix71 LI Guru Member

  12. danix71

    danix71 LI Guru Member

    How can access a SMB/CIFT/FTP server (a network-hdd, NAS) inside a local network ? Inside the network I can access it through http://storage/ and I have enable ftp-server. From the Internet I can access the Tomato 1.07 interface through DDNS-given address and the port that I have chosen for this job: Oke. Now, what address should I put to access the ftp-server from the local LAN. And what port-forwarding should I have in the router ? Many thanks!
  13. paped

    paped LI Guru Member

    Just as a double check and referring to my config that appears to work OK in Administration -> Admin Access you have Https set in the "Web Admin - remote access" section (second prompt down) and 8890 as the port. Also further down the page there is a section called "Remote web/SSH admin restriction" the allowed IP address box at least during testing should be empty which allows all connections from all hosts? If this is how yours set-up is then the connection from a tomato point of view should work by using https://yourISPassignedIPaddress:8090. The only other thing I can think of as I had a similar problem with a friends router is what type of modem does the WRT connect through to the internet, by type I mean it is a true modem or an ADSL router setup in bridge mode? As if it is a router you may have to added port forwarding into it so that the traffic to port 8090 is forwarded from the internet to your WAN ports IP address on the WRT i.e. it could be your modem/router that is blocking the traffic before it reaches the WRT?

    Also you could try using the true https port of 443 just in case there is a firewall between your remote location and the WRT that is configured up to block https traffic on a none native ports i.e. not 443. Some companies do this, say if your are trying to access it from your work.
  14. danix71

    danix71 LI Guru Member

    I intend to keep it simple explaining once again.
    My router is controlled externaly (not from LAN but from Internet) through https://myISPassignedIPaddress:8000 or from https://myDDNSadress:8000 . I've got a NAS in the LAN, with FTP server enabled. How can I use the NAS (network HDD) from the Internet ? I know that https is more secure but I want it http.

    Attached Files:

  15. jonmccurry

    jonmccurry LI Guru Member

    You can go to an internet website and enter the port number you specified in the remote access page of tomato to see if things on the internet can "see that open port" on the tomato router. If cannot then something is preventing access to that port for some reason, possibly your ISP blocking traffic on that port, or there is another router in front of the tomato router (like one built-into Netopia DSL modems sometimes) that may need a port forward setup as well or may need to have the mode changed a little.

    As far as the "Allowed IP Address" box in tomato that is indeed to restrict remote access to only allow the specified IP address, addresses, or address range(s) to connect to your router from the internet. Just to keep things simple during testing I'd leave it blank so that tomato will allow anything on the internet to connect to your tomato router.
  16. jonmccurry

    jonmccurry LI Guru Member

    Also make sure you are using the tomato router's WAN IP address when you are outside on the internet trying to connect back to your tomato router remotely instead of your tomato router's LAN (internal) IP address (which the default of was

    Once you have your tomato router's WAN IP address you also need to confirm this is the public IP address as the internet sees you so go to or and both of those sites will tell you your public (internet) IP address your internet connection is using. Both these websites will show the same IP address, and that should match what your tomato router shows as its WAN IP address. If it does and the port isn't blocked, then you should be able to access it remotely. If tomato's WAN IP address is different that the IP listed at those 2 websites then there is another device between your tomato router and the internet, most likely a NATing/PATing device like one built into some modems (like lots of Netopia DSL modem/routers).

    Hope that helps.
  17. danix71

    danix71 LI Guru Member

    Done already (port fwd-ing) for days now. :)

    Attached Files:

  18. hpsmartyz

    hpsmartyz LI Guru Member


    knowing that the thread is about remote access, I have one question:
    I have disabled remote access in Tomato 1.07, (and set local access to only be https
    and allowed wireless access) but from my laptop, (connected to my LAN through
    wireless) if I type https://WAN IP@ I get the login/pass screen of my router (after
    having agreed for the certificate).
    Is this normal knowing that I disabled remote access?

    just tried another thing. I enable http and https local access and now I can access
    the router both in http and https with WAN IP.

    many thanks
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice