Repeater Mode cannot assign IP - Tenda AC18

Discussion in 'X-WRT - OpenWRT Firmware' started by zigzagbooms, Jul 24, 2018.

  1. zigzagbooms

    zigzagbooms New Member Member

    Hey guys, first time poster here so hopefully I don't mess with the rules.

    Setup:

    Primary router - Huawei HG659b
    My router - Tenda AC18 with XWRT Firmware 380.67_x7.6

    My router is in repeater mode, connected to the 5g wifi of the primary router, extending the signal of the primary to fill my house.

    Issue:
    Up until yesterday everything was working fine. Now it's not and I can't connect to the wifi on my router. According to my Samsung S7, it refuses to assign an ip address. I know that DHCP is turned off in repeater mode and that the primary router assigns the IP in this case, but for some reason this just isn't happening.

    When I access the Merlin dashboard on my router via the primary router's wifi, I can see that the Parent AP status is set to connected. I can also successfully run a ping to google in Network Tools.

    But NOTHING will connect to the wifi my router is putting out.

    I super appreciate any help/thoughts you may have. Thanks heaps!
     
  2. Sean B.

    Sean B. LI Guru Member

    Have you tried simply rebooting the routers? Both shutdown, primary up first, then secondary?
     
  3. zigzagbooms

    zigzagbooms New Member Member

    Thanks for the reply Sean - Yup. Many times. Just tried it once more and no dice :( Any other thoughts?
     
  4. Onee-chan

    Onee-chan Network Newbie Member

    Try installing the latest version X7.9, maybe solve the problem:
    RT-AC68U v380.70 X7.9 MD5:5601BA1DE4F608EB99BF2CB1E7CC460D

    After installing the latest version do a factory reset and do not use backup, configure the router from scratch.
    • Administration -> Restore/Save/Upload Setting -> Factory default: Restore

    Information: Guide of Tenda AC18 to RT-AC68U (read the posts)
     
    Last edited: Jul 25, 2018
  5. Sean B.

    Sean B. LI Guru Member

    To confirm:

    That statement is saying you can access the GUI of the secondary router via a wifi connection to the primary router?

    Try setting a static IP address on a wireless client. One that is within the correct subnet and set the gateway as the IP of your primary router. IE: When it was working, if connecting to the wifi of the secondary router would have gotten an IP of 192.168.1.x, set an IP of something like 192.168.1.225. Try connecting to the secondary router wifi and see if that device has any connectivity. This step will give clues as to which router is causing the problem.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice