Discussion in 'HyperWRT Firmware' started by evil-doer, Feb 10, 2006.

  1. evil-doer

    evil-doer Network Guru Member

    ..PLEASE firmware authors. take some time and try to figure out exactly why this router sucks with p2p programs. now before people start bitching me out, please listen.

    ive tried 3 different kinds of firmware, default, dd-wrt, and now hyperwrt-thibor. ive done extensive research on startup scripts and settings on how to cure this problem. ive also lowered my connection settings on my p2p apps WAY down from the levels they were at (that were working perfectly fine with other routers, i might add!). so whats the deal here? i dont run emule very often but i am right now, getting a few files, and my speeds are atrocious. im not talking about the download speed in emule only, even loading the web interface to the router it takes 5-10 seconds per page to load! everything has slowed to a crawl. yet the total bandwidth is 30 k/s.

    where is this bottleneck? is it curable? can i help in any way?

    thank you very much.
  2. purephase

    purephase Network Guru Member

    Have you tried Thibor13c? I've been using it since it's initial release and I haven't had any P2P issues at all (and this is with VOIP).

    Earlier versions of the firmware (12 and below, plus DD-WRT, openwrt, and sveasoft) all had issues with tcp flooding software (in my case it was BitTorrent).

    The problem has disappeared for me. It was even more prominent because my primary phone line is a VOIP service so, believe me, I notice any connectivity and QoS issues immediately.
  3. Lazybones

    Lazybones Network Guru Member

    Your router is most likely low on memory is it a G or a GS and what version?

    In DD-WRT v23 you can use the following settings on a GS v1 - v3 not sure what would be good for a G or the gimped v4GS:

    Maximum Ports : 4096
    TCP Timeout (s): 120
    UDP Timeout (s): 120

    And when you change firmware MAKE SURE you do a full HARD RESET.. If settings remain between firmware changes they can do all sorts of odd things.
  4. evil-doer

    evil-doer Network Guru Member

    this is the startup script:

    i do everything by the book, reset to defaults before and after flashing, reset, etc.

    my router is the wrt54gs v2
    im running thibor 13c
  5. Lazybones

    Lazybones Network Guru Member

    Not sure what would be causing your problems.. We are heavy p2p users in my house.. I had up three users all running Bitorrent, or eDonkey almost 24/7 and on top of that I have VOIP... I like DD-WRT becuase you don't need to mess with the scripts, its all in the Web UI.

    Not 100% sure of the syntax but it looks like you have the same idea in your startup script.. Just thought I would post what worked for me.

    When you say total bandwidth is 30 k/s is that kilobits or kiloBytes?
  6. tokke

    tokke Network Guru Member

    Try to cap your upload to 6kb and see if this helps.
    I also had slow speeds with bittorrent but the problem is not the router but my cablemodem. My cablemodem is half duplex so capping the upload did the trick for me.

    Best regards

  7. NateHoy

    NateHoy Network Guru Member

    evil-doer -

    Your problem sounds like poorly-configured QoS to me.

    On a computer hooked directly to your Internet connection (no routers, no other computers, no applications using the Internet) run a speed test (I like but there are lots of them).

    Go into the Router's QoS settings (Applications and Gaming / QoS), switch the upstream to MANUAL, and enter 90% of the UPLOAD number in kbps you get from whatever speed test site you want.

    For example, my 256k upstream connection maxes out at a real tested upstream of about 220k, so I set 195k as my upstream.

    Next, go to the TCP/IP port priorities and set whatever ports you use for P2P to "LOW" and set all the predefined fields to MEDIUM, like so:


    Using this configuration, and setting my Vonage VoIP adapter to "HIGHEST", I can make Vonage calls, use my other computer-based VoIP line, surf the web, run VPN connections, do FTP uploads, and keep my P2P sessions running uncapped 24/7, and my surfing speeds are always acceptable.
  8. evil-doer

    evil-doer Network Guru Member

    its not the cablemodem. as i said ive been able to max out the connections with other routers and still works fine.

    im not using qos. i use very low upload settings because my isp charges extra money if i go over my cap per month.
  9. dvaskelis

    dvaskelis Network Guru Member

    I saw a similar experience at a friend's home. Bypass the router to see if it changes anything, it didn't for him. He found out later that his ISP started to shape traffic to make p2p programs very low priority.

    I think you'll find that most people are fine with p2p with the current third-party Linksys firmware. It worked fine for me without QoS, but it definitely made the overall experience better when I configured QoS: think like surfing the web while using p2p or talking on Skype.
  10. evil-doer

    evil-doer Network Guru Member

    im sorry but im bumping this back up because this is still a major issue. im thinking it has more to do with emule than bittorrent. ive read that some routers (dlink) can crash when you do searches on emule. i think thats where its "killing" my linksys too. try doing a couple of searches in emule and check your speeds. im trying to transfer a file over my 100mbit wired network and its going VERY VERY slow. the network utilization is maybe 2%. everything slows way the hell down. and this is all intranet here.
    its now 15-20 minutes after i closed emule and the file is still transfering at this incredibly slow rate between my two wired computers. the 500 meg file im transfering is only half moved!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice